Tworzenie obrazu ISO z bootowalnym środowiskiem WIMPE

(duchu) #1

korzystam z tego artykułu ale gdy dojde do

oscdimg -n -h -bC:\WinPE\etfsboot.com C:\WinPE\ISO C:\mojewinpe.iso

to wyskakuje mi 8e1f8b2256eaa2d14da43c172fa54d415461_min.jpg

fakt że omijam to

imagex /mountrw C:\WinPE\winpe.wim 1 C:\WinPE\mount

imagex.exe /unmount /commit C:\WinPE\mount

bo mi ten program nie potrzebny chce dodać total comandera i kopiuje go ręcznie do WinPE do katalogu mount

potem zastępuje plik boot.wim plikiem winpe.wim i to mi wyskakuje jak robie według tego artykułu robie coś źle???

(Kmrb) #2

Dokładnie nie wiem, bo nie znam tego polecenia “oscdimg”,

ale jako parametry powinieneś chyba rozdzielić spacją to “-bC:\WinPE\etfsboot.com

na “-b C:\WinPE\etfsboot.com

(duchu) #3
Należy zauważyć, że pomiędzy argumentem -b a ścieżką nie ma spacji! Wykonanie tego polecenia spowoduje utworzenie obrazu ISO ze środowiskiem WinPE w lokalizacji podanej w ostatnim parametrze.

z tego artykułu więc musi byc chyba dobrze

(Kmrb) #4

Rzeczywiście - przepraszam.

WinPE kiedyś robiłem ale dawno temu (jakies 2 lata).

Jeśli chodzi o dodawanie programów to trzeba je było umieścić w gotowych (pustych + plik menu)

katalogach i zarejestrować użycie tego programu w menu głównym.

Po wielu próbach (nagrania oczywiście na CD-RW) jakoś to działało mino wielu błędów

np. brak czasami polskich fontów.

WinPE chciałem tylko używać do ratowania XP, czyli dostęp do NTFS.

Na szczęście teraz nie mam takiego problemu odkąd wyszedł UBUNTU 7.10 PL (Live CD)

(Hashimoto) #5

Nie rozumiem…

Ja postępowałem zgodnie z artykułem i wszystko (prawie wszystko) poszło normalnie. Miałem problem ze skopiowaniem totalcmd ale przy pomocy polecenia copy udało się.

copype x86 c:\winpe

imagex /mountrw c:\winpe\winpe.wim 1 c:\winpe\mount

Przekopiowanie total commandera do zamontowanego obrazu (na stronie Microsoft’u pokazany był sposób przeciągnięcia między oknami ale ja skorzystałem tym razem z polecenia dos):

copy D:\programy\totalcmd\totalcmd.exe c:\winpe\mount\windows\system32

Odmontowanie:

imagex.exe /unmount /commit c:\winpe\mount

Najważniejsze chyba polecenie zastępujące obraz (wcześniej podmieniałem obraz metodą usuń/wklej):

copy c:\winpe\winpe.wim c:\winpe\iso\sources\boot.wim /y

Utworzenie obrazu:

oscdimg -n -h -bc:\winpe\etfsboot.com c:\winpe\iso c:\winpe\winpe.iso

http://forum.techit.pl/viewtopic.php?f=4&t=76

(duchu) #6

a czy nie podał byś linku bym mógł ściągnąć już WIMPE z TC ???

z góry dziękuje

(Hashimoto) #7

Nie wiem czy to jest zgodne z licencją, ponieważ tak naprawde jest to okorojona Vista. Wiem, że na torrentach jest winpe.

Z drugiej strony nie wiem z czym masz problem - podałem Ci wszystkie komendy, kopiujesz je po kolei i wklejasz do lini komend WAIK (zmieniasz tylko komendę dotyczącą przekopiowania totalcmd - podajesz swoją ścieżke gdzie się on znajduje; możesz też poprostu przekopiować totalcmd pomiędzy oknami do katalogu Program Files w zamontowanym winpe).

PS WinPE a nie WIMPE.

Pozdrawiam.