[Ubuntu 10.04] Błąd konfiguracji sendmail


(Tazik) #1

Chciałem zainstalować program Draftsight, a on ciągnie w zależnościach m. in. sendmail. Jednak po próbie instalacji sendmaila, Synaptic podał następujący komunikat:

Selecting previously unselected package libdb4.7.

(Odczytywanie bazy danych ... 99919 files and directories currently installed.)

Rozpakowanie libdb4.7 (z .../libdb4.7_4.7.25-9_i386.deb) ...

Selecting previously unselected package libdirectfb-extra.

Rozpakowanie libdirectfb-extra (z .../libdirectfb-extra_1.2.8-5ubuntu2_i386.deb) ...

Selecting previously unselected package sendmail-base.

Rozpakowanie sendmail-base (z .../sendmail-base_8.14.3-9.1ubuntu1_all.deb) ...

Selecting previously unselected package sendmail-cf.

Rozpakowanie sendmail-cf (z .../sendmail-cf_8.14.3-9.1ubuntu1_all.deb) ...

Selecting previously unselected package sendmail-bin.

Rozpakowanie sendmail-bin (z .../sendmail-bin_8.14.3-9.1ubuntu1_i386.deb) ...

Selecting previously unselected package sensible-mda.

Rozpakowanie sensible-mda (z .../sensible-mda_8.14.3-9.1ubuntu1_i386.deb) ...

Selecting previously unselected package sendmail.

Rozpakowanie sendmail (z .../sendmail_8.14.3-9.1ubuntu1_all.deb) ...

Przetwarzanie wyzwalaczy dla man-db...

Przetwarzanie wyzwalaczy dla ureadahead...

ureadahead will be reprofiled on next reboot

Konfigurowanie libdb4.7 (4.7.25-9) ...

Konfigurowanie libdirectfb-extra (1.2.8-5ubuntu2) ...

Konfigurowanie sendmail-base (8.14.3-9.1ubuntu1) ...

groupadd: cannot lock /etc/gshadow; try again later.

addgroup: `/usr/sbin/groupadd -g 115 smmta' zwrócił kod błędu 10. Kończenie.

dpkg: błąd przetwarzania sendmail-base (--configure):

podproces zainstalowany skrypt post-installation zwrócił kod błędu 1

Konfigurowanie sendmail-cf (8.14.3-9.1ubuntu1) ...

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie sendmail-bin:

sendmail-bin zależy od sendmail-base; jednakże:

  Pakiet sendmail-base nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania sendmail-bin (--configure):

problemy z zależnościami - pozostawiony nieskonfigurowany

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie sensible-mda:

sensible-mda zależy od sendmail-bin | mail-transport-agent; jednakże:

  Pakiet sendmail-bin nie jest jeszcze skonfigurowany.

  Pakiet mail-transport-agent nie jest zainstalowany.

  Pakiet sendmail-bin dostarcza mail-transport-agent, ale nie został jeszcze skonfigurowany.

dpkg: błąd przetwarzania sensible-mda (--configure):

problemy z zależnościami - pozostawiony nieskonfigurowany

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie sendmail:

sendmail zależy od sendmail-base; jednakże:

  Pakiet sendmail-base nie jest jeszcze skonfigurowany.

sendmail zależy od sendmail-bin; jednakże:

  PakietNo apport report written because the error message indicates its a followup error from a previous failure.

                                  No apport report written because the error message indicates its a followup error from a previous failure.

                                                            No apport report written because MaxReports is reached already

                                           sendmail-bin nie jest jeszcze skonfigurowany.

sendmail zależy od sensible-mda; jednakże:

  Pakiet sensible-mda nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania sendmail (--configure):

problemy z zależnościami - pozostawiony nieskonfigurowany

Przetwarzanie wyzwalaczy dla libc-bin...

ldconfig deferred processing now taking place

Wystąpiły błędy podczas przetwarzania:

sendmail-base

sendmail-bin

sensible-mda

sendmail

E: Sub-process /usr/bin/dpkg returned an error code (1)

Instalacja pakietu nie powiodła się. Próba odtworzenia:

Konfigurowanie sendmail-base (8.14.3-9.1ubuntu1) ...

groupadd: cannot lock /etc/gshadow; try again later.

addgroup: `/usr/sbin/groupadd -g 115 smmta' zwrócił kod błędu 10. Kończenie.

dpkg: błąd przetwarzania sendmail-base (--configure):

podproces zainstalowany skrypt post-installation zwrócił kod błędu 1

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie sendmail-bin:

sendmail-bin zależy od sendmail-base; jednakże:

  Pakiet sendmail-base nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania sendmail-bin (--configure):

problemy z zależnościami - pozostawiony nieskonfigurowany

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie sensible-mda:

sensible-mda zależy od sendmail-bin | mail-transport-agent; jednakże:

  Pakiet sendmail-bin nie jest jeszcze skonfigurowany.

  Pakiet mail-transport-agent nie jest zainstalowany.

  Pakiet sendmail-bin dostarcza mail-transport-agent, ale nie został jeszcze skonfigurowany.

dpkg: błąd przetwarzania sensible-mda (--configure):

problemy z zależnościami - pozostawiony nieskonfigurowany

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie sendmail:

sendmail zależy od sendmail-base; jednakże:

  Pakiet sendmail-base nie jest jeszcze skonfigurowany.

sendmail zależy od sendmail-bin; jednakże:

  Pakiet sendmail-bin nie jest jeszcze skonfigurowany.

sendmail zależy od sensible-mda; jednakże:

  Pakiet sensible-mda nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania sendmail (--configure):

problemy z zależnościami - pozostawiony nieskonfigurowany

Wystąpiły błędy podczas przetwarzania:

sendmail-base

sendmail-bin

sensible-mda

sendmail

Co z tym fantem zrobić? Jest jakiś sposób żeby sendmail się automatycznie skonfigurował po instalacji?

Poprzednio gdy miałem Linux Mint 9 i Ubuntu 10.04, wszystko przy instalacji poszło bez problemu. Teraz, gdy po kolejnej zmianie systemu wróciłem znowu do Ubuntu, jest jak opisałem. Czy może to mieć związek z tym że wywaliłem network-manager'a?

EDIT: problem rozwiązany. Wystarczyło usunąć z /etc wszystkie pliki z gshadow w nazwie i instalacja ruszyła.