Ubuntu 10.10 - brak spolszczenia po ostatniej aktualizacji


(wojownik) #1

witam dziś rano po uruchomieniu Ubuntu 10.10 spotkała mnie niespodzianka w postaci niepolskiego menu - mimo że w opcjach(administracja - języki ) zaznaczony jest język polski - bardzo proszę o rozwiązanie tego problemu

-- Dodane 31.03.2011 (Cz) 10:50 --

w programach - np gimp też wszystko po angielsku - nie jest to jakis nie wiadomo jaki problem ale jestem polakiem i chce mieć całość w moim ojczystym języku - nie wiem co tu się porobiło :frowning:


(system) #2

w konsoli wpisz

sudo apt-get install language-pack-gnome-pl


(Abecikxp) #3

Też walcze z tym problemem ale z tego co widze to nowa aktualizacja przyniosła ten problem , po jej instalacji też mam to samo.


(wojownik) #4

tak pamiętam coś się aktualizowało ale nie wiem co zaspany bylem -

i co teraz :frowning:


(antiferno) #5

a masz włączone jakies aktualizacje dodatkowe tzn proponowane ? bo ja robiłem tylko główną i nie mam takich cyrków


(system) #6

to najpierw odinstluj

sudo apt-get purge language-pack-gnome-pl

a potem jeszcze raz

sudo apt-get install language-pack-gnome-pl


(roobal) #7

A od czego masz /var/log/apt/history.log? :wink: Spróbuj usunąć całkowicie język angielski z systemu (language-pack-gnome-en).

Pozdrawiam!


(wojownik) #8

roobal - pierwsze co zrobiłem to usunąłem j. angielski z systemu - nadal menu jest po ang. odinstalowałem jeszcze raz język polski i ponownie zainstalowałem i to samo .

Antiferno ja też robiłem to z głowa zaznaczyłem aktualizacje proponowane przez Ubuntu w managerze aktualizacji - nie dawałem rep z niewiadomo skąd - jak mówisz ,że nie robiłem tego z głowa to aż ręce opadają

problem nadal jest

abecikxp - zadziałałeś coś ? jest u Ciebie już ok ?


(dragonn) #9

Pokażcie wynik:

locale

I

sudo locale-gen

(Ernestyna7) #10
locale: Cannot set LC_CTYPE to default locale: No such file or directory

locale: Nie mo?na ustawi? LC_ALL na domy?ln? lokalizacj?: Nie ma takiego pliku ani katalogu

LANG=pl_PL

LANGUAGE=pl_PL:en

LC_CTYPE="pl_PL"

LC_NUMERIC="pl_PL"

LC_TIME="pl_PL"

LC_COLLATE="pl_PL"

LC_MONETARY="pl_PL"

LC_MESSAGES=pl_PL.UTF-8

LC_PAPER="pl_PL"

LC_NAME="pl_PL"

LC_ADDRESS="pl_PL"

LC_TELEPHONE="pl_PL"

LC_MEASUREMENT="pl_PL"

LC_IDENTIFICATION="pl_PL"

LC_ALL=

-- Dodane 31.03.2011 (Cz) 21:05 --

Generating locales...

  en_AG.UTF-8... up-to-date

  en_AU.UTF-8... up-to-date

  en_BW.UTF-8... up-to-date

  en_CA.UTF-8... up-to-date

  en_DK.UTF-8... up-to-date

  en_GB.UTF-8... up-to-date

  en_HK.UTF-8... up-to-date

  en_IE.UTF-8... up-to-date

  en_IN.UTF-8... up-to-date

  en_NG.UTF-8... up-to-date

  en_NZ.UTF-8... up-to-date

  en_PH.UTF-8... up-to-date

  en_SG.UTF-8... up-to-date

  en_US.UTF-8... up-to-date

  en_ZA.UTF-8... up-to-date

  en_ZW.UTF-8... up-to-date

  pl_PL.UTF-8... up-to-date

Generation complete.

(dragonn) #11

I coś to nie gra, bo powinno wyglądać tak:

LANG=pl_PL.UTF-8

LC_CTYPE="pl_PL.UTF-8"

LC_NUMERIC="pl_PL.UTF-8"

LC_TIME="pl_PL.UTF-8"

LC_COLLATE="pl_PL.UTF-8"

LC_MONETARY="pl_PL.UTF-8"

LC_MESSAGES="pl_PL.UTF-8"

LC_PAPER="pl_PL.UTF-8"

LC_NAME="pl_PL.UTF-8"

LC_ADDRESS="pl_PL.UTF-8"

LC_TELEPHONE="pl_PL.UTF-8"

LC_MEASUREMENT="pl_PL.UTF-8"

LC_IDENTIFICATION="pl_PL.UTF-8"

LC_ALL=

Spróbuj coś takiego dopisać do .bashrc:

export LANG=pl_PL.UTF-8

export LC_CTYPE="pl_PL.UTF-8"

export LC_NUMERIC="pl_PL.UTF-8"

export LC_TIME="pl_PL.UTF-8"

export LC_COLLATE="pl_PL.UTF-8"

export LC_MONETARY="pl_PL.UTF-8"

export LC_MESSAGES="pl_PL.UTF-8"

export LC_PAPER="pl_PL.UTF-8"

export LC_NAME="pl_PL.UTF-8"

export LC_ADDRESS="pl_PL.UTF-8"

export LC_TELEPHONE="pl_PL.UTF-8"

export LC_MEASUREMENT="pl_PL.UTF-8"

export LC_IDENTIFICATION="pl_PL.UTF-8"

(wojownik) #12

mój wynik

=

-- Dodane 31.03.2011 (Cz) 21:56 --


(dragonn) #13

Wygląda na podobny problem, próbowałeś tego co podałem post wyżej?


(Ernestyna7) #14

Żebym to ja wiedział jak to dopisać, dopiero co się przesiadłem z windowsa, może kolega wojownik dopisze i powie czy pomogło.


(dragonn) #15

bergenbrau otwórz terminal i wpisz:

gedit .bashrc

Otworzy ci się edytor tekstu z otwartym plikiem, na samym jego końcu dopisujesz to co podałem.


(Ernestyna7) #16

Po wklejeniu do terminala pojawia się komunikat

(process:5247): Gtk-WARNING **: Locale not supported by C library.

	Using the fallback 'C' locale.

potem otwiera się puste okno o nazwie " .bashrc"

dopisałem restart i dalej bez zmian.

Dodam jeszcze że w moim przypadku wchodzac do katalogu domowego pojawiły się nowe katalogi (dokumenty,obrazy,video,pobrane,publiczny, pulpit, szablony) lecz w języku angielskim i system korzysta jakby z nich innymi słowy utworzył sobie nowy profil obok tego polskiego.


(wojownik) #17

rano zrobiłem tak jak radziłeś ale nie mogłem pisać bo do pracy leciałem - niestety u mnie dokładnie tak samo jak u kolegi - i te katalogi też wszystko identycznie menu dalej angielskie


(Karoldeperas) #18

w konsoli/terminal wklejamy

"sudo gedit /etc/default/locale"

podajemy hasło

podmieniamy wpis

LANG=pl_PL.UTF-8

LC_CTYPE="pl_PL.UTF-8"

LC_NUMERIC="pl_PL.UTF-8"

LC_TIME="pl_PL.UTF-8"

LC_COLLATE="pl_PL.UTF-8"

LC_MONETARY="pl_PL.UTF-8"

LC_MESSAGES="pl_PL.UTF-8"

LC_PAPER="pl_PL.UTF-8"

LC_NAME="pl_PL.UTF-8"

LC_ADDRESS="pl_PL.UTF-8"

LC_TELEPHONE="pl_PL.UTF-8"

LC_MEASUREMENT="pl_PL.UTF-8"

LC_IDENTIFICATION="pl_PL.UTF-8"

LC_ALL=

zapisujemy. restart. powinno zadziałać.

U mnie na dwóch maszynach zadziałało.

Polecam http://ubuntu.pl/forum/

Jeśli ja dałem rade to znaczy że to jest proste:)

Pozdrawiam.


(Abecikxp) #19

działa :))


(wojownik) #20

poszło :slight_smile: thx