Ubuntu 10.10 - Nie chce instalować aplikacji z repozytorium


(Jarek Zakrzewski1) #1

Mam pewien problem, jestem początkującym urzytkownikiem ubuntu a sam problem tkwi w tym że jak chce zainstalować jakąś aplikacje z repozytorium to wywala mi błąd:

"Wygląda to na błąd oprogramowania w aptdeamon, oprogramowaniu pozwalającym na instalowanie/usuwanie oprogramowania i przeprowadzania innych zadań związanych z zarządzaniem pakietami. Proszę zgłosić ten błąd na stronie http://launchpad.net/aptdaemon/+filebug i spróbować ponownie."

Szczegóły:

"Traceback (most recent call last):

File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 769, in simulate

return self._simulate_helper(trans, status_path)

File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 948, in _simulate_helper

return depends, status, self._cache.required_download, \

File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download

pm.get_archives(fetcher, self._list, self._records)

SystemError: E:I wasn't able to locate file for the liblog4j1.2-java package. This might mean you need to manually fix this package."

Kompletnie nie wiem o co w tym chodzi więc proszę o pomoc :smiley:


(Hard Vard) #2

przez co instalujesz soft?

pokaż cat /etc/apt/sources.list


(Colzen Lan) #3

Działają u ciebie konsolowe narzędzia apt-get, aptitude ? Jeśli tak to przeinstaluj tą graficzną nakładkę do instalowania programów z repozytorium.


(nintyfan) #4

Takiego błędu nie udało mi się odtworzyć. Nie wiem, jak wywołać SyntaxError z pełnym śladem. U mnie składnia jest chyba sprawdzana przy uruchamianiu.


(Jarek Zakrzewski1) #5

Taaa, początkowemu tak możecie móić a ja kompletnie nie wiem o co biega.

@Hard_vard - Wpisałem to w Terminalu i wywaliło, że nie ma takiej ścieżki/pliku

@teletubies1 - Wpisałem apt-get w Terminalu i wyskoczyła mi jakaś pomoc i komendy, to znaczy, że działa?

Po wpisaniu aptitude wyskoczył mi taki oto przykład jak mam tą komendę wykorzystać.

sudo apt-get install <- To ostatnie to ma być ścieżka do pakietu? Czy nazwa z jakiejś bazy pakietów?

Czasami działa instalowanie a czasami nie. Nie chodzi tu już o same repozytorium tylko pliki z rozszeżeniem .deb :smiley:


(Jusko) #6

Poszukałbym tej paczki w repo i sprawdził czy mogę ją przeinstalować. A jak nie z repo, to ręcznie: http://packages.ubuntu.com/maverick/liblog4j1.2-java

Wyskoczyły Ci możliwe parametry i pewnie ogóle info o apcie. Nic wielkiego.

Co ma związek z czym? Graficzna nakładka to tylko nakładka na te narzędzia. Wszystko i tak przechodzi przez apta/dpkg.

za wybrany_pakiet podstaw nazwę programu. Jak chcesz zainstalować coś spod konsoli (lokalny pakiet) to klepiesz dpkg -i /ścieżka_do_pakietu.


(marcin82) #7

@NiceZakiCJ

Zmieniałeś jakieś wpisy w pliku: /etc/apt/sources.list? Jeśli dodawałeś nieoficjalne repozytoria - to może powodować problem z zależnościami.

Wklej oficjalne repozytoria dla tego wydania, znajdziesz je tutaj:

http://forum.ubuntu.pl/showthread.php?t=37494

Zobacz, czy błąd znowu wystąpi.


(Jarek Zakrzewski1) #8

Jest rozwiązanie problemu! Dziękuje bardzo, wystarczyło tylko tą paczkę przeinstalować.