Ubuntu 10.4:System zmienia rozdzielczość po restarcie


(Serafin1209) #1

Witajcie mam od paru dni liniksa wiec jestem zielony :stuck_out_tongue: mam problem jak w temacie po restarcie systemu Ubuntu z każdym razem z rozdzielczości którą mogę ustawić ręcznie i zapisuje tj. 1280x1024 czyli standardowa jak dla mnie (bez problemowo działa), zmienia na 1024X768 ;/ i nie wiem jak ustawić na stałe wyższą rozdzielczość. dodam jeszcze zawartość pliku: /etc/X11/xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings

# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010



Section "ServerLayout"

    Identifier "Layout0"

    Screen 0 "Screen0" 0 0

    InputDevice "Keyboard0" "CoreKeyboard"

    InputDevice "Mouse0" "CorePointer"

    Option "Xinerama" "0"

EndSection


Section "Files"

EndSection


Section "InputDevice"


    # generated from default

    Identifier "Mouse0"

    Driver "mouse"

    Option "Protocol" "auto"

    Option "Device" "/dev/psaux"

    Option "Emulate3Buttons" "no"

    Option "ZAxisMapping" "4 5"

EndSection


Section "InputDevice"


    # generated from default

    Identifier "Keyboard0"

    Driver "kbd"

EndSection


Section "Monitor"


    # HorizSync source: builtin, VertRefresh source: builtin

    Identifier "Monitor0"

    VendorName "Unknown"

    ModelName "CRT-0"

    HorizSync 31.0 - 83.0

    VertRefresh 60.0 - 75.0

EndSection


Section "Device"

    Identifier "Device0"

    Driver "nvidia"

    VendorName "NVIDIA Corporation"

    BoardName "GeForce 8600 GT"

EndSection


Section "Screen"

    Identifier "Screen0"

    Device "Device0"

    Monitor "Monitor0"

    DefaultDepth 24

    Option "TwinView" "0"

    Option "TwinViewXineramaInfoOrder" "CRT-0"

    Option "metamodes" "1280x1024_60 +0+0"

    SubSection "Display"

        Depth 24

    EndSubSection

EndSection

(Phobos64) #2

Odpalaj nvidia-settings przez sudo

sudo nvidia-settings

Wtedy się zapisze.


(Serafin1209) #3

próbowałem i nic nie pomagało :frowning: nawet ręcznie edytowałem na root sam pliczek i tez nic ;/ zawsze ten sam efekt ..


(Phobos64) #4

Ja mam tak:

# nvidia-settings: X configuration file generated by nvidia-settings

# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010


Section "ServerLayout"

    Identifier "Layout0"

    Screen 0 "Screen0" 0 0

    InputDevice "Keyboard0" "CoreKeyboard"

    InputDevice "Mouse0" "CorePointer"

    Option "Xinerama" "0"

EndSection


Section "Files"

EndSection


Section "InputDevice"

    # generated from default

    Identifier "Mouse0"

    Driver "mouse"

    Option "Protocol" "auto"

    Option "Device" "/dev/psaux"

    Option "Emulate3Buttons" "no"

    Option "ZAxisMapping" "4 5"

EndSection


Section "InputDevice"

    # generated from default

    Identifier "Keyboard0"

    Driver "kbd"

EndSection


Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid

    Identifier "Monitor0"

    VendorName "Unknown"

    ModelName "Samsung S/M 755DF"

    HorizSync 30.0 - 85.0

    VertRefresh 50.0 - 160.0

    Option "DPMS"

EndSection


Section "Device"

    Identifier "Device0"

    Driver "nvidia"

    VendorName "NVIDIA Corporation"

    BoardName "GeForce 8800 GT"

EndSection


Section "Screen"

    Identifier "Screen0"

    Device "Device0"

    Monitor "Monitor0"

    DefaultDepth 24

    Option "TwinView" "0"

    Option "TwinViewXineramaInfoOrder" "CRT-0"

    Option "metamodes" "1280x1024 +0+0"

    SubSection "Display"

        Depth 24

    EndSubSection

EndSection

Spróbój zainstalować sterowniki z nvidia.com, wcześniej odinstaluj stare.


(Serafin1209) #5

zaktualizowałem sterowniki do najnowszej wersji wspomogłem się twoimi ustawieniami i wygląda na to ze pomogło :slight_smile: wielkie dzięki :smiley: :!: