Ubuntu 12.04 odinstalowane sterowniki - nie włącza się


(Mlody993) #1

Witam,

mam taki problem z moim Ubuntu 12.04, instalowalem sterowniki graficzne ale nie pamietam repozytorium, wiem, ze bylo cos xserver-xorg. Potem dowiedziałem się, że do intela nie potrzebne są sterowniki bo są one w jądrze linuksa. Zostawiłem to tak jak jest, potem miałem problemy z grafiką, wyskakiwały błędy systemu. Odinstalowałem te sterowniki przez centrum oprogramowania, niestety nie miałem wtedy dostępu do sieci i może to był błąd. Po restartcie kompa ubuntu już nie startuje, jest animacja ładowania Ubuntu i potem czarny ekran, nic się nie dzieje.

Działa mi tylko tryb ratunkowy, próbowałem tam wykonać komendy (z obsługą sieci) typu sudo apt-get update /upgrade/ -f install / jednak nic nie pomaga. ;/ Gdy wpisuje sudo startx to wyskakują jakieś błędy dotyczące właśnie xorg.

Chciałem wgrać system na nowo, jednak problem jest taki, że muszę najpierw skopiować moje dane z partycji ubuntu, potem moge resetować. Próbowałem więc odpalić Ubuntu z Live CD, zeby skopiować pliki jednak nie mam takich uprawnień.

Proszę o pomoc jak przywrócić sterowniki graficzne ale te oryginalne żeby system odpalił, albo jak skopiować dane (ubuntu mam obok Win7 może będzie to pomocne chociaż wiem, że z windowsa raczej nie skopiuje danych ubuntu).

Próbowałem też zrobić dodatkową partycję i na niej zainstalować ubuntu na chwile, żeby tylko skopiować dane z poprzedniej wersji ubuntu, jednak po zrobieniu partycji i klikaniu naprzód wyskakuje błąd, że muszę wybrać główny system plików w menu partycjonowania - nie wiem o co w tym chodzi, a nie widzę też nigdzie żadnego menu partycjonowania. ;/

Proszę o jak najszybszą pomoc.


(roobal) #2

Mlody993 , korzystanie z polskich liter dotyczy również tytułu, proszę dokonać stosowanej korekty.


(Marcin86s) #3

Ctrl+Alt+F2,F3,F4...

Logujesz się

sudo apt-get install xserver-xorg


(roobal) #4

Pliki możesz przekopiować z uprawnieniami roota.

sudo cp -prfv /mejsce/źródłowe/* /miejsce/docelowe/

lub graficznie

sudo nautilus

w livecd hasło dla sudo jest domyślnie wyłączone.

Zainstaluj Xserver w trybie ratunkowym podanym wyżej poleceniem.

Rozumiem, że Ubuntu i /home masz na jednej partycji, jeśli tak, to możesz ewentualnie zaryzykować instalacji nakładkowej, tj. zainstalować system na partycji bez jej formatowania, pliki systemowe zostaną nadpisane i uzupełnione, zawartość /home nie powinna się zmienić, tj. nic nie powinno być usunięte (pomijając pliki konfiguracyjne, które zostaną nadpisane tymi z domyślnymi ustawieniami).

Pozdrawiam!


(Qba Lukaszczyk) #5

System pewnie da się uratować, ale "jakieś" błędy niewiele pomagają.

Skusisz się na wklejenie całego komunikatu?


(Mlody993) #6

Problem rozwiązany, przez Windowsa skopiowałem pliki te ważniejsze i przeinstalowałem system, teraz nie bawię się w żadne kombinacje z grafiką. :wink: