Ubuntu 13.04 problem z Wi-Fi - "RFKILL"


(Haker16644) #1

Witam, mam problem z włączeniem Wi-Fi (nie łączeniem się z siecią, tylko po prostu włączeniem) w Ubuntu 13.04. Problem polega na tym, że w Network Manager (chyba tak to się nazywa, jestem "zielony" w Ubuntu) jest napisane, że Wi-Fi jest wylączone przez przełącznik sprzętowy. Podam dokładniej wszystko co jest tam napisane:

Sieć ethernetowa

rozłączone


Sieci Wi-Fi

Wi-Fi jest wyłączone przez przełącznik sprzętowy


Połączenia VPN ►


√Sieć

Sieć Wi-Fi


Informacje o połączeniu

Modyfikuj połączenia...

To, co jest napisane na szaro, to te przyciski, których nie da się kliknąć.

W terminalu próbowałem komendę:

sudo ifconfig wlan0 up

ale wyskakuje błąd:

SIOCSIFFLAGS: Operacja niemożliwa ze względu na RF-kill

a w "rfkill" :

rfkill list

wyskakuje:

0: phy0: Wireless LAN

                     Soft blocked: no

                    Hard blocked: yes

Komenda

rfkill unblock 0

nie pomaga.. Co mogę zrobić? Moja karta sieciowa to Atheros 9285 (ath9k). Jak mogę rozwiązać ten problem?

Z góry dzięki za pomoc :wink:


(roobal) #2

Tak na początek, próbowałeś użyć przełącznika i włączyć te kartę sprzętowo? Zresztą wystarczy zajrzeć do manuala, aby przeczytać w nim.


(Haker16644) #3

W jaki sposób mam włączyć kartę "sprzętowo" ? Bo nie rozumiem. W ustawieniach sieciowych próbowałem włączyć Wi-Fi i nic.


(roobal) #4

Sprzętowo tzn. przy użyciu przełącznika na obudowie laptopa lub kombinacji klawiszy, zajrzyj do instrukcji obsługi jak się włącza i wyłącza moduł WiFI w twoim modelu laptopa.