Ubuntu 7.04 Nvidia GeForce 2 TI 64MB


(E Mr Koka) #1

Po instalacji Ubuntu działało na sterowniku "vesa" zmieniłem na "nv" i dalej działało tylko na wyższej rozdzielczości, ale dalej do akceleracji korzysta z CPU a nie z karty graficznej (chyba i tak zle to ujelem :slight_smile: ) , zainstalowałem sterowniki do tej karty z repozytoriów i po instalacji uruchomiłem nvidia-config co zmieniło sterownik na "nvidia" lecz X'y z tego sterownika nie chcą startowa, musiałem z powrotem zmienić na "nv" oto plik xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Nov 9 17:55:20 PST 2006


# /etc/X11/xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the xorg.conf(5) manual page.

# (Type "man xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg


Section "ServerLayout"

    Identifier "Default Layout"

    Screen "Default Screen" 0 0

    InputDevice "Generic Keyboard"

    InputDevice "Configured Mouse"

    InputDevice "stylus" "SendCoreEvents"

    InputDevice "cursor" "SendCoreEvents"

    InputDevice "eraser" "SendCoreEvents"

EndSection


Section "Files"


	# path to defoma fonts

    FontPath "/usr/share/fonts/X11/misc"

    FontPath "/usr/share/fonts/X11/cyrillic"

    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"

    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"

    FontPath "/usr/share/fonts/X11/Type1"

    FontPath "/usr/share/fonts/X11/100dpi"

    FontPath "/usr/share/fonts/X11/75dpi"

    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

EndSection


Section "Module"

    Load "i2c"

    Load "bitmap"

    Load "ddc"

    Load "extmod"

    Load "freetype"

    Load "glx"

    Load "int10"

    Load "vbe"

EndSection


Section "InputDevice"

    Identifier "Generic Keyboard"

    Driver "kbd"

    Option "CoreKeyboard"

    Option "XkbRules" "xorg"

    Option "XkbModel" "pc105"

    Option "XkbLayout" "pl"

EndSection


Section "InputDevice"

    Identifier "Configured Mouse"

    Driver "mouse"

    Option "CorePointer"

    Option "Device" "/dev/input/mice"

    Option "Protocol" "ImPS/2"

    Option "ZAxisMapping" "4 5"

    Option "Emulate3Buttons" "true"

EndSection


Section "InputDevice"

    Identifier "stylus"

    Driver "wacom"

    Option "Device" "/dev/input/wacom"

    Option "Type" "stylus"

    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection


Section "InputDevice"

    Identifier "eraser"

    Driver "wacom"

    Option "Device" "/dev/input/wacom"

    Option "Type" "eraser"

    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection


Section "InputDevice"

    Identifier "cursor"

    Driver "wacom"

    Option "Device" "/dev/input/wacom"

    Option "Type" "cursor"

    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection


Section "Monitor"

    Identifier "C1770NSL/NST"

    Option "DPMS"

EndSection


Section "Device"


#	Driver "vesa"

    Identifier "Generic Video Card"

    Driver "nv"

EndSection


Section "Screen"

    Identifier "Default Screen"

    Device "Generic Video Card"

    Monitor "C1770NSL/NST"

    DefaultDepth 24

    SubSection "Display"

        Depth 1

        Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"

    EndSubSection

    SubSection "Display"

        Depth 4

        Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"

    EndSubSection

    SubSection "Display"

        Depth 8

        Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"

    EndSubSection

    SubSection "Display"

        Depth 15

        Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"

    EndSubSection

    SubSection "Display"

        Depth 16

        Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"

    EndSubSection

    SubSection "Display"

        Depth 24

        Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"

    EndSubSection

EndSection

(system) #2

usuń sterowniki nvidia

sudo apt-get --purge remove nvidia-*

a następnie uruchom synaptica, znajdź pakiet nvidia nvidia-glx-legacy i go zainstaluj (razem z zależnościami) następnie wpisz

sudo dpkg-reconfigure xserver-xorg

wybierz sterownik nvidia.

zresetuj Xy


(Karas Lublin) #3

W Menedżeże Pakietów Synaptic szukamy i instalujemy nvidia-glx-legacy następnie poleceniem

sudo dpkg-reconfigure xserver-xorg

zmieniamy sterowniki z „nv” na „nvidia” resztę zostawiamy tak jak jest. Po ponownym uruchomieniu systemu w konsoli wpisujemy

sudo nvidia-settings

i z menu wybieramy odpowiednią rozdzielczość a następnie zatwierdzamy Apply i zapisujemy.


(system) #4

glx nie obsługuje geforce 2, potrzebny jest glx-legacy.


(E Mr Koka) #5

Na uruchomionych X'ach usunąć sterowniki z których korzystają? ;]

I tak na przyszłość to jak ze wszystkimi zależnościami zainstalowac ?


(Trol1 1966) #6

skorzystaj z repozytoriów ubuntu tam masz wszystko opisane krok po kroku jak skonfigurowa karte grafiki


(system) #7

tsk

możesz w konsoli


(E Mr Koka) #8

Wytłumacz mi to dokładniej, bo dalej niewiem o co chodzi.