Ubuntu 8.04 - biały ekran po logowaniu po upgrade


(silvver) #1

Jestem dość nowych userem tego systemu, ale już mam z nim problem, mianowicie klika dni (to był dzień premiery FF3) temu w update pokazało się 180 MB updejtów (np firefox 3, coś tam od open offica i inne). Po pobraniu tego system zażyczył sobie reset - po resecie pulpit przestawił się na 800x600 (miałem na 1024x768) i nie dało się go z powrotem przestawić, to uruchomiłem komputer jeszcze raz.

No i właśnie po wpisaniu loginu i hasła, pokazuje się tylko biały ekran i nic więcej....

Próbowałem dzisiaj się zalogować do sesji KDE i się udało, ale jak przywrócić gnome do pełnej sprawności?

Moja karta graficzna to X1950 (obiło mi się o uszy, że są problemy z nimi z ubunciakiem ;/ ), i miałem zainstalowane sterowniki od ATI (te co miały rozszerzenie .run i przez 'sh' się je włączało). Miałem też ustawione efekty pulpitu na maksymalne i wszystko ładnie chodziło....

do czasu tej felernej aktualizacji

Awaryjny GNOME się włącza, spod niego zainstalowałem te sterowniki ATI ale nadal gdy się loguje normalnie to się po logowaniu pokazuje tylko biały ekran :confused:


(Kaka') #2

Być może podczas aktualizacji systemu, także i kernel został uaktualniony. To czasami wiąże się z brakiem zgodności niektórych modułów z poprzedniej wersji jądra, z aktualną (ta sytuacja często występuje w przypadku sterowników ATI, NVIDIA). Mniemam także, że masz pod GNOME włączone wszystkie wodotryski (a one bez akceleracji nie zadziałają). Spróbuj wyłączyć te efekty i/lub zainstalować ponownie sterowniki (sprawdź przy tym jednak czy zainstalowały się poprawnie, czy system ich używa oraz czy jest akceleracja 3D).


(mario@) #3

Wchodzisz w tryb tekstowy i jako root wpisujesz (po kolei)

cd /usr/share/ati

sh ./fglrx-uninstall.sh

I stery powinny się odinstalować, następnie najlepiej je z powrotem zainstalować i posprawdzać zależności, bo jeżeli miałeś włączone jakieś dodatki to pewnie efekt końcowy będzie taki sam.

A nie robiłeś czasem aktualizacji w trybie graficznym :?: Raz tak zrobiłem i system u mnie padł.


(Kynski) #4

Albo użyć wolnych sterowników ATI.

Driver "radeon"