[Ubuntu 9.04] Nie trzyma ustawionej rozdzielczości


(Byadii22) #1

Witam

Niestety mam problem z moim Ubuntu. Wylogowując się z mojego kota, nagle zmieniło mi rozdzielczość ekranu. Tzn. na moim koncie mam rozdzielczość 1280x1024, lae po wylogowaniu się mam już 800x600 i już tak trzyma ;/

Dodam, że reinstalacja sterowników, rekonfiguracja xorg.conf nie pomogła.

W zasadzie pomogła, ale częściowo i debilnie. Bo mam ustawioną rozdzielczość, załóżmy na 1280x1024, ale wyświetla mi obraz w rozdziałce 1024x768 i muszę przewijać obraz myszą ;/

Co jeszcze... przeglądając nieśmiertelny xorg.conf zobaczyłem, że mój monitor lcd wykrywa jako crt ;/

mój xorg:

# nvidia-settings: X configuration file generated by nvidia-settings

# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

# xorg.conf (X.Org X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the xorg.conf manual page.

# (Type "man xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# Note that some configuration settings that could be done previously

# in this file, now are automatically configured by the server and settings

# here are ignored.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg


Section "Monitor"

	Identifier "Configured Monitor"

EndSection


Section "Monitor"

	Identifier "Monitor0"

	VendorName "Unknown"

	ModelName "LCD-0"

	HorizSync 28.0 - 55.0

	VertRefresh 43.0 - 72.0

EndSection


Section "Screen"

	Identifier "Default Screen"

	Device "Configured Video Device"

	Monitor "Configured Monitor"

	DefaultDepth	24

EndSection


Section "Screen"

	Identifier "Screen0"

	Device "Device0"

	Monitor "Monitor0"

	DefaultDepth 24

	Option "TwinView" "0"

	Option "TwinViewXineramaInfoOrder" "LCD-0"

	Option "1280x1024" "nvidia-auto-select @1280x1024 +0+0"

	SubSection "Display"

		Depth 24

	EndSubSection

EndSection


Section "Module"

	Load "glx"

EndSection


Section "InputDevice"

	Identifier "Keyboard0"

	Driver "kbd"

EndSection


Section "InputDevice"

	Identifier "Mouse0"

	Driver "mouse"

	Option "Protocol" "auto"

	Option "Device" "/dev/psaux"

	Option "Emulate3Buttons" "no"

	Option "ZAxisMapping" "4 5"

	# generated from default

EndSection


Section "ServerLayout"

	Identifier "Default Layout"

	Screen 0 "Screen0" 0 0

	InputDevice "Keyboard0" "CoreKeyboard"

	InputDevice "Mouse0" "CorePointer"

EndSection


Section "Device"

	Identifier "Configured Video Device"

	Driver "nvidia"

	Option "NoLogo" "True"

EndSection


Section "Device"

	Identifier "Device0"

	VendorName "NVIDIA Corporation"

	BoardName "GeForce 6600"

	Driver	"nvidia"

	Option	"NoLogo"	"True"

EndSection


Section "ServerFlags"

	Option "Xinerama" "0"

EndSection

Na koniec muszę wspomnieć, iż konfiguratorem od NVidii (ten w sterach) bawiłem się, ale nie przyniosło to żadnego efektu.

System: Ubuntu 9.04

Grafa : GF6600

Stery: 180 z repo


(roobal) #2

Może to zahaszuj:

Option "1280x1024" "nvidia-auto-select @1280x1024 +0+0"

i do tego:

SubSection "Display"

      Depth 24

   EndSubSection

dodaj Modes 1280x1024 :

SubSection "Display"

      Depth 24

      Modes 1280x1024

   EndSubSection

Ewentualnie zrób kopię zapasową obecnego xorg:

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

i wygeneruj nowy przy pomocy Xorg-utils:

X -configure

mv -v /root/xorg.conf.new /etc/X11/xorg.conf

Pozdrawiam!


(Kaka') #3

Jeżeli powyższy post nie pomoże, spróbuj usunąć wyżej zacytowane linijki, bądź zmień podane wartości odświeżania monitora, na zgodne z Twoim modelem (znajdziesz je na stronie producenta, instrukcji, etc.).


(Byadii22) #4

Hmm.. nie wiem co jest, ale dzisiaj mój brat uruchamia komputer i Ubuntu wystartowało... normalnie :stuck_out_tongue: Nic nie grzebałem, nie zmieniałem, po prostu młody włączył kompa i się zalogował z rozdzielczością 1280x1024, jak bozia przykazał :slight_smile: Pobawię się troszkę Ubuntu żeby znaleźć winowajce, ale puki co działa... Dzięki za szybką odpowiedź i pozdrawiam, w razie czego (czyt. kolejnego wysypania) napiszę tutaj.


(Phanyx) #5

Mimo, że problem rozwiązany, to dla potomności dodam, że po zainstalowaniu sterów nvidii (nie wiem jak z ati) można wszystkie parametry wyświetlania poustawiać w NVIDIA X Server Settings, a następnie po kliknięciu na 'Save to X configuration file' wygenerować xorg.conf, bez jego manualnej edycji.


(Byadii22) #6

Problem w tym, że u mnie to nie działało. Ale problem leży po stronie monitora, na Windowsie zdarza się, że nic nie widać, a na Ubuntu to chociaż zmieni tą rozdziałkę i coś widać. Monitor testowałem tydzień na innym komputerze (tez z Windows i Ubuntu) i działo się wręcz identycznie. W moim wypadku pomaga wyłączenie komputera, odłączenie monitora z sieci i ponowne uruchomienie całego zestawu. Czyli popularnie mówiąc wyłączyć kompa i wyłączyć go na "listwie" :slight_smile: