Ubuntu 9.04 - samoczynna zmiana rozdzielczości


(Hazel Adam) #1

Witam.

Mój problem polega na tym, iż po każdym restarcie samoczynnie rozdzielczość zmienia mi się z 1680x1050 na 1280x1024.

Oto mój plik xorg.conf:

Jakiś pomysł jak to rozwiązać?


(Michal Olber) #2

Uruchom za pomocą polecenia:

gksudo nvidia-settings

wpisz swoje hasło, potem przejdź do jednej z ostatnich zakładek, tam zmień sobie rozdzielczość na jaką ci pasuje i zachowaj ustawienia. Powinno to pomóc. Potem tylko musisz po każdym restarcie uruchomić nvidia-settings, aby sobie zmienić głębie kolorów, którą zrobiłeś wcześniej, bo system nie zapisuje tego w pliku konfiguracyjnym, tylko w zwykłym pliku w katalogu /home.


(Hazel Adam) #3

Ustawiłem. Reset i znowu mam 1280x1024...


(moongoose) #4

Spróbuj przeinstalować xorg , potem zrób nvidia-settings i jeszcze sprawdź wartości "HorizSync"

"VertRefresh".


(Hazel Adam) #5

Jak mam niby xorga przeinstalować?

Reinstalowałem sterowniki i nic nie dało. Dodam, że wcześniej instalując Ubuntu z tej samej płyty problemu nie miałem.


(moongoose) #6

tu masz linka - może będzie łatwiej

http://pl.wikibooks.org/wiki/Ubuntu/Roz ... %87_ekranu

A tak może wykarzesz więcej własnej inicjatywy - google nie boli!


(roobal) #7

Na przykład tak:

sudo dpkg-reconfigure xserver-xorg

Możesz jeszcze spróbować wygenerować nowy xorg.conf, jednak zrób sobie kopię obecnego, w tym celu uruchom Ubuntu Recovery Mode lub Single User, czy jakoś tak się to nazywa w Ubuntu, w każdym bądź razie w opcjach jądra ma być single i wykonaj odpowiednio:

mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Xorg -configure

mv -v /root/xorg.conf.new /etc/X11/xorg.conf

reboot

Gdyby nie było ustawionych rozdzielczości takich jak chcesz to je dopisz, zrestartuj Xserver.

Pozdrawiam!


(Hazel Adam) #8

Widziałem to wcześniej.

roobal , dzięki. :wink: