[Ubuntu 9.04 x64] Firefox 3.5 + Adobe Flash Player nie dział


(Mlody993) #1

Witam,

mam problem z Adobe Flash Player na Ubuntu 9.04 PL x64 bit , a dokładniej Firefox 3.5.

Pobrałem już tą specjalną wersję Flash Playera dla Linuxa 64bit no i próbowałem wielu sposobów. Od wczoraj wertuję Google i nic. :frowning: Na forum Ubuntu nic, zero pomocy. :frowning: A więc liczę na pomoc z waszej strony.

No więc sposoby jakie próbowałem:

  • Instalacja przez Synaptic'a.

  • Usuwanie/reinstal przez Synaptic'a.

  • Wrzucanie do folderu /home/mlody/.mozilla/plugins

  • Wrzucanie do folderu z firefoxem /firefox/plugins

  • Wrzucanie do /usr/lib/firefox/plugins

  • Wrzucanie do /usr/lib64/firefox/plugins

Nic z tego niestety. Teraz doczytałem, że bez wtyczki Shockwave Player nie będzie działać Flash Player. Więc właśnie pobrałem Shockwave i instaluje poprzez Wine.


(mati75) #2

http://get.adobe.com/flashplayer/thanky ... inux_(.deb


(nintyfan) #3
file /usr/bin/firefox

stat /usr/bin/firefox

file /usr/bin/firefox-3.5

stat /usr/bin/firefox-3.5

Prześlij wynik powyższego.

Jeszcze przeciągnij plik skrótu Firefoksa na pulpit, po czym otwórz go. Interesuje mnie wartość do końca linii po wyrażeniu:

Exec=

Możesz też otworzyć właściwości skrótu i podać nam polecenie(zawartość pola o tej nazwie).

Wykonaj też file i stat na plikach, które kopiujesz do wspomnianych przez Ciebie katalogów.


(Mlody993) #4

Wtedy wyskakuje błąd: Nieodpowiednia architektura "i386"

@nintyfan:

Już to robię, dam edita.

@edit:

@edit2:

Firefox został pobrany z mozilla.com (wersją 3.5 PL dla Linuxa), rozpakowany i wrzucony w Home/Mlody/Dokumenty - stamtąd go odpalam.

-- Dodane 18.07.2009 (So) 22:47 --

Proszę o pomoc :frowning:

-- Dodane 18.07.2009 (So) 22:57 --

Problem został rozwiązany.

Odpowiedź jest na forum Ubuntu, nie wiem czy mogę podać link. Ale jakby ktoś miał ten sam problem to pisać PW, podam link.


(Kaka') #5

Na stronie mozilli standardowo są dostępne tylko 32-bitowe binarki, stąd ten cały problem.

Jak najbardziej możesz, a nawet powinieneś :slight_smile:


(Mlody993) #6

Tak więc odpowiedź na ten problem jest tutaj: http://forum.ubuntu.pl/showthread.php?t=51601

Zamiast pobierać z macromedia pobieramy wersję x64 z adobe.com . Pliku flashplayer.xpt w Flash Player 10 nie ma więc odpuszczamy tą linijkę:

sudo cp flashplayer.xpt /usr/lib/mozilla/plugins/

Z resztą w tych komendach:

cd Desktop

cd install_flash_player_9_linux

sudo cp libflashplayer.so /usr/lib/mozilla/plugins/

sudo cp flashplayer.xpt /usr/lib/mozilla/plugins/ 

nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

Może wywalić błąd większość poleceń, ale ignorować to i jechać dalej. :slight_smile: Po prostu jest to stary poradnik i wymaga aktualizacji.

UWAGA! Jeśli mamy cd Desktop to proponuje nie wpisywać w terminalu tylko prawym na pulpicie i Otwórz w terminalu****. Piszę dlatego, że mi komenda **** cd Desktop **** nie działała.

Właśnie napisałem poradnik na forum Ubuntu, poprawiłem stary. Dostałem informację, że w ciągu 5 minut pojawi się temat. Więc jak tylko się pojawi dam link do poprawionej wersji.


(matiit) #7

nie działa cd Desktop bo działa cd Pulpit (;

w Ubu po prostu nazwali ten folder w rodzimych językach.


(Kaka') #8

I skucha, ponieważ nspluginwrapper jest używany dla wtyczek 32-bitowych, a nie 64 (przynajmniej z tego co się orientuję i z tego co sam testowałem).


(Mlody993) #9

Ale napisałem:

Po prostu podałem rozwiązanie problemu, co zrobiłem, że błąd został rozwiązany. ;] Ważne, że sposób działa. :stuck_out_tongue: