Ubuntu-alc883 brak dźwięku na głośnikach


(niezDarek) #1

otóż po zainstalowaniu dawno temu ubuntu miałem problem bo gdy wsadzałem słuchawki dźwięk nadal leciał na głośnikach zamiast się przełączyć na gniazdo słuchawek, poszperałem w :google:

no i uzyskałem dźwięk na słuchawkach ale tylko na słuchawkach, na głośnikach dźwięku niema(oczywiście gdy mam odłączone słuchawki)

właściwie to nie przeszkadzało mi to do tej pory bo i tak zazwyczaj słucham muzy na słuchawkach albo zewnętrznych głośnikach, ale ostatnio stwierdziłem że przydały by sie działające głośniki w laptopie,

aha głośniki sa sprawne bo na Viście działają bez problemu, próbowałem z zaznaczaniem i odznaczaniem opcji Headphones w Przełącznikach w Regulacji głośności i aktualizowałem Alse

Da sie jakoś zrobić aby po odłączeniu słuchawek był dźwięk na głośnikach ??

jak nie to przynajmniej aby działały tylko głośniki zamiast słuchawek (próbowałem przywrócić usuwając dodaną linie ale nie działa)


(Reksio009) #2

Co to za laptop? Jaki model?

Która wersja Ubuntu?

Która wersja jądra?


(niezDarek) #3

laptop Belinea o.book 3.2 ale właściwie jakie to ma znaczenie ?? chipset dźwiękowy podałem, pełna nazwa: Realtek ALC883 High Definition Audio

ubuntu 9.04 2.6.28-11-generic


(roobal) #4

Masz dwa warianty, spróbuj dodać takie wpisy:

options snd-pcsp index=-2

options snd-hda-intel model=auto

Albo takie:

options snd-hda-intel model=targa-2ch-dig

options snd-hda-intel enable_msi=1

i daj znać czy coś się zmieniło :slight_smile:

EDIT: Znalazłem przy okazji jeszcze taką stronę http://widmogrod.blogspot.com/2008/10/u ... 6735s.html :slight_smile:

Pozdrawiam!


(niezDarek) #5

minął już miesiac ale może przyda sie innym, po aktualizacji do 9.10 zadziałało dodanie na końcu pliku: /etc/modprobe.d/alsa-base

options snd-pcsp index=-2

options snd-hda-intel model=auto

o dziwo na 9.04 u mnie nie zadziałało

dzięki roobal ,