Ubuntu czyta tylko 3GB z 4GB


(Lost World) #1

Witam,

Mam dość dziwny problem,

Ubuntu czyta mi tylko 3GB ramu z 4GB zainstalowanych,

Zarówno na 32 oraz 64 bitowej wersji,

Dziwne, bo u mojego znajomego który ma 8GB ramu, jest wszystko ok.

Proszę o pomoc.

Laptop Lenovo T60.


(roobal) #2

Na 32-bitowym systemie potrzebujesz jądro skompilowane z obsługą dużej ilości RAMu (do 64GB), zainstaluj serwerową wersję jądra lub PAE, jeśli jest w repozytorium.

sudo apt-get update && sudo apt-get install linux-server linux-headers-server linux-restricted-modules-server

Na 64-bitowym powinno być normalnie. Pokaż jeszcze wyniki poleceń z 64-bitowej wersji systemu.

cat /proc/meminfo

uname -r

(Lost World) #3
MemTotal: 3082584 kB

MemFree: 899280 kB

Buffers: 133680 kB

Cached: 836296 kB

SwapCached: 0 kB

Active: 1099780 kB

Inactive: 488872 kB

Active(anon): 619448 kB

Inactive(anon): 976 kB

Active(file): 480332 kB

Inactive(file): 487896 kB

Unevictable: 0 kB

Mlocked: 0 kB

SwapTotal: 3142652 kB

SwapFree: 3142652 kB

Dirty: 100 kB

Writeback: 0 kB

AnonPages: 618716 kB

Mapped: 122948 kB

Shmem: 1752 kB

Slab: 104360 kB

SReclaimable: 76272 kB

SUnreclaim: 28088 kB

KernelStack: 3216 kB

PageTables: 25500 kB

NFS_Unstable: 0 kB

Bounce: 0 kB

WritebackTmp: 0 kB

CommitLimit: 4683944 kB

Committed_AS: 2668864 kB

VmallocTotal: 34359738367 kB

VmallocUsed: 96716 kB

VmallocChunk: 34359630844 kB

HardwareCorrupted: 0 kB

AnonHugePages: 0 kB

HugePages_Total: 0

HugePages_Free: 0

HugePages_Rsvd: 0

HugePages_Surp: 0

Hugepagesize: 2048 kB

DirectMap4k: 492352 kB

DirectMap2M: 2652160 kB

3.2.0-31-generic

na wszelki wypadek, uname -a

Linux IBMT60 3.2.0-31-generic #50-Ubuntu SMP Fri Sep 7 16:16:45 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

(dragonn) #4

Jaką masz kartę graficzną? Jak masz integrę to pewnie ona sobie resztę rezerwuję i dlatego nie widać brakującego 1GB.


(Lost World) #5

Moja karta to,

ATI Radeon X1400 128MB

No karta wiem, że jest zintegrowana, ale jakim cudem by mi zjadało 1GB?


(dragonn) #6
dmesg | grep Memory

Pokaż no wynik tego - najlepiej zaraz po włączeniu systemu (inaczej może uciec to z loga). Możesz też wrzucić cały dmesg.


(Lost World) #7

Poszło,

[0.000000] initial memory mapped : 0 - 02000000

[0.000000] Base memory trampoline at [c009b000] 9b000 size 16384

[0.000000] init_memory_mapping: 0000000000000000-0000000037bfe000

[0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000

[0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000d2000

[0.000000] PM: Registered nosave memory: 00000000000d2000 - 00000000000d4000

[0.000000] PM: Registered nosave memory: 00000000000d4000 - 00000000000dc000

[0.000000] PM: Registered nosave memory: 00000000000dc000 - 0000000000100000

[0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups

[0.000000] virtual kernel memory layout:

[0.008282] Initializing cgroup subsys memory

[0.689858] Freeing initrd memory: 19680k freed

[1.194943] Freeing unused kernel memory: 744k freed

[1.316309] [drm] Generation 2 PCI interface, using max accessible memory

[1.321331] [TTM] Zone kernel: Available graphics memory: 432718 kiB.

[1.321335] [TTM] Zone highmem: Available graphics memory: 1548274 kiB.

[1.321360] [drm] radeon: 128M of VRAM memory ready

[1.321362] [drm] radeon: 512M of GTT memory ready.

[21.766582] Non-volatile memory driver v1.3

[22.506545] pcmcia_socket pcmcia_socket0: cs: memory probe 0xe4300000-0xe7ffffff: excluding 0xe4300000-0xe46cffff

[22.506566] pcmcia_socket pcmcia_socket0: cs: memory probe 0xe0000000-0xe3ffffff: excluding 0xe0000000-0xe3ffffff

[22.633079] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0c0000-0x0fffff: excluding 0xc0000-0xd3fff 0xdc000-0xfffff

[22.633115] pcmcia_socket pcmcia_socket0: cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa0ffffff

[22.633147] pcmcia_socket pcmcia_socket0: cs: memory probe 0x60000000-0x60ffffff: excluding 0x60000000-0x60ffffff

(dragonn) #8

Ehhh bez powodu nie podałem grep Memory a nie grep memory ;p. Daj jeszcze raz ale dokładnie:

dmesg | grep Memory

A jak już mówiłem - wrzuć też od razu cały dmesg.


(Lost World) #9

Sorry, mój bład Panie kolego :slight_smile:

[0.000000] Memory: 3076124k/3144512k available (5839k kernel code, 67936k reserved, 2861k data, 744k init, 2231112k highmem)

dmesg,

http://www.wklej.org/id/1177643/


(dragonn) #10

Faktycznie, widzi tylko 3GB, ale dlaczego masz kernel 3.2.0-56-generic-pae? Sprawdź może pod inną dystrybucją czy jest ok.


(Lost World) #11

Od kilku dni testuje, różne dystrybucje i wczoraj po prostu zainstalowałem 32 bitową z PAE.

Sprawdzałem, sprawdzałem i nic.

A w Biose widać available: 4GB :confused:


(dragonn) #12

A Windows? Widzi całe 4GB?


(MrQ) #13

Zapodaj wynik polecenia

cat /proc/mtrr