Ubuntu Gutsy Gibbon - instalacja kadu


(Attendite) #1

Przepraszam, tak, wiem, że jestem kolejnym który zadaje proste [dla Was] pytania.

Używam ubuntu od DZIŚ, chciałbym zainstalować kadu. Przeczytałem WSZYSTKIE dostępne instrukcje, ta na kadu.net radzi

sudo apt-get update

Instalujemy kadu:

sudo apt-get install kadu

Po czym ja dostaję:

E: Nie udało się odnaleźć pakietu kadu

Baaardzo dziękuję za jakiekolwiek odpowiedzi poza "naucz się korzystać z google" <- nie mogę już dziś więcej na nie patrzeć.


(Mail) #2

sudo gedit /etc/apt/sources.list

usuń zawartość pliku i wklej:

Zapisz plik (CTRL+S) i w terminalu:

sudo apt-get update

sudo apt-get install kadu kadu-alsasound

Musi działać :slight_smile:


(Attendite) #3
Czytanie list pakietów... Gotowe

W: GPG error: http://wine.budgetdedicated.com gutsy Release: Następujące sygnatury nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 58403026387EE263

W: GPG error: http://dl.google.com stable Release: Następujące sygnatury nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY A040830F7FAC5991

W: GPG error: http://packages.medibuntu.org gutsy Release: Następujące sygnatury nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 2EBC26B60C5A2783

W: Należy uruchomić apt-get update aby naprawić te problemy.

hack@hack:~$ sudo apt-get install kadu kadu-alsasound

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

E: Nie udało się odnaleźć pakietu kadu-alsasound

Niestety. Nie wiem, co robię źle. Bardzo dziękuję za powyższą odpowiedź!


(Mail) #4

to wbij:

sudo apt-get install kadu

niepotrzebnie dałem pakiet dźwięków, widocznie go nie ma...


(lazikar) #5

Ubutu to Linux wiec czemu piszesz posta w dziale problemy.

Przenoszę.


(Attendite) #6
hack@hack:~$ sudo apt-get install kadu

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

Należy uruchomić `apt-get -f install', aby je naprawić:

Następujące pakiety mają niespełnione zależności:

  kadu: Wymaga: libartsc0 (>= 1.5.0-1) ale nie zostanie zainstalowany

        Wymaga: libaudio2 ale nie zostanie zainstalowany

        Wymaga: libqt3-mt (>= 3:3.3.8really3.3.7) ale nie zostanie zainstalowany

  php-java-bridge: Wymaga: sun-java6-jre ale nie zostanie zainstalowany

                   Wymaga: liblucene-java ale nie zostanie zainstalowany

                   Wymaga: libitext-java ale nie zostanie zainstalowany

E: Niespełnione zależności. Spróbuj 'apt-get -f install' bez pakietów (lub podaj rozwiązanie).

hack@hack:~$ sudo apt-get install kadu

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

Należy uruchomić `apt-get -f install', aby je naprawić:

Następujące pakiety mają niespełnione zależności:

  kadu: Wymaga: libartsc0 (>= 1.5.0-1) ale nie zostanie zainstalowany

        Wymaga: libaudio2 ale nie zostanie zainstalowany

        Wymaga: libqt3-mt (>= 3:3.3.8really3.3.7) ale nie zostanie zainstalowany

  php-java-bridge: Wymaga: sun-java6-jre ale nie zostanie zainstalowany

                   Wymaga: liblucene-java ale nie zostanie zainstalowany

                   Wymaga: libitext-java ale nie zostanie zainstalowany

E: Niespełnione zależności. Spróbuj 'apt-get -f install' bez pakietów (lub podaj rozwiązanie).

hack@hack:~$

Z javą coś tam się bawiłem, ale też mi nie wyszło. Cóż, próbować dalej... ?

`apt-get -f install' ?


(Attendite) #7

po apt get -f install

Tak, root.


(Mail) #8

to daj sudo apt-get -f install


(Attendite) #9

Chwilowo coś się dzieje, jakby się java instalowała , którą wcześniej próbowałem zainstalować ale coś było tam z zależnościami...

Po tym kadu powinno śmigać ? [piwollo, bardzo Ci dziekuje za zainteresowanie]

// Połączono posty.

Podczas instalowania javy pojawia mi sie uparcie konfig. pakietu ktory wylaczam escapem a on i tak wraca. :confused:

EDIT nie mam talentu ^^

hack@hack:~$ sudo apt-get -f install kadu

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. 

hack@hack:~$ dpkg --configure -a

dpkg: żądana operacja wymaga uprawnień administratora

hack@hack:~$ sudo apt-get -f install

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

(Kaka') #10

TTTx , proszę nie pisać posta po postem, użyj przycisku EDYTUJ. Twoje posty połączyłem, ale w razie dalszego pisania posta pod postem, dostaniesz ostrzeżenie. Ponadto proszę używać tagów code do wklejania informacji z konsoli.


(adami) #11

Zapodaj i zobaczymy co wyświetli

sudo apt-get install kadu kadu-external-modules

(Morietto) #12

wydaje mi się że popsułeś instalator ;] choć mogę się mylić ;]

miałem tak gdy instalowałem program z wbudowaną javą ;] java na ubuntu długo się instaluje a przy jej instalacji trzeba w okienku informującym otworzyć szczegóły i zamiast czarnego ekraniku z tekstem informującym co się instaluje po pewnym czasie pojawi się regulamin i prośba o potwierdzenie ;]

UWAGA PRZERWANIE INSTALACJI JAVY USZKADZA COŚTAM.. TRZEBA POZWOLIĆ ZAINSTALOWAĆ SIĘ JEJ DO KOŃCA ;] INACZEJ MOŻE BYĆ KLOPS ;]

u mnie na trzy takie przypadki trzy skończyły się awarią ;] aż nauczyłem się na błędzie ;]

UWAGA: mogę się mylić ;]

U Ciebie w treści z terminala pojawił się następujący komunikat:

you must manually run 'dpkg --configure -a' to correct the problem

więc:

dpkg --configure -a

a potem

sudo apt-get install kadu

;]


(JarekMk) #13

dpkg --configure -a

a potem apt-get dist-upgrade - tak dla pewności.

potem apt-get autoremove - żeby wywalić śmieci które ewentualnie załapałeś :slight_smile:

Po co instalować starą paczke jak możęsz mieć kadu w wersji 0.6 :slight_smile:

http://linuksowiec.ovh.org/kadu/kadu_0. ... 1_i386.deb

pzdr!


(Attendite) #14

Jak widzę, problem nie jest tak prosty do rozwiązania. Czy to możliwe, że jeśli na jednym dysku mam Starego ubuntu, oraz 7.10, to na tym 7.10 jakgdyby nie jestem na roocie ? Mimo, ze na 7.10 jest tylko jedno konto...

Chyba sformatuję dysk z linuxami i zacznę wszystko od początku, bo po wykorzystaniu Waszych porad:

dpkg --configure -a

dostaję:

[b]dpkg: żądana operacja wymaga uprawnień administratora[/b]

A jak dam:

apt-get dist-upgrade

dostaję:

E: Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock - open (13 Permission denied)

E: Unable to lock the administration directory (/var/lib/dpkg/),are you root?

apt-get autoremove:

To samo co powyżej.

Myślę, że format dysku, usunięcie obu ubuntu i zainstalowanie Gibbona jeszcze raz pomoże, a Wy ? :slight_smile: Cały czas pyta mnie czy jestem na root.


(Kaka') #15

TTTx , polecam zapoznać się z podstawami dotyczącymi obsługi systemu. Zajrzyj w tematy przyklejone w tym dziale i poczytaj poradniki do Ubuntu.

Format w ogóle nie jest potrzebny. W Ubuntu możesz dostać się na konto roota wpisując sudo su, bądź używając samego sudo.

Pozdrawiam.


(Attendite) #16

Kadu 0.6, nowe, które polecił mi JarekMK zainstalowane. Edytowałem jakiś tam plik, dzięki któremu w Aplications -> Internet i na pasku miały się pojawić ikony kadu, i faktycznie - pojawiły się. Jest tylko jeden, mały, ale istotny problem - klikając na nie.. nic się nie dzieje, może ktoś wie, dlaczego ?


#17

Pewnie dlatego, że źle jest określona ścieżka do Kadu pod tym skrótem.

A co się dzieje jak próbujesz odpalić Kadu z konsoli?


(Attendite) #18

Jak wpisuję kadu w terminalu:

hack@hack:~$ kadu

kadu: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

#19

No to jeżeli potrafisz czytać, to widzisz że brakuje Ci jednego pakietu.

Zainstaluj libqt i zobacz wtedy.


(Attendite) #20
hack@hack:~$ sudo apt-get install libqt

[sudo] password for hack:

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Reading state information... Gotowe

E: Nie udało się odnaleźć pakietu libqt

Chyba nie taki miał być wynik :(.