Ubuntu - Huawei e3131 i Aero2 - błąd łączenia


(JarekMk) #1
$ tail /var/log/syslog
Mar 19 10:04:47 house1 NetworkManager[1439]: <info> (ttyUSB0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
Mar 19 10:04:47 house1 NetworkManager[1439]: <warn> Activation (ttyUSB0) failed for connection 'aero2 Domyślne'
Mar 19 10:04:47 house1 NetworkManager[1439]: <info> Activation (ttyUSB0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
Mar 19 10:04:47 house1 NetworkManager[1439]: <info> (ttyUSB0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Mar 19 10:04:47 house1 NetworkManager[1439]: <info> (ttyUSB0): deactivating device (reason 'none') [0]
Mar 19 10:04:47 house1 modem-manager[1179]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (connected -> disconnecting)
Mar 19 10:04:47 house1 modem-manager[1179]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disconnecting -> connected)
Mar 19 10:04:49 house1 avahi-daemon[1218]: Withdrawing workstation service for ppp0.
Mar 19 10:04:49 house1 NetworkManager[1439]: SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Mar 19 10:04:52 house1 vnstatd[1392]: Interface "ppp0" disabled.

Ubuntu 13.04

Karta  Aero2

Huawei e3131-s2

Mróga na niebiesko - mrugnięcia co 3 sekundy.

Wcześniej działało (jakiś miesiąc temu)

Nie bardzo wiem gdzie szukać przyczyny...

NM 'kręci' jak do łączenia i po chwili zaprzestaje.

 

 

Modem widziany poprawnie.


(Dimatheus) #2

JarekMk , zapoznaj się, proszę, z tym tematem i stroną, a następnie - korzystając z przycisku Edytuj (na dole pierwszego posta po prawej stronie) i opcji Użyj pełnego edytora - popraw tytuł wątku tak, by mówił konkretnie o problemie. Poprawnie zatytułowany wątek zwiększa szansę na uzyskanie szybkiej pomocy. Zignorowanie tej prośby będzie skutkować przeniesieniem tematu do kosza.

Pozdrawiam,

Dimatheus


(Ubbaa) #3

Niestety Aero2 dział różnie (w tym samy miejscu modem nie łapie zasięgu) w dodatku Network Manager czasami nie łączy, rozłącza, lub próbuje połączyć się w nieskończoność (zachowuje się dziwnie). I oczywiście łączenie 15 minutowe z siecią jest czymś normalnym.

 

Proponuje zainstalować i skonfigurować wvdial do Aero2, działa lepiej. Jak jesteś zainteresowany dziś wieczorem mogę Ci przesłać mój plik konfiguracyjny. Ja przy konfiguracji wvdial korzystałem z tego http://dug.net.pl/tekst/197/aero2_z_modemem_huawei_e3131/ przejdź od razu do sekcji “Konfiguracja wvdial”, większość modemów sprzedawana jest tak aby działać pod Linuksem out-of-box.


(JarekMk) #4

 wvdial aero2 

–> WvDial: Internet dialer version 1.61

–> Initializing modem.

–> Sending: AT+CGDCONT=1,“IP”,“darmowy”

OK

–> Modem initialized.

–> Sending: ATDT*99#

–> Waiting for carrier.

CONNECT

–> Carrier detected.  Starting PPP immediately.

–> Starting pppd at Thu Mar 20 09:41:19 2014

–> Pid of pppd: 3394

–> Using interface ppp0

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> Disconnecting at Thu Mar 20 09:41:56 2014

–> The PPP daemon has died: A modem hung up the phone (exit code = 16)

–> man pppd explains pppd error codes in more detail.

–> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.

–> Auto Reconnect will be attempted in 5 seconds

–> Initializing modem.

–> Sending: AT+CGDCONT=1,“IP”,“darmowy”

OK

–> Modem initialized.

–> Initializing modem.

–> Sending: AT+CGDCONT=1,“IP”,“darmowy”

OK

–> Modem initialized.

–> Sending: ATDT*99#

–> Waiting for carrier.

CONNECT

–> Carrier detected.  Starting PPP immediately.

–> Starting pppd at Thu Mar 20 09:42:01 2014

–> Pid of pppd: 3405

–> Using interface ppp0

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> pppd: ��x�`1� 8.� [01]

–> local  IP address 93.154.251.94

–> pppd: ��x�`1� 8.� [01]

–> remote IP address 10.64.64.64

–> pppd: ��x�`1� 8.� [01]

–> primary   DNS address 193.41.112.14

–> pppd: ��x�`1� 8.� [01]

–> secondary DNS address 193.41.112.18

–> pppd: ��x�`1� 8.� [01]

 

 

Pomimo tego - nie ma połączenia - nie da się pingować żadnego IP - sieć niedostępna:

$ ping 8.8.8.8

connect: Network is unreachable

 

Dlaczego?

 

Bus 002 Device 003: ID 12d1: 1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

Może w tym jest problem?

Wszędzie piszą o 14fe…


(Ubbaa) #5

Być może sam sobie odpowiedziałeś :). Zainstaluj pakiety  usb-modeswitchusb-modeswitch-data,  potem restart systemu i zobaczy czy możesz się połączyć.

 

Jeśli nadal nie możesz się połączyć to spróbuj wydać polecenie, przed wvdial:

sudo usb_modeswitch -v 12d1 -p 14fe -V 12d1 -P 1506

 Jeśli żonglujesz karami SIM w modemie sprawdź czy karta SIM jest dobrze włożona.

 

Spróbuj uruchomić wvdial jako root. (Jak zadziała to dodaj siebie do grupy dial )