Ubuntu - jak zamontować partycję ntfs


(Devv93) #1

Zrobiłem tak jak znalazłem na necie czyli:

sudo mkdir /media/ntfs


Następnie do fstaba:


sudo gedit /etc/fstab


Dodajemy linijkę:


/dev/sda2 /media/windows ntfs nls=utf8,umask=0222 0 0

1 dysk udało mi zamontować, chociaż nawet nie wiem jak. A drugi się nie da. Wyskakuje błąd.

Error mounting: mount exited with exit code 1: helper failed with:

mount: only root can mount /dev/sda2 on /media/windows

Zanim to zrobiłem był taki komunikat:

Error mounting: mount exited with exit code 14: Hibernated non-system partition, refused to mount.

Failed to mount '/dev/sda2': Operation not permitted

The NTFS partition is hibernated. Please resume and shutdown Windows

properly, or mount the volume read-only with the 'ro' mount option, or

mount the volume read-write with the 'remove_hiberfile' mount option.

For example type on the command line:


            mount -t ntfs-3g -o remove_hiberfile /dev/sda2 /media/6A321EFB321ECBC7

Wkleiłem tą ostatnią linijkę do terminalu i znowu pisze mount: only root can do that


(roobal) #2

No a wykonałeś to i inne polecenia z uprawnieniami roota (administratora)?

Pozdrawiam!


(Devv93) #3

Pierwszy raz mam linuxa, jak instalowałem stworzyłem użytkownika, więc chyba jest administratorem? a jak uzyskać te uprawnienia?


(roobal) #4

Linux to nie Windows, w żadnym wypadku pierwszy użytkownik nie jest administratorem, może co najwyżej należeć do grupy z prawami administracyjnymi ale nigdy nie będzie bezpośrednio administratorem i właśnie dlatego, że w Windows użytkownik jest domyślnie adminem, obniża to bezpieczeństwo systemu.

W Ubuntu, żeby uzyskać prawa administracyjne przed każdym poleceniem należy dodać polecenie sudo, hasło takie samo, jak pierwszego użytkownika, ponieważ pierwszy użytkownik w Ubuntu należy do grupy administratorów ale nie jest nim bezpośrednio, ma tylko prawa nadane właśnie dzięki sudo.

Pozdrawiam!


(Devv93) #5

Działa. Wielkie dzięki. Temat można zamknąć.