Ubuntu jako linuksowy serwer na VirtualBoxie - nie można zaktualizować bazy danych pakietów oraz pobrać pakietów


(Agnieszkasowinska2201) #1

Mam za zadanie postawić serwer Ubuntu. Niestety mam problem od samego początku, gdyż nie mogę zainstalować nic poleceniem apt-get install... oczywiście na koncie root, apt-get update nie chce zaktualizować wszystkiego. Jeśli ktoś mógłby mi pomóc, z góry dziękuję.


Tym razem jest lepiej, ale w przyszłości staraj się precyzyjniej dobierać tytuł wątku. Im tytuł jest precyzyjniejszy, tym większa masz szansa, że zajrzy tu więcej osób, które będą potrafiły Ci szybko pomóc.

roobal


(marcin82) #2

Jeśli mógłbyś podać wersję i Ubuntu i wynik polecenia z konsoli:

sudo apt-get update

 

Z góry dziękuję.


(Agnieszkasowinska2201) #3

a jak pokazać wynik z konsoli? i poprawka, jestem dziewczyną ;]


(kuba3351) #4

Robisz zrzut ekranu, lub wklejasz tutaj zrzut ekranu, a to że jesteś dziewczyną nie ma znaczenia :smiley:


(marcin82) #5

Uruchom terminal / konsolę, potem wpisz taką komendę i Enter:

sudo apt-get update

Wszystko co pojawi się na ekranie zaznacz myszką i skopiuj, wklej na forum w tagach code.


(Agnieszkasowinska2201) #6

gdyby jeszcze mi się skopiować chciało.


(pocolog) #7

Wykonaj polecenie:

apt-get update > /root/plik_do_pokazania_na_forum.txt

w katalogu /root/ pojawi się nowy plik z którego przekopiuj zawartość tutaj. Jeśli nie wykrywa Ci myszki to w menu bodajże urządzenia możesz zaznaczyć myszkę usb ew. przeszukaj opcje maszyny wirtualnej aby przechwytywała mysz. W maszynie wirtualnej możesz też ustawić współdzielony katalog między systemem gospodarzem i przekopiować go tam.


(roobal) #8

Jaki typ połączenia sieciowego masz w VirtualBox? Sprawdź czy jest odpowiedź na pingowanie.

ping -c 4 8.8.8.8

(Agnieszkasowinska2201) #9

dalej nic. może najprostrzym rozwiązaniem by było zdalne sterowanie?


(roobal) #10

Czekam na odpowiedź.

Bez podłączenia do sieci możesz o tym zapomnieć.


(GBM) #11

 

Sprawdź czy w VirtualBox w ustawieniach Twojej maszyny wirtualnej ustawiłeś kartę sieciową w trybie bridged/mostkowanym.

Innym sposobem jest sprawdzenie czy w ogóle Twój interfejs sieciowy jest widziany  w systemie. W tym celu wpisz polecenie

sudo ifconfig

I sprawdź czy masz widoczny interfejs “eth0”, a także przypisany adres. Powinno to wyglądać mniej więcej tak:

 

4d35b472ac3a1104gen.png

 

Jeśli takowego nie masz wykonaj następujące polecenia:

sudo ifconfig eth0 up
sudo /etc/init.d/networking restart
sudo ifconfig

Jeśli nadal nie masz przypisanego adresu IP wklep polecenie:

dhclient eth0

Spróbuj wykonać powyższe czynności i daj znać jaki efekt ostateczny wyszedł…