Ubuntu-nie działa LiveCD, zmiana rozdzielczości w VirtualBox


(baciany) #1

Ściągnąłem Ubuntu 8.10. nagrałem na Płytkę DVD. W VirtualBox wszystko startuje tylko tyle że nie ma Efektów pulpitu oraz jest w rozdzielczości max 800x600 (a chcę 1680x1050). Znowu jak próbuje uruchomić Ubuntu na "normalnym" komputerze w trybie Live to system się ładuje *ten pasek taki lata) potem staje na kilka minut, znowu się ładuje. Potem pojawiają się napisy Starting Coośtam [ok] i tak dalej. Potem dochodzi do Starting Bluetooth i tak staje. W prawym dolnym rogu mryga tylko kreseczka..

Pytanie 1: jak mam uruchomić to Live Ubuntu

Pytanie 2: jak zmienić rozdzielczość ubuntu w VirtualBox (max 800x600 jet dostępne a ja pragnę 1680x1050).


(SxMaN) #2

Pyt 1: Live uruchom w trybie bezpiecznym(nie pamiętam jak to się dokładnie nazywa, ale wyłącza masę rzeczy które mogą powodować ten twój zwis).

Pyt 2: Samym VirtualBoxem nie zmienisz rozdzielczości, możesz to zrobić w ubuntu uruchomionym w VirtualBoxie.


(baciany) #3

Właśnie w tym rzecz że w Samym Ubuntu też nie mogę. 800x600 lub mniejsza jest dostępna tylko..


(B Brachaczek) #4

Do drugiego problemu: Zainstaluj przede wszystkim Guest Additions (przy uruchomionej maszynie wybierz w menu Urządzenia -> Zainstaluj Dodatki, potem wejdź w konsolę, wpisz: sudo /media/cdrom/VBoxLinuxAdditions-x86.run , po czym zrestartuj maszynę). Potem wykonaj sudo gedit /etc/X11/xorg.conf i w nowym okienku dodaj do sekcji Device wpis Driver "vboxvideo" , a do sekcji Screen coś takiego:

DefaultDepth 24


 Subsection "Display"

  Depth 24

  Modes "1680x1050" "1280x800" "1024x768" "800x600"

  ViewPort 0 0

 EndSubsection

Potem wyloguj się i zaloguj ponownie, powinna być taka rozdzielczość, jaką chcesz, a nawet powinna być ustawialna w menu Ubuntu.

Dla efektów pulpitu musisz jeszcze mieć włączoną akcelerację 3D w ustawieniach danej maszyny wirtualnej (tym razem przy wyłączonej). Tylko musisz mieć VirtualBoksa w wersji minimum 2.1.0.


#5

beevvy , też miałem podobny problem. Teraz wszystko działa jak trzeba. Dzięki.


(baciany) #6

DZIAŁA. HURRA. Dzięki działa.

P.S.

A dokładniej jak tą Akceleracje 3d włączyć ? Zaznaczyłem Enable 3d akceleration Ale Efektów jak było tak nie ma..


(Brtx) #7

Poczytaj instrukcję. Akceleracja działa tylko dla Windows.

Strona 67:


(B Brachaczek) #8

Eh, przepraszam za wprowadzenie w błąd. Przyznam, że nie próbowałem tej opcji. Za kilka miesięcy pewnie wydadzą wersję ze wsparciem dla innych systemów.


(baciany) #9

Kilka miesięcy.... za ten czas to mi się linux Znudzi.

Dobra dzięki za Informacje i Za pomoc !!