UBUNTU - Nie moge odpalić systemu


(Adi Superstar) #1

Witam.

Problem pojawił mi się z dnia na dzień. Wczoraj jeszcze było wszystko OK, komp pracował idealnie, łącznie z zamknięciem systemu. Ale dziś już nie mogę go odpalić. Od 3 dni nie miałem żadnych nowych aktualizacji. Chciałbym uniknąć formata. Po włączeniu kompa ładuje mi sie to i stoi:

IMG_20110209_165154.jpg

Problem dotyczy systemu UBUNTU 10.10

Czy mam coś nie tak z twardzielem czy wina leży po innej stronie?

POMOCY


(dragonn) #2

Masz podłączone jakieś urządzenia USB, spróbuj je po kolei odłączać. Trzeba dojść co powoduje problem. Choć wygląda to bardziej na problem z stertownik USB. Instalowałeś czasami jakieś nowe jądro, może spróbuj z gruba włączyć starsze, albo wypróbuj czy ruszy recorvery mode.


(Adi Superstar) #3

Racja. Kamerka internetowa powodowała część komunikatów. Tylko dlaczego dopiero po 3 miesiącach po instalacji systemu. Te komunikaty poginęły oczywiście po jej wypięciu, ale problem nie zniknął:

IMG_20110209_202909.jpg

A po kliknięciu na Recovery wyświetlane są takie komunikaty:

IMG_20110209_202147.jpg

Ps. Jestem raczkującym uzytkownikiem Linuxa i nie bardzo wiem jak należy poprawnie włączyć starsze jądro GRUB'a?!


(marcin82) #4

Witam.

Jeśli nie usuwałeś manualnie poprzedniego jądra i jeśli instalowałeś nowsze jądro, podczas startu systemu i wyświetleniu menu Gruba - wciśnij Shift - to anuluje domyślne odliczanie "timeout" i zobacz, czy jest na liście jądro z niższym numerem wersji.


(BenderBendingRodriguez) #5

Na górze przedostatniego screena masz chyba jakiś kernel oops. Niby nie może zamontować partycji, możesz pokazać różnicę pomiędzy wpisem recovery a normalnym który Ci wywala?


(Adi Superstar) #6

Recovery to ostatnie zdjęcie

A może tu jest problem, bo przy UBU 10.10 powinien być GRUB2 a mi wyświetla GNU GRUB wersja 1,98+20100804-5ubuntu3?


(BenderBendingRodriguez) #7

Tzn. tak, grub jeszcze nie osiągnął wersji 2.0 ale canonical uznał że jest wystarczająco stabilne że ustawili jak standardowe także wersję masz dobrą.

To jest jakiś problem z jądrem lub komendą w grubie przy standardowym jądrze, dobrze by było sprawdzić te dyski z jakiegoś livecd a następnie zrobić to co polecił kolega przede mną czyli spróbować zabootować na poprzednie jądro o ile go nie usunąłeś.


(Adi Superstar) #8

Brak poprzedniego jądra.

Uruchomiłem LiveCD i okazało sie, że moge sie dostać tylko do partycji z moimi (administrator) i syna (uzytkownik) plikami.

Do partycji, gdzie był zainstalowany system nie mogę sie dostac. Wyskakuje okienko:

"ERROR

Unable to mount 19 GB Filesystem

DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending"


(BenderBendingRodriguez) #9

Tzn. chodzi o to by partycję na której jest system sprawdzić na poziomie systemu plików za pomocą fsck. Jak uruchomisz LiveCD to otwórz terminal i sprawdź partycję systemową :

su (otrzymaj prawa roota, na livecd chyba su działa a jeśli nie to po prostu sudo fsck.ext4(jeśli masz inny system plików to zmień ext4 na inny) /dev/sdXY (X - dysk na który jest partycja systemowa, Y - partycja na tym dysku).

Jeśli wszystko będzie w porządku to możliwe że aktualizacja jądra poszła nie tak? W teorii zawsze można ten system zamontować z livecd i zainstalować np. inne jądro ale to już jest opis na dwadzieścia wpisów i dużo takich jest na internecie, wystarczy poszukać jako: chroot ubuntu


(Adi Superstar) #10

Podejrzewam, że padl mi dysk.

Oto co wywala w terminalu:

ubuntu@ubuntu:~$ fsck.ext4 panyrcdfvtDFV

e2fsck 1.41.12 (17-May-2010)

fsck.ext4: No such file or directory podczas próby otworzenia panyrcdfvtDFV

superblok nie mógł być odczytany lub nie opisuje prawidłowego systemu

plików ext2. Jeżeli urządzenie jest prawidłowe i naprawdę zawiera

system plików ext2 (nie jest swapem, ufs-em ani niczym innym),

to superblok jest uszkodzony - można próbować uruchomić e2fsck z innym

superblokiem:

e2fsck -b 8193

Dysk 80GB mam podzielony na 2 partycje. 19GB ext4 sda1, 60GB ext4 sda2 i 1,5GB SWAP. Pod LiveCD w partycji 60GB mogę bez problemu podejrzeć pliki i foldery (żadnych wewnętrznych zmian). Natomiast na partycji 19GB (gdzie był system) wystepuje brak odpowiedzi lub:

ERROR

Unable to mount 19 GB Filesystem

DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending


(BenderBendingRodriguez) #11

Nie sądzę aby Ci padł dysk skoro inna partycja na tym samym dysku Ci działa. Czy wyłączyłeś może przypadkowo komputer z zasilania ? Dane na partycji systemowej mogły ulec uszkodzeniu.

Spróbuj odmontować ten dysk

sudo umount /dev/sda1

nastepnie

sudo fsck.ext4 -cfv (nic nie zmieni w systemie plików, sprawdzi poprawność, jeśli wyskoczą jakieś błędy sprawdź następnie dysk za pomocą

sudo fsck.ext4 -fv

(ale postaraj się odmontować ), wyłączyć automontowanie w GNOME, odmontować w konsoli za pomocą umount i następnie sprawdzić dysk.


(Adi Superstar) #12

ubuntu@ubuntu:~$ sudo umount /dev/sda1

umount: /dev/sda1: not mounted

a przy każdej innej komendzie wywala:

superblok nie mógł być odczytany lub nie opisuje prawidłowego systemu

plików ext2. Jeżeli urządzenie jest prawidłowe i naprawdę zawiera

system plików ext2 (nie jest swapem, ufs-em ani niczym innym),

to superblok jest uszkodzony - można próbować uruchomić e2fsck z innym

superblokiem:

e2fsck -b 8193


(BenderBendingRodriguez) #13

W takim razie postaraj się go sprawdzić

sudo fsck.ext4 -v /dev/sda1


(Adi Superstar) #14

ubuntu@ubuntu:~$ sudo fsck.ext4 -v /dev/sda1

e2fsck 1.41.12 (17-May-2010)

fsck.ext4: Device or resource busy podczas próby otworzenia /dev/sda1

System plików zamontowany lub otwarty na wyłączność przez inny program?


(BenderBendingRodriguez) #15

W takim razie jest to conajmniej dziwne jeśli nie jest zamontowane, czy przypadkiem nautilus nie stara się go montować cały czas?

Zresztą nieważne, sprawdź dysk za pomocą (z livecd)

sudo fsck.ext4 -cfv (sprawdzi dysk w trybie do odczytu)


(Adi Superstar) #16

Ciągle te same komunikaty


(BenderBendingRodriguez) #17

Z tego co mi się wydaje to Ubuntu ciągle stara się zamontować ten dysk więc musisz zabić proces automounter czy coś takiego, jeśli pomimo tego będzie coś nie tak to albo reinstalka albo odzyskanie danych jeśli są jakieś cenne.


(Adi Superstar) #18

Screenshot2.png

Screenshot-3.png

W okienku pierwszej partycji cały czas trwa wczytywanie. nic nie mogę zrobić z ta partycją. powyższa komenda również nie działa.


(BenderBendingRodriguez) #19

Zrób tak

ps -A | grep autofs (w odpowiedzi pokaże Ci nazwę tego procesu i numer nazwijmy go X)

następnie zabij ten proces X

sudo kill X (albo "sudo su" i następnie zabij), dla pewności zabij demona autofs (albo spróbuj to najpierw przed zabiciem :wink:

/etc/init.d/autofs stop

Po tym powinieneś być w stanie sprawdzić partycję.


(Adi Superstar) #20

Po ps -A | grep autofs nic sie nie pojawiło.

Po samej komendzie ps -A to:

PID TTY TIME CMD

    1 ? 00:00:00 init

    2 ? 00:00:00 kthreadd

    3 ? 00:00:00 ksoftirqd/0

    4 ? 00:00:00 migration/0

    5 ? 00:00:00 watchdog/0

    6 ? 00:00:02 events/0

    7 ? 00:00:00 cpuset

    8 ? 00:00:00 khelper

    9 ? 00:00:00 netns

   10 ? 00:00:00 async/mgr

   11 ? 00:00:00 pm

   12 ? 00:00:00 sync_supers

   13 ? 00:00:00 bdi-default

   14 ? 00:00:00 kintegrityd/0

   15 ? 00:00:00 kblockd/0

   16 ? 00:00:00 kacpid

   17 ? 00:00:00 kacpi_notify

   18 ? 00:00:00 kacpi_hotplug

   19 ? 00:00:00 ata_aux

   20 ? 00:00:00 ata_sff/0

   21 ? 00:00:00 khubd

   22 ? 00:00:00 kseriod

   23 ? 00:00:00 kmmcd

   26 ? 00:00:00 khungtaskd

   28 ? 00:00:00 kswapd0

   29 ? 00:00:00 ksmd

   30 ? 00:00:00 aio/0

   31 ? 00:00:00 ecryptfs-kthrea

   32 ? 00:00:00 crypto/0

   38 ? 00:00:00 kstriped

   39 ? 00:00:00 kmpathd/0

   40 ? 00:00:00 kmpath_handlerd

   41 ? 00:00:00 ksnapd

   42 ? 00:00:00 kondemand/0

   43 ? 00:00:00 kconservative/0

  275 ? 00:00:00 scsi_eh_0

  276 ? 00:00:00 scsi_eh_1

  293 ? 00:00:00 scsi_eh_2

  294 ? 00:00:00 scsi_eh_3

  304 ? 00:00:00 radeon/0

  305 ? 00:00:00 ttm_swap

  312 ? 00:00:09 kslowd000

  313 ? 00:00:09 kslowd001

  412 ? 00:00:00 jbd2/sda1-8

  451 ? 00:00:00 aufsd/0

  452 ? 00:00:00 aufsd_pre/0

  465 ? 00:00:00 loop0

  481 ? 00:00:00 usbhid_resumer

 1251 ? 00:00:00 upstart-udev-br

 1256 ? 00:00:00 rsyslogd

 1270 ? 00:00:00 dbus-daemon

 1285 ? 00:00:00 udevd

 1641 ? 00:00:00 hci0

 1651 ? 00:00:00 kpsmoused

 1656 ? 00:00:00 kgameportd

 1685 ? 00:00:00 avahi-daemon

 1689 ? 00:00:00 avahi-daemon

 1706 ? 00:00:00 NetworkManager

 1723 ? 00:00:00 bluetoothd

 1740 ? 00:00:00 modem-manager

 1745 ? 00:00:00 l2cap

 1821 ? 00:00:00 krfcommd

 1833 ? 00:00:00 wpa_supplicant

 1838 ? 00:00:00 dhclient

 1881 tty4 00:00:00 login

 1884 tty5 00:00:00 login

 1899 tty2 00:00:00 login

 1901 tty3 00:00:00 login

 1908 tty6 00:00:00 login

 1912 ? 00:00:00 acpid

 1919 ? 00:00:00 atd

 1920 ? 00:00:00 cron

 1928 ? 00:00:00 cupsd

 2251 ? 00:00:00 console-kit-dae

 2568 tty4 00:00:00 bash

 2569 tty3 00:00:00 bash

 2570 tty6 00:00:00 bash

 2571 tty5 00:00:00 bash

 2572 tty2 00:00:00 bash

 2759 tty1 00:00:00 login

 2818 tty1 00:00:00 bash

 2994 ? 00:00:00 upowerd

 2998 ? 00:00:00 udisks-daemon

 2999 ? 00:00:00 pulseaudio

 3002 ? 00:00:00 rtkit-daemon

 3004 ? 00:00:00 polkitd

 3007 ? 00:00:00 udisks-daemon

 3085 ? 00:00:00 gconf-helper

 4278 ? 00:00:00 udevd

 4282 ? 00:00:00 udevd

 4372 ? 00:00:00 gdm-binary

 4380 ? 00:00:00 gdm-simple-slav

 4383 tty7 00:05:03 Xorg

 4394 ? 00:00:00 gdm-session-wor

 4403 ? 00:00:00 gnome-session

 4433 ? 00:00:00 ssh-agent

 4436 ? 00:00:00 dbus-launch

 4437 ? 00:00:00 dbus-daemon

 4442 ? 00:00:01 gconfd-2

 4447 ? 00:00:00 gnome-power-man

 4450 ? 00:00:00 gnome-keyring-d

 4453 ? 00:00:02 gnome-settings-

 4459 ? 00:00:00 gvfsd

 4465 ? 00:00:00 bluetooth-apple

 4466 ? 00:00:00 gvfs-fuse-daemo

 4467 ? 00:00:00 evolution-alarm

 4470 ? 00:00:00 polkit-gnome-au

 4472 ? 00:00:05 gnome-panel

 4477 ? 00:00:00 gvfs-gdu-volume

 4479 ? 00:00:00 gvfs-gphoto2-vo

 4481 ? 00:00:00 gvfs-afc-volume

 4485 ? 00:00:46 compiz

 4486 ? 00:00:06 nautilus

 4490 ? 00:00:00 nm-applet

 4530 ? 00:00:00 gnome-screensav

 4533 ? 00:00:00 gdu-notificatio

 4536 ? 00:00:00 bonobo-activati

 4551 ? 00:00:07 wnck-applet

 4552 ? 00:00:00 trashapplet

 4558 ? 00:00:00 gvfsd-trash

 4568 ? 00:00:00 indicator-apple

 4569 ? 00:00:00 clock-applet

 4570 ? 00:00:00 indicator-apple

 4571 ? 00:00:00 notification-ar

 4587 ? 00:00:00 gvfsd-burn

 4588 ? 00:00:00 sh

 4589 ? 00:00:02 gtk-window-deco

 4593 ? 00:00:00 indicator-appli

 4595 ? 00:00:00 indicator-messa

 4600 ? 00:00:00 gvfsd-metadata

 4611 ? 00:00:00 indicator-sound

 4614 ? 00:00:00 indicator-me-se

 4616 ? 00:00:00 indicator-sessi

 4618 ? 00:00:00 applet.py

 4621 ? 00:00:00 update-notifier

 4696 ? 00:03:29 palimpsest

 4699 ? 00:00:00 mount

 4701 ? 00:00:00 firefox

 4705 ? 00:00:00 run-mozilla.sh

 4709 ? 00:04:26 firefox-bin

 5167 ? 00:00:00 gnome-terminal

 5170 ? 00:00:00 gnome-pty-helpe

 5171 pts/0 00:00:00 bash

 5220 pts/0 00:00:00 ps