Ubuntu nie widzi partycji


(Legopatryk223) #1

Witam. Chciałbym zainstalować Ubuntu na laptopie obok windowsa 8 (ale na osobnej partycji). I tu jest problem, ponieważ instalator (gparted również) nie widzi podziału dysku na partycje które podzieliłem na windowsie tylko cały dysk. Mam uefi i gpt. Da się to naprawić bez utraty plików ?


(ubuuser) #2

Da się - pliki zabezpiecz sobie na jakimś nośniku, a po konwersji GPT do MBR je przywrócisz :slight_smile:


(Legopatryk223) #3

A więc nie ma możliwości zainstalowania Ubuntu na GPT ?


(Piotrstepinski1904) #4

Najpierw parę pytań bo podałeś tyle danych że będę musiał poprosić kolegę o pożyczenie szklanej kuli :slight_smile:

Jaki to laptop?

Ma secure boot?

pracuje napewno w trybie uefi?

instalkę ubuntu uruchamiasz w trybie uefi czy legacy? (też taki problem miałem jak uruchamiałem płytę w trybie legacy)

Jaka wersja ubuntu?

Płyta czy pendrive / jak przygotowane?

Dysk działa na pewno w GPT? / sprawdzałeś w wnindowsie?

 


(Legopatryk223) #5

A więc tak:

Model laptopa: samsung np350e5c-s05pl

Ma secure boot ale wyłączyłem w biosie

Na 100% mam uefi i GPT bo sprawdzałem na windowsie

Ubuntu 14.04 lts na pendrive przygotowane w Universal Usb Installer

I teraz w jakim trybie uruchamiam, to myślę że chodzi ci o to: (mam ustawione na uefi os)

https://zapodaj.net/3ecc2cadf542e.jpg.html


(Piotrstepinski1904) #6

ubuntu obsługuje secure boot więc włączony czy wyłączony obojętne

Ubuntu oczywiście 64 bit?

Próbowałeś nagrać na płytę / ten sam efekt?

jak wygląda boot:

tak:bios.thumb.png.c4ca0773faabf64fba2a431f6

czy tak:uefi.thumb.jpg.ae0fcd1904fc99a339c3d168a

 

“nie widzi podziału dysku na partycje” dałbyś rade zrobić zdjęcie/screen jak to wygląda w instalatorze lub gparted?

ps. Jestem wariatem na punkcie zdjęć/screenów więc sorry na prośbę o to. :slight_smile:

 

“które podzieliłem na windowsie” = na windowsie = ntfs -linux zobaczy takie partycje a nawet może z nich korzystać, ale się nie instaluje linuxa na ntfs tylko na ext4

 

Życze powodzenia w w szukaniu problemu. :slight_smile:


(Legopatryk223) #7
  1. Ubuntu tak 64 bit

  2. Nie próbowałem odpalać płyty, ale myślę że efekt będzie taki sam

3.Boot wygląda następująco: https://zapodaj.net/d3b63fcb77355.jpg.html

  1. Zdjęcie z gparted: https://zapodaj.net/54a1eb9c5190f.jpg.html

  2. Wiem że windows na ntfs a linux ext4. Chodziło mi o to że zmniejszyłem partycje E aby utworzyć wolne miejsce na którym miałem zamiar zainstalować Ubuntu

  3. Dzięki :wink:


(Piotrstepinski1904) #8

spróbuj z płyty jak masz taką możliwość

fastboot wyłączony?

http://www.ubuntu-pomoc.org/instalator-ubuntu-nie-widzi-partycji/ - (stare ale warto chyba zobaczyć)

ile partycji masz i jakie (daj jakiś screen z układu obecnego)

odpal terminal na LiveCD i zarzuć wynik:

sudo su

 

Wiele razy instalowałem ubuntu oraz debian’a i nigdy nie spotkałe takiej sytuacjii, więc jestem prawdopodobnie tak samo zdziwiony jak ty,