Ubuntu - partycje się nie montują


(Adrian 1987) #1

Zainstalowałem sobie jeszcze raz 9.04. Podczas instalacji wybrałem punkty montowania dla partycji ale po uruchomieniu nie są zamontowane. Wszystko robiłem tak jak zawsze montuje partycję (też ntfs) ale nic z tego. Wklepywałem do konsoli np. sudo mount /dev/sda5 /mnt/Moje i wyskakuje

czyli jest zamontowana.

fstab wygląda tak:

Pliki są w tych katalogach w których powinny ale nie widać ikon partycji ani w "Miejsca" ani na pulpicie ani w nautilusie.


(nintyfan) #2

Poszukaj, jak to zmienić w GConf. Szukaj pod hasłami GConf, Nautilus, Mój komputer.

To jest normalne zachowanie w GNOME. GNOME tylko wyświetla ikonki dla nośników zewnętrznych, a w oknie mój komputer dodatkowego dla głównego korzenia. Można to zmienić właśnie poprzez GCONF-a usuwając wpisy z /etc/fstab, a posiłkując się innym mechanizmem.

Rozwiązanie problemu jednak jest błahe. Dodaj sobie skrót dla katalogu /mnt na pulpicie.


(Kornicameister) #3

czy ten problem to dokładnie to samo co moj ?

u mnie są właśnie widoczne ikony, ale partycje windy (2) nie są od razu zamontowane, trzeba na nie kliknąć i wtedy się montują :slight_smile:

# /etc/fstab: static file system information.

#

# Use 'vol_id --uuid' to print the universally unique identifier for a

# device; this may be used with UUID= as a more robust way to name devices

# that works even if disks are added and removed. See fstab(5).

#

# 

proc /proc proc defaults 0 0

# / was on /dev/sda6 during installation

UUID=944ac721-fad4-432d-8bb0-6d2a534cad08 / ext4 relatime,errors=remount-ro 0 1

# swap was on /dev/sda5 during installation

UUID=0e80cb08-ba57-4d96-bd14-03f64dbb59c5 none swap sw 0 0

/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

brakuje wpisów do partycji sda2 i sda3, co mnie dziwi, bo w każdym poprzednim distro nie musiałem tego sam wpisywać, było od razu


(roobal) #4

Z tego co pamiętam w Ubuntu ntfs nigdy nie były montowane automatycznie, tylko dopiero po kliknięciu, za montowanie w Gnome odpowiada gnome-mount i zapewne jak pisał nintyfan można zmieniać ustawienie w Gconf. Z tego co jest napisane w twoim fstab, że podczas instalacji podałeś pkt montowania tylko dla sda5 i 6, dopisz po prostu do fstab, daj odpowiednie opcje. Natomiast umcs, dodaj do pozycji options do pktu montowania /mnt/Moje opcję defaults,user.

Pozdrawiam!


(Adrian 1987) #5

Problem dotyczył wszystkich partycji, nie tylko ntfs. Zaktualizowałem dzisiaj do 9.10, system się posypał tak, że huhu, zainstalowałem Kubuntu ale wracam już do GNOME. Więc problemu nie ma już.


(roobal) #6

Ponieważ 9.10 to wersja niestabilna/testowa i to mogło być przyczyną. Inną przyczyną wysypania systemu jest również bałagan lub nieoficjalne repozytoria albo repo z innych systemów, np. Debiana. Systemy oczywiście można mieszać, jeśli potrafi się nad tym utrzymać kontrolę :slight_smile:

Pozdrawiam!


(Adrian 1987) #7

Po ponownym zainstalowaniu 9.04 znowu partycje nie chciały się zamontować za Chiny więc zmieniłem punkt montowania z /mnt/ na /media/ i działa jak należy. Cały czas pisałem o systemie plików ext4 więc nie wiem dlaczego rozmowa zaczęła się o ntfs.


(roobal) #8

Bo tu się wtrącił Kornica :slight_smile:

Pozdrawiam!


(Kornicameister) #9

nie wtrącił, a grzecznie zapytał :twisted: :lol: