Ubuntu problem z Internetem


(Piotrro36) #1

Dzień dobry,


(bob999) #2

Witam, spróbuj tego : Ustawienia systemowe/ Oprogramowanie i aktualizacja/ zakładka dodatkowe sterowniki - kliknij i poczekaj czy znajdzie. Jeśli tak to sprobuj użyć tego sterownika.

 


(Piotrro36) #3

Niestety, nie znalazło sterownika


(marcin82) #4

Podaj wynik komendy z terminala:

lspci -k | grep -A2 Eth

 


(Piotrro36) #5
02:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 08)
	Subsystem: Lenovo AR8161 Gigabit Ethernet
	Kernel driver in use: alx
	Kernel modules: alx

 


#6

cat /etc/resolv.conf?


(Piotrro36) #7
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

Próbowałem też zmienić na 8.8.8.8 (DNS googla), niestety nic nie pomogło, a po restarcie wróciło do 127.0.1.1


#8

A to przeczytałeś:

 Poczytaj o zmianie DNSów w Ubuntu. Pewnie da sie to wyklikać.


(Piotrro36) #9

Problem w tym, że chyba nie chodzi o DNS. Myślę, że gdyby DNS źle działał, to nie byłbym w stanie w ogóle połączyć się z Internetem. Jak już pisałem, przez około 30-45 sekund od włożenia wtyczki wszystko działa dobrze, potem coś nawala.

Spróbuję pobawić się z tym DNS, może jednak to pomoże. Na pewno lepsze próbowanie, niż bezczynne czekanie.


#10

W takim razie wpisz

i podaj wynik, a następnie

i też podaj wynik.


(dragon321) #11

DNS nie ma nic do rzeczy przy połączeniu internetowym - internet równie dobrze pracuje bez niego.


#12

W takim razie usuń w swoim systemie adresy serwerów DNS i powiedz jak korzysta Ci się z sieci.


(dragon321) #13

Normalnie, tylko mniej wygodnie, bo zamiast adresów stron muszę podawać ich IP. Tyle.


(Piotrro36) #14

Areh:

piotr@Espadon:~$ ping dobreprogramy.pl
ping: unknown host dobreprogramy.pl
piotr@Espadon:~$ ping 194.0.171.163
PING 194.0.171.163 (194.0.171.163) 56(84) bytes of data.
From 192.168.0.13 icmp_seq=1 Destination Host Unreachable
From 192.168.0.13 icmp_seq=2 Destination Host Unreachable
From 192.168.0.13 icmp_seq=3 Destination Host Unreachable
From 192.168.0.13 icmp_seq=4 Destination Host Unreachable
From 192.168.0.13 icmp_seq=5 Destination Host Unreachable
From 192.168.0.13 icmp_seq=6 Destination Host Unreachable
From 192.168.0.13 icmp_seq=7 Destination Host Unreachable
From 192.168.0.13 icmp_seq=8 Destination Host Unreachable
^C
--- 194.0.171.163 ping statistics ---
10 packets transmitted, 0 received, +8 errors, 100% packet loss, time 9047ms
pipe 3

dragon321:


#15

To pewnie nie to, ale możesz podać jeszcze wynik:

A najlepiej wyłącz DHCP i ustaw wszystko ręcznie.


(Piotrro36) #16
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.0.1 0.0.0.0 UG 100 0 0 enp2s0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 enp2s0
192.168.0.0 0.0.0.0 255.255.255.0 U 100 0 0 enp2s0

Jak mogę wyłączyć DHCP? I ręcznie ustawić IP, maskę - coś jeszcze?


#17

A to to już chyba lenistwo.

https://www.google.com/search?q=ubuntu+konfiguracja+sieci&ie=utf-8&oe=utf-8&client=firefox-b

pierwszy link.


(Piotrro36) #18

Nie pomogło


#19

Wybacz, ale przytłoczył mnie ogrom informacji które podałeś w ostatnim poście. Jeszcze je trawię.


(Piotrro36) #20

Samemu postanowiłeś pomóc, a teraz w każdym poście ironicznie po mnie jedziesz, bo jesteś wkurzony że musisz coś napisać. To musi być naprawdę irytujące, kiedy sam z własnej, nieprzymuszonej woli chcesz komuś pomóc.

Napisałem tak mało, bo przytłoczył mnie ogrom informacji z Twojego wcześniejszego postu.
 

Jakże nieoceniona okazała się Twoja pomoc.

Ale dobrze, rozwinę wypowiedź.
Wykonałem wszystko to, co zostało opisane tu https://www.google.com/search?q=ubuntu+konfiguracja+sieci&ie=utf-8&oe=utf-8&client=firefox-b  w pierwszym linku. Niestety nic nie pomogło i problem nie został rozwiązany. Dalej strony się nie ładują, a liczba overruns wciąż rośnie.

 

 

 

Mam nadzieję, że dostrzeżesz parodię siebie w wyższym tekscie.

 

Temat można usunąć. Nie udało się rozwiązać problemu. Zainstalowałem Debiana i wszystko działa. Ubuntu najprawdopodobniej nie ma, albo ma niepoprawnie działające sterowniki do mojej karty sieciowej.