Ubuntu - system nie rozpoznaje karty dźwiękowej


(kurzoczek) #1

Witajcie. Mam taki problem. System nie rozpoznaje karty dźwiękowej. Co ciekawe: dźwięk w Chrome działa, ale gdy już staram się uruchomić alsamixer, to wyświetla mi, że nie może znaleźć urządzenia. 

 

Macie pomysły?


(Linka) #2

Spróbuj skorzystać z programu pavucontrol, zamiast alsamixer. Ubuntu korzysta obecnie z PulseAudio, a ALSA jedynie pośredniczy między Pulse, a sprzętem. Jeśli masz coś wyciszone tam, to alsamixerem nie naprawisz. Chociaż to dziwne, że w alsamixerze nie widać Twojej karty. Z jakiej konkretnie korzystasz? Intel, NVIDIA (HDMI), Realtek?

Podaj wynik komendy:

cat /proc/asound/cards

 


(kurzoczek) #3

Pavucontrol nie działa: 

 

cat /proc/asound/cards dało wynik: 

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                     HDA Intel PCH at 0x90a10000 irq 93

 

1111.png


(Linka) #4

Spróbuj włączyć pulseaudio w terminalu i jeśli pojawią się jakieś błędy, to wklej. A masz w ogóle włączony sterownik od Intel HDA? 

lsmod | grep hda_intel

Powinno się wyświetlić ‘snd_hda_intel’ i jakieś numerki, jeśli nie, aktywuj sterownik:

sudo modprobe snd_hda_intel

 


(kurzoczek) #5

Wynik polecenia lsmod | grep hda_intel:  1111.png

 

Co ciekawe: tak jak wspominałem wcześniej w przeglądarce Google Chrome dźwięk jest, w innych aplikacjach także, a już na przykład ze Skype nie mogę korzystać, gdyż nie rozpoznaje urządzeń dźwiękowych(w ustawieniach Skype wyświetla mi jakieś Virtual Devices).

 

Kurczę spróbuję nowy kernel wgrać. Może to jakiś problem ze sterownikami.

Dodam - chociaż może za bardzo mącę - że w Debianie Jessie miałem podobny problem w wyniku tego samego działania, czyli po próbie kompilacji najnowszego Wine.


(kurzoczek) #6

Przerxuciłem system. Temat do zamknięcia.