Ubuntu9.04 laptop brak dźwięku w głośnikach


(mateusz6639) #1

Jak w temacie po zainstalowaniu UBUNTU 9.04 nie mam dźwięku w głośnikach laptopa ASUS M51T, dźwięk jest dopiero po podłaczeniu słuchawek ale tylko w słuchawkach. Suwaki w alsamikser nie są wyzerwane. Odhaczenie przełącznika głośniki/słuchawki nic nie da.

Po wpisaniu lspci, wykrywa mi:

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge

00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)

00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)

00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)

00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)

00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)

00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]

00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller

00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller

00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller

00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller

00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller

00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller

00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)

00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller

00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge

00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller

00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 11h HyperTransport Configuration (rev 40)

00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h Address Map

00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 11h DRAM Controller

00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 11h Miscellaneous Control

00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 11h Link Control

01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]

02:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series

02:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]

03:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

08:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)

08:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)

08:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)

08:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)

Proszę o pomoc


(Revolver0) #2

Napisze tak karta dźwiękowa jest wykrywana więc w ubuntowskim mikserze musisz odhaczyć ptaszki przy wycisz dany kanał.


(mateusz6639) #3

wszystkie kanały są odhaczone a dźwięku nie ma. Jestem początkującym użytkownikiem linuxa więc proszę o wyrozumiałość.


(Revolver0) #4

spróbuj sudo alsaconf, alsaconfig, polecenie które jeszcze raz konfiguruje kartę dźwiękową.


(mateusz6639) #5

jest to samo. Jak uruchomię ubuntu z live cd, to jest identycznie (dźwięk w głośnikach nie działa)


(Revolver0) #6

Zapodaj jakieś screeny mixera alsy i ubuntowego miksa. I najważniejsze spróbuj odpalić notka z innej dystrybucji np. starszy ubuntu, slax, fedora, czy jakieś inne dystro livecd. Może tylko ubunciak ma problemy.


(Porchekarera) #7

Ja musiałem dodać surround więc jeśli go nie masz to dodaj i wyłącz wyciszenie.


(mateusz6639) #8

jak uruchomiłem mandrive one to było to samo.

Screeny:


(Revolver0) #9

Jaka wersja alsy to juz wiem ze screna 1.0.18, może alsa źle osbuguje twoją kartę dźwiękową i istalacja nowej wersi pomoże i jeszcze jedno co masz w pliku /etc/modprobe.d/alsa-base lub podobnym w ubunciu. Zgłoś to iec958 iec958 d może pomoże.


(mateusz6639) #10

alsa-base.conf

autoloader aliases

install sound-slot-0 /sbin/modprobe snd-card-0

install sound-slot-1 /sbin/modprobe snd-card-1

install sound-slot-2 /sbin/modprobe snd-card-2

install sound-slot-3 /sbin/modprobe snd-card-3

install sound-slot-4 /sbin/modprobe snd-card-4

install sound-slot-5 /sbin/modprobe snd-card-5

install sound-slot-6 /sbin/modprobe snd-card-6

install sound-slot-7 /sbin/modprobe snd-card-7

Cause optional modules to be loaded above generic modules

install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }

Workaround at bug #499695 (reverted in Ubuntu see LP #319505)

install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }

install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }

install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }

Cause optional modules to be loaded above sound card driver modules

install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }

install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)

install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }

Prevent abnormal drivers from grabbing index 0

options bt87x index=-2

options cx88_alsa index=-2

options saa7134-alsa index=-2

options snd-atiixp-modem index=-2

options snd-intel8x0m index=-2

options snd-via82xx-modem index=-2

options snd-usb-audio index=-2

options snd-usb-us122l index=-2

options snd-usb-usx2y index=-2

options snd-usb-caiaq index=-2

Ubuntu #62691, enable MPU for snd-cmipci

options snd-cmipci mpu_port=0x330 fm_port=0x388

Keep snd-pcsp from beeing loaded as first soundcard

options snd-pcsp index=-2


(Revolver0) #11

Może będziesz musiał poczekać na nowszego ubunciaka i na razie słuchać muzyki przez słuchawki. https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/65752 powinno pomóc. Napisz czy pomoglo.

p.s.

ten model ma dwie karty graficzne jak to działa w praktyce np. na Windowsie zauważalna jakość obrazu czy wydajności podczas grania? E lipa myślałem, że to są mocne karty jedna to integra, a drugi to mobilny radeon HD 3650 z 512 mb ramu i nie można ich używać jednocześnie np. jak kart muzycznych.

Udało Ci się zmusić głośniki do odzewu.


(mateusz6639) #12

dzięki Revolver0 pomogło. Mam dźwięk :D:D:D Wiszę Ci piwo :stuck_out_tongue:

Please try this procedure:

Step 1: Open Terminal from "Applications->Accessories->

Terminal"

Step 2: Run the following command (copy/paste each command into the Terminal and then hit )

sudo gedit /etc/modprobe.d/alsa-base

Add the following 5 lines to the end of the alsa-base file:

options snd-pcsp index=-2

alias snd-card-0 snd-hda-intel

alias sound-slot-0 snd-hda-intel

options snd-hda-intel model=m51va

options snd-hda-intel enable_msi=1

Run the following command (copy/paste each command into the Terminal and then hit )

sudo gedit /etc/modprobe.d/options

Add the following 5 lines to the end of the options file:

options snd-pcsp index=-2

alias snd-card-0 snd-hda-intel

alias sound-slot-0 snd-hda-intel

options snd-hda-intel model=m51va

options snd-hda-intel enable_msi=1

Step 3: Reboot pc and retest sound.

Step 4: If audio output still does not work, please try one of the following model options (instead of m51va):

ALC662/663

3stack-dig 3-stack (2-channel) with SPDIF

3stack-6ch 3-stack (6-channel)

3stack-6ch-dig 3-stack (6-channel) with SPDIF

6stack-dig 6-stack with SPDIF

lenovo-101e Lenovo laptop

eeepc-p701 ASUS Eeepc P701

eeepc-ep20 ASUS Eeepc EP20

m51va ASUS M51VA

g71v ASUS G71V

h13 ASUS H13

g50v ASUS G50V

auto auto-config reading BIOS (default)

Regards,