Udostępnienie wejścia do internetu na drugi komputer


(Joemix) #1

Witam, serdecznie - napiszę co mam i co chciałbym zrobić, a czego nie mogę zrobić by to osiągnąć...

Komputer mam w dość rozbudowanej sieci, do której dostęp do świata gwarantują 3 radio linie (czy coś takiego) sieć jest głownie bezprzewodowa (między budynkami) natomiast w budynkach jest już kablowo (czyli maszt na dachy bloku (jeden na blok) a do domów kabelkami normalnie idzie)

Mieszkam w domku i sieć mam bezprzewodowo - na dachu mam antenę do której idzie przewód sieciowy tylko w domu przy kompie mam przelotkę która daje po drodze zasilanie... Adres mam przydzielany przez DHCP z puli 192.168.55.X i wszystko mi ładnie śmiga. Nie mam nigdzie ustawionych żadnych serverów proxy ani portów.

W komputerze mam drugą kartę sieciową i do niej doczepiam laptop lub komputer który współpracuje z TV z drugiego pokoju, chciałbym na tym sprzęcie mieć dostęp do interentu... i tu jest problem.

Większość sposobów jakie próbowałem nakazuje używanie adresów 192.168.X.X i od razu zaznaczam ze nie mogę tak zrobić gdyż nie będzie działało... Użycie adresu poniżej 192.168.128.X powoduje od razu konflikt a wyższe działają i komputery się połączą i teoretycznie będzie dobrze, ale jeden drugiego nie będzie widział... albo będzie działać tylko w jedną stronę (mówię o LAN) internet w ogóle nie działa...

Próbowałem programów typu PROXY ale nie działa albo raczej ja tego nie umiem ustawić, w necie znalazłem kiedyś info jak zbudować taką sieć na adresach 90.0.0.X i chodziło tylko jest jedno ale, wymagało to padania adresów servera proxy a ja np. na komputerze z TV tego zrobić nie mogę, bo nie przewidziano czegoś takiego w oprogramowaniu, również na laptopie jak są podane servery proxy to niby wszystko działa ale np. nie ładują sie aktualizacje lub nie działają pewne usługi/programy..

Czyli w sumie jak dobrze myślę to muszę zbudować w domu sieć i schować ją za NATem, tak jak mój komputer jest schowany za NATem serwera do którego się łączy... Miałem program który dobrze w marę chodził jako "transparent proxy" czy coś na adresach 90.0.0.X i miał w opcjach "full NAT" ale jak to wybrałem to klientom od razu przydzielał adresy 192.168.X.X i były problemy...

Znam się na sieciach tyle co w necie wyczytałem czyli wcale :mrgreen:


(system) #2

Kliknij z poziomu pulpitu na start - ustawienia - połączenia sieciowe i kliknij prawym przyciskiem na połączeniu dzięki któremu masz net wybierz właściwości a potem potem przejdz do zakładki zaawansowane i tam kliknij na zezwalaj innym użytkowikom sieci na łączenie się poprzez to połączenie internetowe tego komputera. I to w zasadzie wszystko A i tych adresów IP nie musisz zmieniać ustaw je na automatyczne


(Robin-Otzi) #3

jeśli chcesz podłączyć drugi komputer bezpośrednio to możesz dla drugiej karty ustawić wewnętrzne IP z puli 10.x.x.x i włączyć udostępnianie połączenia internetowego

ale faktycznie lepiej będzie wstawić wewnętrzny router z natem

który sam powinien przydzielić IP i wtedy nie powinno mieć znaczenia czy będzie to pula 10.x.x.x czy 192.168.x.x bo z zewnątrz będzie widziany tylko numer PI routera


(Joemix) #4

:-x :-x :-x Jak kiedyś chciałem włączyć udostępnianie połączenia internetowego to system od razu informował że adres tej karty zostanie zmieniony na 192.168.0.1 czy coś takiego, na pewno wyłączał mi automatyczne przyznawanie IP... a teraz tylko mi się łapka pojawiła... hmm... nie wiem czemu... mam świeża (kilka dni) instalacje systemu, ale nie sądzie... może jakieś stare programy czy coś, chociaż... poprzednia instalacja maiła ponad 5 latek... ...leceem po tableta zobaczyć czy działa... :stuck_out_tongue:

Złączono Posta : 23.09.2007 (Nie) 11:18

Ok, działamy dalej - jak mam skonfigurowane adresy automatycznie to na komputerze mam komunikat że sieć działa z ograniczeniami i mam adres 0.0.0.0 a na laptopie mam adres prywatny 169.245.247.68... czyli musze klepnąc adresy ręcznie... np. Ip: 10.0.0.1 maskę komputer proponuje sam: 255.0.0.0 a brama? a dalej?


(Robin-Otzi) #5

na jednym zrób 10.0.0.2 na drugim 10.0.0.3 i ustaw tą samą grupę roboczą

PS masz kabel skrosowany między nimi??


(Joemix) #6

Tak, kabel mam odpowiedni czyli taki do łączenia bezpośrednio 2 komputerów, nie wiem czy jest krosowany czy nie, ale w firmie jak się wpinam do HUBa to używam innego przewodu... Grupe roboczą komputery mają taką samą, rozumem że pozostałe pola (brama, dns i takie tam) zostawić puste...


(Robin-Otzi) #7

tak, mam nadzieję, że zadziała

ale z sieciami nigdy nic nie wiadomo...


(Joemix) #8

Nie działa :frowning:

Więc tak, na licznikach widać ze jakieś pakiety są odbierane i wysyłane... laptop pokapował się że ma sieć, bo wyskoczyła lista aktualizacji Windowsa do pobrania, ale nic nie działa... komputer stacjonarny widzi laptop w sieci, wszystko się ładnie pinguje... a na laptopie jak spinguje stacjonarkę to jest TimeOut a jak spingowałem laptop to się zawiesił :cry:

Złączono Posta : 23.09.2007 (Nie) 12:23

Wysłano/Odebrano, Laptop: 495 / 16 Komputer 1591 / 63 Tak mnie przeleciało przez myśl - może przewód walnięty?


(system) #9

(Joemix) #10

...192.168.0.1 :cry: Nie mogę uzywać adresów z puli 192.168.X.X a wszystkie programy i spece każą mi tak robić... konflikt mi wyskakuje że adres jest już w sieci jak używam puli 192.168.X.X

Złączono Posta : 23.09.2007 (Nie) 21:34

Więc tak, inny 100% sprawny przewód i coś się zaczęło dziać... na adresach 10.0.0.2/3 i masce 255.0.0.0... Komputery się widza odpowiadają na PINGi i działa sieć lokalna, ale Internet nie przełazi :frowning:

A, na komputerze mam Nortona 360, i żeby zadziałano musiałem go wyłączyć... warunkowo pozwolił mi na 10 minut... ruszyło jak napisałem wyżej, wszystko bez neta.. Teraz Norton się ponownie włączył i nadal chodzi, więc czemu wcześniej blokował albo jak go skonfigurować by mi dopuszczał ruch lokalny. Sprawny LAN to już 80% sukcesu :smiley: