Ukrycie programu z GUI przy starcie Linux Mint 17 Cinnamon


(system) #1

Witam, mam problem dość dobrze znany posiadaczom zintegrowanych kart dźwiękowych w Linuxie. Po podłączeniu słuchawek i odtwarzaniu muzyki lub filmów pojawia się szum i dźwięki jakby zakłóceń radiowych. Jest to tak irytujące, że korzystanie ze słuchawek odpada nawet po zatrzymaniu odtwarzania dźwięk ten zostaje, można go zatrzymać tylko odtwarzając jakikolwiek dźwięk systemowy. Nowy kernel 3.16 miał niby to poprawić, ale nie poprawił, sprawdziłem. Wgrywałem również różne łatki, ale nie pomagały. Jedyne rozwiązanie to włączenie aplikacji Pavucontrol (PulseAudio Volume Control), wtedy nie ma szumów ani tych denerwujących zakłóceń. Jednak do pełni szczęścia brakuje mi możliwości całkowitego ukrycia tego programu przy starcie. Chcę żeby był niewidoczny w każdym możliwym miejscu, czyli na pasku zadań w menu ALT-TAB i przy zmianie miejsca roboczego. System jaki posiadam to Linux Mint 17 64-bit Cinnamon, a notebook ASUS K50AB z kartą dźwiękową VIA T1708S. Problem ten występuje też na Debianie i każdej odmianie Ubuntu, Mint. Innych dystrybucji nie sprawdzałem.


(Juche) #2

Trochę z innej beczki: Może spróbuj wywalić PulseAudio i jechać na czystej ALSIE. Nie wiem, czy w Buntu-Mintu jest to możliwe bez rozkiełbaszenia 90% systemu, ale w Debianie,czy takim Archu na bank się tak da.


(system) #3

Próbowałem już wcześniej wywalenie PulseAudio i system się kiełbasi niestety. Fajny system, wszystko już pod siebie zrobiłem, jedynie ten błąd jest irytujący.


(marcin82) #4

Co się “kiełbasi”? Całkowicie usunąłeś PulseAudio? Co nie działało?

 

Podaj wynik:

dpkg -l | grep pulse

(Pompon7) #5

A sprawdzałeś zależności przed usunięciem pakietu pulseaudio?


(system) #6

Nie ładuje się Cinnamon. Czarny ekran i kursor tylko. Zaraz na notebooka wejdę i zobaczę co wyrzuca po tej komendzie.

ii gstreamer0.10-pulseaudio:amd64 0.10.31-3+nmu1ubuntu5 amd64 GStreamer plugin for PulseAudio
ii gstreamer1.0-pulseaudio:amd64 1.2.4-1~ubuntu1 amd64 GStreamer plugin for PulseAudio
ii libcanberra-pulse:amd64 0.30-0ubuntu3 amd64 PulseAudio backend for libcanberra
ii libpulse-mainloop-glib0:amd64 1:4.0-0ubuntu11 amd64 PulseAudio client libraries (glib support)
ii libpulse-mainloop-glib0:i386 1:4.0-0ubuntu11 i386 PulseAudio client libraries (glib support)
ii libpulse0:amd64 1:4.0-0ubuntu11 amd64 PulseAudio client libraries
ii libpulse0:i386 1:4.0-0ubuntu11 i386 PulseAudio client libraries
ii libpulsedsp:amd64 1:4.0-0ubuntu11 amd64 PulseAudio OSS pre-load library
ii libpulsedsp:i386 1:4.0-0ubuntu11 i386 PulseAudio OSS pre-load library
ii pulseaudio 1:4.0-0ubuntu11 amd64 PulseAudio sound server
ii pulseaudio-module-bluetooth 1:4.0-0ubuntu11 amd64 Bluetooth module for PulseAudio sound server
ii pulseaudio-module-x11 1:4.0-0ubuntu11 amd64 X11 module for PulseAudio sound server
ii pulseaudio-utils 1:4.0-0ubuntu11 amd64 Command line tools for the PulseAudio sound server
ii vlc-plugin-pulse 2.1.4-0ubuntu14.04.1 amd64 PulseAudio plugin for VLC

Pewnie X11 robi tutaj problem, po odinstalowaniu pulsa rozumiem, że ten kontroler dźwięku co jest aktualnie nie będzie działać?


(roobal) #7

Możesz zamiast PA i ALSA wypróbować jeszcze OSS4, niekiedy sprawdza się lepiej. Jeśli chodzi o wywalanie pakietów, to nie w Ubuntu, w tym systemie wszystko ma być ze sobą powiązane. W tym systemie jest zintegrowane wszystko co się da, aby użytkownik nie musiał nic już robić, jak chcesz wywalić jakiś pakiet, to przeważnie leci cały system. Zresztą Mint bazuje na Ubuntu, więc będzie to samo.


(system) #8