[Validator]Jak naprawić?


(Taex32) #1

Sprawdzając swoją stronę w Validatorze okazało się, że mam 3 błędy.

Line 26, Column 30: Attribute "class" exists, but can not be used for this element.

Line 26, Column 42: Attribute "src" exists, but can not be used for this element.
<iframe></iframe>
 You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead). This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information. How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the element to incorporate flash media in a Web page, see the FAQ item on valid flash.
    Line 26, Column 54: element "iframe" undefined. Did you mean "iframe" or "frame"?
<iframe></iframe>
 You have used the element named above in your document, but the document type you are using does not define an element of that name. This error is often caused by: \* incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Frameset" document type to get the "" element), \* by using vendor proprietary extensions such as "" or "" (this is usually fixed by using CSS to achieve the desired effect instead). \* by using upper-case tags in XHTML (in XHTML attributes and elements must be all lower-case).

Pechowa linia 26 to:
[code]

Nie mam pojęcia jak to prawić. Męczę się męczę ale nic nie znalazłem :-o


(mario@) #2

Użyj doctype Transitional zamiast Strict. Nie używa się iframe w XHTML strict.


(Taex32) #3

Ok, dzięki wielkie działa =D>