VirtualBox - Brak internetu


(Viano3) #1

Witam,

Postawiłem sobie ostatnio wirtualną maszynę z Windows XP, problem jest tylko jeden - brak dostępu do internetu.

Przesiedziałem chyba 2 godziny an google oraz sam próbowałem to jakoś rozwiązać, niestety - brak efektów.

Ustawione jest połączenie NAT, wszystko bardzo ładnie pobiera przez DHCP, lecz internetu nie ma. Co ciekawsze pingując IP onetu czy też innej strony widzę, że internet jednak jest, lecz strony się nie ładują. Na początku myślałem, że problem tkwi w ustawieniach serwera DNS, niestety wklepując IP onetu w przeglądarce wyświetla się komunikat: "Trwa łączenie z onet.pl" co wskazuje na to iż z serwerm DNS jest wszystko wporządku. I tu pytanie do Was - użytkowników, macie jakiś pomysł z czym może być związany ten problem, a co najważniejsze jak go rozwiązać ?


(Irek6910) #2

spróbuj w ustawieniach virtual boxa zmienić kartę sieciową na inną np. intel pro 1000 mt desktop


(Viano3) #3

Próbowałem już wcześniej tak zrobić i przetestowałem każdą po kolei, niestety brak rezultatu.


(greh) #4

Ustaw ręcznie na wirtualu domyślną bramę podając adres IP taki jaki masz przy routerze.

Przypisz także na sztywno IP.


(Viano3) #5

Nic z tego.


(Jan Szatan) #6

Ustaw mostek sieciowy między twoim połączeniem z internetem a VirtualBox Host...


(Viano3) #7

Na mostku sieciowym internet działa, zgadza się (lecz tylko w VirtualBoxie) a ja chciałbym mieć dostęp do internetu na wirtualnej maszynie jak i w normalnym systemie.


(greh) #8

To czemu VirtualBox?

Spróbuj Microsoft Virtual PC.


(roobal) #9

Jeśli twój ISP filtruje adresy MAC kart sieciowych to po NAT neta nie będziesz miał, tylko na mostku, wtedy twoja karta w komputerze współdzieli połączenie sieciowe z kartą wirtualną.

Pozdrawiam!