Walidator W3C - jak usunąć błędy?


(Mayerproject) #1

Witam, ostatnio sprawdzałem poprawność kodu na mojej stronie, i wyskakuje mi błąd w walidatorze zawsze w linijce gdzie mam wpisane:

Wie ktoś może jak to poprawić żeby poprawność kodu była dobra?


(Irekxara) #2

podaj strone


(Mayerproject) #3

Strona to www.verex.pl = proszę nie patrzeć na treść strony, bo dopiero zacząłem kodować i uzupełniać layout. (Chcę layout zmienić, bo ten jest zbyt szary jak dla mnie..)


(Sitemaster) #4

A doctype to krowa zjadła? poza tym kodowanie pliku się nie zgadza z zadeklarowanym w meta, no i w ogóle nie ma co jeszcze walidować.


(Irekxara) #5

jak skończysz zalecanie i budowę zgłoś sie :wink:


(Mayerproject) #6

Tak...

Problem w tym że za bardzo nie wiem jak dostosować ten szablon dla wszystkich przeglądarek... :confused:

A budowę strony skończyłem - chodziło o uzupełnianie i wstawienie linków w menu... :wink:


(Sitemaster) #7

No chyba sobie jaja robisz.

  1. nie widzę byś dodał/poprawił to o czym wcześniej pisałem

  2. bez wykonania punktu pierwszego nie ma co walidować

3.

Faktycznie, Opery nie zalecasz - może i słusznie, bo pod opera bardziej się sypie niż pod zalecanym FF i Chrome, na IE aż się bałem sprawdzać.

Powtarzam, zacznij od doctype, potem zapisz stronę z kodowaniem utf-8 i dopiero potem waliduj


(Mayerproject) #8

api - Jak chciałem dodać Doctype, to jakimś cudem cała strona mi się rozwaliła - dlatego nie dodałem.


(kostek135) #9

Strona "się sypie" ze względu na brak zgodności z tym doctype polecam przeczytać cała dokumentacje w3c odnośnie html przed rozpoczęciem, ewentualnie http://www.kurshtml.boo.pl/

Bo wiesz tak trochę trudno pisać ze standardami, których się nie zna =)


(Mayerproject) #10

Ok, dodałem Doctype, przystosowałem stronę (w miarę moich możliwości) do różnych przeglądarek.