Wifi nie działa w Ubuntu 13.10 Lenovo B590


(Ryziaczeq) #1

Witam,

bardzo proszę o pomoc.

Zainstalowałem Ubuntu i nie szuka mi wifi.

Kompletnie nie wiem co mam zrobić bo na innym komputerze nie miałem takie problemu


(MrQ) #2

Możesz go spróbować grzecznie poprosić, albo przekupić… jedno z dwóch powinno zadziałać.

 

A tak na poważnie… Może łaskawie napiszesz jaki masz sprzęt i którą wersję Ubuntu aka Nie-umiem-zainstalować-Debiana wrzuciłeś?


(Ryziaczeq) #3

mam tego świadomości ale nie wiem co mam napisać. Napisałem że mam lenovo B590 i Ubuntu w wersji 13.10. Powiedz mi jeszcze co powinienem napisać


(MrQ) #4

 

Dokładny model karty wifi by się przydał, ale już sobie poradziłem. Proponuję zastosować się do tego rozwiązania http://ubuntuforums.org/showthread.php?t=2134684


(Ryziaczeq) #5

bardzo dziękuje że mi pomagasz :slight_smile:

jak wpisuje polecenie $  sudo apt-get install --reinstall bcmwl-kernel-source  to wyskakuje mi E: Unable to locate package bcmwl-kernel-source


(MrQ) #6

Do wykonania powyższych poleceń potrzebujesz połączenie z internetem. Skoro nie działa wifi to trzeba po kablu. Dodatkowo powyższe polecenia możesz poprzedzić tym:

sudo apt-get update

(roobal) #7

ryziaczeq , zgodnie z regulaminem, który zaakceptowałeś podczas rejestracji, proszę dokonać zmiany tytułu na taki, który wstępnie opisze problem, w przeciwnym razie temat zostanie przeniesiony do kosza.

W celu dokonania korekty tytuły należy użyć opcji edytuj w poście otwierającym wątek, a następnie skorzystać z pełnego edytora tekstu.


(Ryziaczeq) #8

kuba@ubuntu:~$ sudo apt-get install --reinstall linux-headers-generic linux-headers-3.11.0-12-generic
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
bcmwl-kernel-source : Depends: dkms but it is not going to be installed
linux-generic : Depends: linux-headers-generic (= 3.11.0.12.13) but 3.11.0.20.21 is to be installed
linux-headers-generic : Depends: linux-headers-3.11.0-20-generic but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
kuba@ubuntu:~$ sudo apt-get install --reinstall bcmwl-kernel-source
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
bcmwl-kernel-source : Depends: dkms but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
kuba@ubuntu:~$ sudo modprobe wl
FATAL: Module wl not found.


#9

Czytaj komunikaty i stosuj się do nich.


(Ryziaczeq) #10

Zmieniłem sobie wersje ubuntu na 14.04 bo myśłałem że to coś zmieni ale (nadale nie szuka mi wifi) i mam teraz “3.13.0-24-generic”

po wpisaniu tamtych komend wyskoczyły mi takie żeczy

Ps: bardzo proszę o wspracie bo juz nie wiem co robić

 

kuba@ubuntu:~$ sudo apt-get install --reinstall linux-headers-generic linux-headers-3.13.0-24
Czytanie list pakietów… Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie… Gotowe
0 aktualizowanych, 0 nowo instalowanych, 2 ponownie instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 0 B/8871 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
(Odczytywanie bazy danych … 170681 plików i katalogów obecnie zainstalowanych.)
Preparing to unpack …/linux-headers-3.13.0-24_3.13.0-24.46_all.deb …
Unpacking linux-headers-3.13.0-24 (3.13.0-24.46) over (3.13.0-24.46) …
Preparing to unpack …/linux-headers-generic_3.13.0.24.29_amd64.deb …
Unpacking linux-headers-generic (3.13.0.24.29) over (3.13.0.24.29) …
Konfigurowanie pakietu linux-headers-3.13.0-24 (3.13.0-24.46) …
Konfigurowanie pakietu linux-headers-generic (3.13.0.24.29) …
kuba@ubuntu:~$ sudo apt-get install --reinstall bcmwl-kernel-source
Czytanie list pakietów… Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie… Gotowe
Zostaną zainstalowane następujące dodatkowe pakiety:
dkms fakeroot libfakeroot
Sugerowane pakiety:
dpkg-dev debhelper
Zostaną zainstalowane następujące NOWE pakiety:
bcmwl-kernel-source dkms fakeroot libfakeroot
0 aktualizowanych, 4 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 1271 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 6564 kB miejsca na dysku.
Kontynuować? [T/n] t
Pobieranie:1 http://pl.archive.ubuntu.com/ubuntu/ trusty/main dkms all 2.2.0.3-1.1ubuntu5 [64,4 kB]
Pobieranie:2 http://pl.archive.ubuntu.com/ubuntu/ trusty/restricted bcmwl-kernel-source amd64 6.30.223.141+bdcom-0ubuntu2 [1126 kB]
Pobieranie:3 http://pl.archive.ubuntu.com/ubuntu/ trusty/main libfakeroot amd64 1.20-3ubuntu2 [25,4 kB]
Pobieranie:4 http://pl.archive.ubuntu.com/ubuntu/ trusty/main fakeroot amd64 1.20-3ubuntu2 [55,0 kB]
Pobrano 1271 kB w 0s (1977 kB/s)
Wybieranie wcześniej niewybranego pakietu dkms.
(Odczytywanie bazy danych … 170681 plików i katalogów obecnie zainstalowanych.)
Preparing to unpack …/dkms_2.2.0.3-1.1ubuntu5_all.deb …
Unpacking dkms (2.2.0.3-1.1ubuntu5) …
Wybieranie wcześniej niewybranego pakietu bcmwl-kernel-source.
Preparing to unpack …/bcmwl-kernel-source_6.30.223.141+bdcom-0ubuntu2_amd64.deb …
Unpacking bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) …
Wybieranie wcześniej niewybranego pakietu libfakeroot:amd64.
Preparing to unpack …/libfakeroot_1.20-3ubuntu2_amd64.deb …
Unpacking libfakeroot:amd64 (1.20-3ubuntu2) …
Wybieranie wcześniej niewybranego pakietu fakeroot.
Preparing to unpack …/fakeroot_1.20-3ubuntu2_amd64.deb …
Unpacking fakeroot (1.20-3ubuntu2) …
Processing triggers for man-db (2.6.7.1-1) …
Konfigurowanie pakietu dkms (2.2.0.3-1.1ubuntu5) …
Konfigurowanie pakietu bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) …
Loading new bcmwl-6.30.223.141+bdcom DKMS files…
First Installation: checking all kernels…
Building for 3.11.0-12-generic and 3.13.0-24-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
Building initial module for 3.13.0-24-generic
Done.

wl:
Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/3.13.0-24-generic/updates/dkms/

depmod…

DKMS: install completed.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Konfigurowanie pakietu libfakeroot:amd64 (1.20-3ubuntu2) …
Konfigurowanie pakietu fakeroot (1.20-3ubuntu2) …
update-alternatives: użycie /usr/bin/fakeroot-sysv jako dostarczającego /usr/bin/fakeroot (fakeroot) w tryb auto
Processing triggers for initramfs-tools (0.103ubuntu4) …
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
Warning: No support for locale: pl_PL.utf8
kuba@ubuntu:~$ sudo modprobe wl
modprobe: FATAL: Module wl not found.

 

 

////////////////////////

Ps: Nie wiem czy moze to wl(jakies inne wybrac)

 

kuba@ubuntu:~$ sudo modprobe wl
wl1251          wl1273-core     wl3501_cs       wlcore
wl1251_sdio     wl12xx          wlags49_h25_cs  wlcore_sdio
wl1251_spi      wl18xx          wlags49_h2_cs   wlcore_spi

(roobal) #11

Tak w ogóle przydałaby się informacja na temat twojego czipu, a poznamy go, gdy podasz wynik polecenia.

lspci -k

PS wyniki poleceń podawaj w tagu code, a długie w spoiler, łatwiej się je przegląda.


(Ryziaczeq) #12

kuba@ubuntu:~$ lspci -k

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)

    Subsystem: Lenovo Device 5011

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: i915

00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: xhci_hcd

00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: mei_me

00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: ehci-pci

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)

    Kernel driver in use: pcieport

00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)

    Kernel driver in use: pcieport

00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)

    Kernel driver in use: pcieport

00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: ehci-pci

00:1f.0 ISA bridge: Intel Corporation 7 Series Chipset Family LPC Controller (rev 04)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: lpc_ich

00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)

    Subsystem: Lenovo Device 5011

    Kernel driver in use: ahci

00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)

    Subsystem: Lenovo Device 5011

02:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)

    Subsystem: Lenovo Device 0611

    Kernel driver in use: bcma-pci-bridge

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

    Subsystem: Lenovo Device 5002

    Kernel driver in use: r8169

 

Ps: Dzięki za cenne wskazówki i zainteresowanie


(roobal) #13

Twój czip nie jest wspierany przez sterownik b43, ale można skorzystac ze sterownika wl. Spróbuj zrobić tak, zainstaluj sterownik.

 

sudo apt-get install wireless-bcm43142-dkms

nąstepnie załaduj moduł wl.

 

modprobe wl

Pokaż wyniki poleceń.

ifconfig
iwconfig

(Ryziaczeq) #14

:slight_smile:


(roobal) #15

Widocznie pakiet nie jest już dostępny. Może upakowali go do pakietu z firmware.

 

sudo apt-get install firmware-b43-installer

Jeśli to nie pomoże, prawdopodobnie trzeba będzie gdzieś wyszukać sterownik i ręcznie go skompilować. Z broadcomami niestety już tak jest, Braodcom i Linux to ciężkie życie, dlatego pod Linuksa lepiej szukać kart z układami Atherosa.


(Ryziaczeq) #16
kuba@ubuntu:~$ sudo apt-get install firmware-b43-installer
[sudo] password for kuba:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
firmware-b43-installer jest już w najnowszej wersji.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

Czyli to jest :slight_smile:

i co dalej :stuck_out_tongue: