Windows posiada ikonkę że brak internetu ale on działa

Witam, mam problem w Windowsie 10, mianowicie krzyczy mi że brak dostępu do sieci ale ta sieć działa.
Jakiś czas temu zmodernizowałem swoją sieć, mianowicie działa ona w LAN. Główny router jest na poddaszu a z niego lecą do każdego routera kable. Na nim tylko włączony jest serwer DHCP, na pozostałych wyłączony. Co może być nie tak?

Zresetuj połączenie. Powinno pomóc.

Nie pomaga.

Sprawdź zapory; Pi-Hole, AdGuard Home lub Diversion (AB-Solution) jak posiadasz.

https://pi-hole.net/
https://adguard.com/pl/adguard-home/overview.html
https://diversion.ch/ (https://www.ab-solution.info/)

Zapora jest zwykła windowsowa + program antywirusowy ale co to ma do tego?

Niby można zablokować pliki txt do sprawdzania czy internet jest, tak to działa na Windows i zapora w routerze może cudem na jakimś etapie zbanowała kilka serwerów Microsoft.

Chodzi o tę ikonkę?
obraz

Albo tę:

obraz

Tak o ta właśnie chodzi. U mnie to wygląda tak: dsfdsfsdf

i jak kliknę to tak : nettt

a czasem jak kliknę to pisze brak internetu ale on działa cały czas.
Modyfikowałem sieć ostatnio w domu, do tego czasu było ok

Tutaj może być wyjaśnienie i rozwiązanie.
Od sekcji " Więcej informacji"

To nie to. W 1903 zmienili NCSI na UWP, a w 2004 ta usługa ma jakieś problemy i notorycznie twierdzi ze nie ma internetu. W końcu jej przechodzi.

Spróbuj zmienić profil sieciowy. Użyj Set-NetConnectionProfile. Jak to nie pomoże, to przestawimy NCSI żeby pytał inny punkt :slight_smile:

Potwierdzam. Ale u mnie w 2004 ikonka inforumująca o braku netu jest tylko na ekranie logowania. Po zalogowaniu do systemu od razu się załączą że połączenie jest dostępne.

1lajk

Oby ten problem rozwiązano przed wydaniem nowego Windows Server

Dla mnie to jest taka popierdółka, że naprawdę wstyd, że takie coś w ogóle ma miejsce. Nie znam się na programowaniu ale, serio, to chyba nie jest trudne dla takiego giganta jak MS napisać kawałek kodu, który będzie prawidłowo informował o tym czy komputer ma dostęp do sieci czy nie. Na mój rozum to kilka, może kilkanaście linijek kodu a tu takie cyrki. Może po prostu MS takie z pozoru proste zadania zleca stażystom licząc na to, że to zbyt banalne zadanie by mogło coś się nie udać. I potem mamy takie kwiatki. :wink:

Oj nie. NCSI pod spodem jest OGROMNE, a zarządza się nim przez kilkanaście zasad grupy. Rok temu przemigrowano ikonkę na aplikację UWP, a w najnowszej wersji wprowadzono kod modern do obsługi połączeń przez nią.
Efekt jest oczywiście taki, jak ze wszystkim tkniętym przez UWP. Nie działa :smiley:

2lajki

Możesz bardziej opisać ?
Jak mam tego użyć ?

W chwili obecnej na przykład jest ikonka ok, jest komputerek i jest wszystko w porządku.
A za dzien czy dwa znów wisi że brak a net działa.

Spróbuj -> Edytor rejestru:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator
Utwórz nową wartość DWORD o nazwie UseGlobalDNS z wartością 1