Windows XP wiele instalatorów nie włącza się, niektóre wywalają się w trakcie działania


(kijek) #1

Witam. Ostatnimi czasy na czystych Windowsach XP dostrzegam dziwny problem z instalatorami. Otóż wiele z nich nie uruchamia się z dwukliku. Jedynie odpalenie z wiersza poleceń daje szanse na instalację oprogramowania. Choć i to nie jest regułą - większość instalatorów zaraz po włączeniu wywala się - występuje słynny błąd z wysyłaniem raportów o błędach.

Co powoduje ten błąd i jak można mu zaradzić?


(system) #2

Co powoduje, nie wiem. Natomiast spróbuj “wyleczyć” tym: http://www.majorgeeks.com/files/details/tweaking_com_repair_msi_(windows_installer).html Pobierz, uruchom, poczekaj chwilę i zrestartuj komputer.


(kijek) #3

Niestety, to nie pomogło. Poniżej log:

OS: Microsoft Windows XP
OS Architecture: 32-bit
OS Version: 5.1.2600
OS Service Pack: Dodatek Service Pack 2
Computer Name: ZAMIENNY
Windows Drive: C:\
Windows Path: C:\WINDOWS
Program Files: C:\Program Files
Current Profile: C:\Documents and Settings\Admin
Current Profile SID: S-1-5-21-448539723-299502267-1801674531-1004
Current Profile Classes: S-1-5-21-448539723-299502267-1801674531-1004_Classes
Profiles Location: C:\Documents and Settings
Profiles Location 2: C:\WINDOWS\ServiceProfiles
Local Settings AppData: C:\Documents and Settings\Admin\Ustawienia lokalne\Dane aplikacji
--------------------------------------------------------------------------------

Spróbuję jeszcze instalacji SP3, aczkolwiek na innych komputerach już to robiłem i problem wciąż występuje.


(G7996095) #4

Problem z usługą instalatora Windows. Sprawdź w Usługach Systemowych jaki status ma usługa Instalatora Windows. Zrestartuj ją. Jeśli nie pomoże to masz poważne problemy systemowe.


(ichito) #5

Wiele programów na XP wymaga SP3…bez tego poprawnie się nie zainstalują. Mogę polecic narzędzie naprawcze do XP Dial-a fix do naprawy kilku systemowych rzeczy

 

http://wiki.lunarsoft.net/wiki/Dial-a-fix


(system) #6

Wobec tego spróbuj jeszcze tego: http://www.majorgeeks.com/files/details/tweaking_com_repair_wmi.html Reszta jak poprzednio.


(kijek) #7

Dziękuję za interesujące linki oraz narzędzia, które niewątpliwie mogą mi się przydać w przyszłości. Problem niejako sam rozwiązał się po instalacji którejś aktualizacji.