[WINE] Nie da się uruchomić żadnej aplikacji


(Max Graczyk) #1

Witam,

Po zainstalowaniu Linuksa postanowiłem zainstalować WINE, bo będzie mi potrzebny na Windowsowskie aplikacje. Zainstalował się pięknie, odpalał wszystkie aplikacje lecz nagle PACH! I nie może żadnej odpalić. Tylko napis "Uruchamianie " i znika. Nie wiem, co jest grane. Jeszcze wcześniej śmigał pięknie i nagle się zepsuł?!

Reinstalacja, zmiana konfiguracji itp. nic nie pomogła! Nie mam pomysłów. Może by ktoś mi pomógł?

System to Ubuntu 9.10 Karmic Koala. A może aktualizacja jądra pomoże? (mam wersję 2.6.31-16)


(mati75) #2

Jaką aplikację chcesz uruchomić? Jaka wersja wine?


#3

maksio1 , to spróbuj odpalić to w konsoli i zobacz na czym się wykrzacza. W tej chwili to tylko wróżka mogłaby pomóc, a jak sam wiesz, wróżki nie istnieją.


(Max Graczyk) #4

Nie wiem, czy to dobre polecenie, ale jak próbuję w konsoli odpalić program tym: ./ to za każdym razem wywala błąd:

bash: ./AQQ_FN_21050.exe: Permission denied

Tak jest z każdą aplikacją.

Użycie polecenia sudo lub uruchamianie na koncie roota nie pomaga. WINE jest w wersji 1.1.33 (rozwojowa, stabilna nie chciała się zainstalować).


(dragonn) #5

Nie, wpisujesz

wine "dokładna/scieżka/do/pliku.exe"

EDIT

Zapomniałem wspomnieć, pod żądnym pozorem nie uruchamiamy aplikacji .exe z uprawieniem root, na 99,999999999999999% żadna tego nie wymaga (nie dałem 100% bo miałem jeden przypadek Dark Regin 2).


(Sawyer47) #6

Odpal z konsoli

wine sciezka/do/aplikacji

No i podaj o jaką aplikację CI chodzi. Chyba nie AQQ? Akurat na wybór komunikatorów pod GNU/Linux nie można narzekać.


(Max Graczyk) #7

Jakąkolwiek ścieżkę wpiszę, zawsze to polecenie wywala taki błąd:

/usr/lib/../bin/wine-pthread: could not open

(dragonn) #8

To jest jakiś błąd chyba w wine, ale spróbuj jeszcze podać ścieżkę w "" cudzysłowach, to jest ważne, bo jeżeli gdzieś w ścieżce jest spacja to nie zadziała bez "". Skąd instalowałeś wine ?


(Max Graczyk) #9

Próbowałem i w cudzysłowach i bez, zawsze ten sam błąd. Wine instalowałem z Ubuntu Software Center (pakiet wine1.2), potem jakieś błędy wywalało, że wymaga pakietu wine1.2, zainstalowałem i pojawił się Wine...

EDIT

Zwróćcie jeszcze na to uwagę, że jak w terminalu wpisuję polecenie:

wine-pthread "<ścieżka do aplikacji>"

to wtedy zwróci błąd, a program (przynajmniej niektóre) się odpali bez problemu :o


(dragonn) #10

Spróbuj:

sudo dpkg-reconfigure wine

(Max Graczyk) #11
/usr/sbin/dpkg-reconfigure: wine jest uszkodzony, lub nie jest w pełni zainstalowany

Tylko to się pokazuje i jeszcze takie coś zauważyłem:

bash: /usr/sbin/dpkg-reconfigure:: No such file or directory

(dragonn) #12

To zrób:

sudo apt-get purge wine && sudo apt-get install wine

(Max Graczyk) #13
Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Odczyt informacji o stanie... Gotowe

Pakiet wine nie jest zainstalowany, więc nie zostanie usunięty.

Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:

  libgconfmm-2.6-1c2

Aby je usunąć należy użyć "apt-get autoremove".

0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Odczyt informacji o stanie... Gotowe

Nie udało się zainstalować niektórych pakietów. Może to oznaczać,

że zażądano niemożliwej sytuacji lub używasz dystrybucji niestabilnej,

w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione

z katalogu Incoming ("Przychodzące").

Następujące informacje mogą pomóc rozwiązać sytuację:


Następujące pakiety mają niespełnione zależności:

  wine: Wymaga: wine1.2 ale nie zostanie zainstalowany

E: Pakiety są uszkodzone

Nie mam spokoju z tą nową wersją Ubuntu 9.10! Jeszcze wywala mi, że pakiet jest uszkodzony :?

Dodam jeszcze, że w Ubuntu 9.04 nie było żadnych problemów!


(dragonn) #14
sudo apt-get purge wine1.2 && sudo apt-get install wine1.2

Albo:

sudo dkkg-reconfigure wine1.2

A jeżeli to nie pomoże to spróbuj zainstalować wine z repo wine http://www.winehq.org/download/deb.


(Max Graczyk) #15

NIC! Te same błędy, nic się nie dzieje. DAWAĆ MI STABILNĄ WERSJĘ WINE 1.0.1 I INSTRUKCJĘ, JAK JĄ ZAINSTALOWAĆ !!


(roobal) #16

(Max Graczyk) #17

Przy poleceniu sudo apt-get -d install wine=1.0.1 :

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Odczyt informacji o stanie... Gotowe

E: Wersja "1.0.1" dla "wine" nie została znaleziona

(dragonn) #18

Ale możesz podać co wyrzuciły te dwa polecenia ? Możesz spróbować zainstalować wine z http://packages.ubuntu.com/ od 9.04 (tylko mnie chwilowo coś ta stronka szwankuje).


(roobal) #19

Bo zapomniałem dodać, żebyś dał gwiazdkę na końcu :slight_smile: Spróbuj tak:

sudo apt-get -d install wine=1.0.1-0

Ewentualnie

sudo apt-get -d install wine=1.0.1-*

Pozdrawiam!