[Wireshark] Brak przechwyconych TCP na otwartej sieci bzp


(Wojciech Cabanski) #1

Chciałem przechwycić pakiety TCP(swoje, z innego urządzenia) wysyłane na moją sieć (otwartą), więc załączyłem karte wlan w tryb monitoringu, jednak wireshark, przechwytuje tylko broadcasty.

Czym to może być spowodowane ?

Jak przechwycić pakiety TCP ??


(roobal) #2

Nie masz przypadkiem włączonych jakiś filtrów. Swoją drogą, protokół TCP wysyła segmenty, nie pakiety :wink: Napisz szegółowo w jaki sposób się za to zabierasz.

Pozdrawiam!


(Wojciech Cabanski) #3

no fakt, pomyłka, segmenty.

-> tryb monitoringu na wlan0 -> Wireshark na roocie -> Capture options -> filter: tcp, interfejs: wlan0 -> start

Bez filtrów są same broadcasty, a z filtrem na tcp nic.


(roobal) #4

Sprawdź w Analyze>Enabled protocols... czy nie masz odznaczonego protokołu TCP. Wireshark uruchamiasz pod Linuksem, czy Windowsem?

Pozdrawiam!


(Wojciech Cabanski) #5

TCP oczywiście że włączony jak i znaczna większość innych.

Korzystam z Mint'a 10, 32bt, wireshark wersja 1.2.11.

Dodam, że z etch0(kabel) oraz wlan0(bez monitoringu) z sieci wszystko jest przechwytywane co wyślę i odbiorę (z tego samego urządzenia).

Tryb monitoringu działa poprawnie, sprawdzałem kismetem.


(roobal) #6

Pokaż wynik polecenia lspci-k. Napisz jeszcze w jaki sposób testujesz sieć.

Pozdrawiam!


(Wojciech Cabanski) #7

Jeśli chodzi o kartę sieciową to jest to TP-Link TL-WN422G, jest w 100% sprawna.

USB Controller: ATI Technologies Inc EHCI USB Controller (rev 01)

	Subsystem: Asus Incorporated [ALI] Device 0065

	Kernel driver in use: ehci_hcd

Postawiłem niezabezpieczony router, załączam tryb monitoringu na wlan0, odpalam wiresharka na roocie.

Z innego urządzenia podłączonego do tego routera otwieram dowolną stronę internetową.

Wireshark na filtrze na tcp nic nie przechwytuje, a bez tylko same broadcasty.


(roobal) #8

No to nie mam pojęcia czemu nie działa, u mnie przechwytuje wszystko elegancko. W Wiresharku masz również opcję nasłuchiwania w trybie monitoringu, sprawdź to jeszcze. Napisz jeszcze może jakim poleceniem wprowadzasz kartę w tryb monitoringu.

Pozdrawiam!


(Wojciech Cabanski) #9

Capture packets in promiscous mode jest włączone.

ifconfig wlan0 down

iwconfig wlan0 mode monitor

ifconfig wlan0 up

(roobal) #10

W takim razie powinno działać, póki co, nic mi nie przychodzi do głowy, co może być nie tak. Pokaż może jeszcze przykładowy zrzut ekrenu z Wiresharka.

Pozdrawiam!