Wolny internet w Linuksie, normalny w Win XP


(Mzale) #1

Witam.

Od kilku tygodni walczę z różnymi dystrybucjami Linuxa i moim internetem Play Online 5MB. Na dysku zainstalowane miałem Ubuntu 10.10 (teraz jest 11.04). Internet wykorzystywany jest na komputerze stacjonarnym, sygnał jest bardzo dobry.

Problem polega na bardzo niskim transferze danych rzędu kilkudziesięciu kb/sek.

Na tym samym komputerze zainstalowany jest też Windows XP i na tym systemie internet działa o wiele szybciej - transfer rzędu kilkuset kb.sek.

Próbowałem różnych, wszystkich rozwiązań jakie udało mi się znaleźć w internecie czyli m.in wyłączenie ipv6 w całym systemie, wyłączenie ipv6 w Firefoksie, stałe DNS-y, DNS-y Google, DNS-y OpenDNS. Próbowałem też ze sterownikami Windowsowymi do modemu (Huawei E160) zainstalowanymi w Linuxie (ndiswrapper) i nic, żadnej poprawy.

Dzieje się tak na różnych dystrybucjach, także LiveCD (np. Fedora 14, OpenSuse 11.4, PCLinux, LinuxMint, Debian), na różnych przeglądarkach (Firefox, Opera, Chrome..), z włączonym i wyłączonym firewallem.

Nie mam już pomysłów. Czy każdy Linux będzie działał dużo wolniej niż Windows XP na moim połączeniu mobilnym, modemie?

Wczoraj, na skargi córki, że internet działa wolno w Ubuntu, z bólem serca powiedziałem jej "wejdź do Windows"...

Proszę o pomoc, co jeszcze może zrobić aby internet działał normalnie w Linuksie?

Marcin


(piotrek91666) #2

Nie miałem do czynienia z tym modemem w Linuxie, próbowałeś tego? : http://ubuntuforums.org/showthread.php?t=616744


(ra-v) #3
ping wp.pl

....i przerwij po 20 próbach CTRL+C

Zmień MTU np,. na 1000 lub 1400.


(Mzale) #4
PING wp.pl (212.77.100.101) 56(84) bytes of data.

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=1 ttl=249 time=119 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=2 ttl=249 time=126 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=3 ttl=249 time=485 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=4 ttl=249 time=473 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=5 ttl=249 time=379 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=6 ttl=249 time=467 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=7 ttl=249 time=318 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=8 ttl=249 time=337 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=9 ttl=249 time=364 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=10 ttl=249 time=415 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=11 ttl=249 time=390 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=12 ttl=249 time=381 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=13 ttl=249 time=360 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=14 ttl=249 time=347 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=15 ttl=249 time=306 ms

64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=16 ttl=249 time=285 ms

^C64 bytes from http://www.wp.pl (212.77.100.101): icmp_req=17 ttl=249 time=444 ms


--- wp.pl ping statistics ---

17 packets transmitted, 17 received, 0% packet loss, time 16759ms

rtt min/avg/max/mdev = 119.546/353.218/485.140/101.333 ms

(ra-v) #5

duże pingi. Jak daleko jesteś od nadajnika?

MTU ustawiasz w /etc/ppp/options wypisując np.

mtu 1000

mru 1000


(Mzale) #6

Zrobiłem to wszystko, bez poprawy.

Mieszkam w centrum Warszawy.

Dzięki.