Wolny internet w SparkyLinux


(Siete) #1

Mam problem z wolnym internetem w SparkyLinux.

Ping jest wysoki a download oscyluje wokół 0,5 Mb/s przez co strony wczytują się bardzo powoli.

 

Co może być przyczyną i jak temu zaradzić?

 


(sajmon17099) #2

A jaka powinna być normalna prędkość internetu?


(Siete) #3

Mam internet 6Mb/s i taką wskazuje laptop obok na którym jest Win7.

Tam jest okej.


(sajmon17099) #4

A jaką masz przeglądarkę w sparky linux? Może powinieneś ją zmienić? I ten twój komputer jest nowy czy jakiś stary (np. 900mb RAM). Bo jeżeli jest stary to to może nie być wina internetu tylko tego, że komputer wolno chodzi.


(Siete) #5

W obydwu jest slimjet.

Sparky jest na dość mocnym sprzętowo laptopie [i5 3gen, 8 GB, SSD].

Zresztą mierzyłem prędkość i to jej niska wartość odpowiada za tak wolne wczytywanie stron.

 

Może MRU jest za niskie? Powinno być 1500?


(sajmon17099) #6

A miałeś jakiś inny system na tym laptopie? Jak tak, to czy tylko na Sparky’m internet jest tak wolny? A, i masz zainstalowane sterowniki?


(Siete) #7

Iwlwifi jest. 

Na manjaro internet też chodził wolno.

 

Chociaż nie jestem pewny czy iwlwifi jest bo w etc/modprobe.d/ nie ma iwlwifi.


(sajmon17099) #8

Na jakiejś stronie pisało, że ktośtam miał właśnie problem z wifi, które było na Ubuntu okropnie wolne. Winą był Power Manamagement. Wiem że nie masz na tym laptopie Ubuntu tylko Sparky, ale może w sparkym też coś takiego jest.


(sir_lucjan) #9

Ja obstawiam zupełnie inny problem. Pokaż zawartość pliku  /etc/resolv.conf

 

https://wiki.debian.org/NetworkConfiguration#The_resolv.conf_configuration_file


(Siete) #10

Dzięki za zainteresowanie.

 

W tym pliku jest takie coś o nazwie: update-libc.d a w nim avahi-daemon o zawartości:

 

Czy można wykluczyć problem sprzętowy?


(dragonn) #11

Spróbuj:

iwconfig wlan0 power off

To wyłącza zarządzanie eneegia na karcie wifi.


(Siete) #12

Po wpisaniu tego w terminalu pojawia się komunikat:

bash: iwconfig nie znaleziono polecenia.

 

 


Wpisałem sudo iwconfig i wyświeliło takie coś:


(dragonn) #13

No to w takim razem wlan1 musisz dać. Problem gdzieś na pewno jest bo Bit Rate=1 Mb/s to się nie dziwię szybkości neta. Sprawdzałeś w miejscu gdzie masz lepszy zasięg?


(Siete) #14

Martwi mnie ten bitrate.

Jeśli chodzi o zasięg to jestem prawie przy routerze.

 

A jak zmienić ten bitrate?


(dragonn) #15

Spróbuj tak:

sudo iwconfig wlan1 rate 24M

(Siete) #16

Próbowałem już i nic się nie zmienia. Dalej jest 1 Mb/s.

A jak wyłączę kartę przed tym poleceniem [sudo ifconfig wlan1 down] to pojawia się błąd.

 

Problem sprzętowy wykluczyłem bo wymieniłem kartę wlan [intel 6205] na inny egzemplarz i jest to samo. No zasięg się nieco zwiększył.


(dragonn) #17

Pokaż no dokładne wynik:

lspci -k

(Siete) #18

Wynik:

Wpisałem komendę sudo iwlist wlan1 rate i taki jest wynik:

 


(dragonn) #19

Spróbuj coś z tego https://wiki.archlinux.org/index.php/Wireless_network_configuration#iwlwifi


(Siete) #20

Coś w tym kierunku chyba trzeba pójść.

Podobno trzeba wyłączyć 802.11n choć nie wiadomo dlaczego.

 

Tu podają aby wpisać:

sudo grep 11n -r /etc

https://askubuntu.com/questions/414654/how-to-get-optimal-performance-from-centrino-advanced-n-6205-wifi-card

 

Tu co prawda dla 6235 ale to samo może dotyczyć 6205:

http://bernaerts.dyndns.org/linux/74-ubuntu/322-ubuntu-trusty-intel-centrino-6235-slow-freeze