Wordpress - kilka problemów w działaniu witryny


(Zioomus) #1

Witam. Posiadam witrynę opartą na Wordpressie, motyw Sight, mam kilka małych problemów w użytkowaniu:

  1. Wrzuciłem swoją faviconkę. Problem jest w tym, że działa jedynie pod Firefoxem (sprawdzane u mnie i u znajomych), na innych przeglądarkach albo się nie ładuje wcale, albo jest domyślna z motywu - co może być nie tak i od czego to zależne?

    /favicon.ico” />

    <?php wp_title ( '|', true,'right' ); ?>

        <?php
    
    		wp_enqueue_script('jquery');
    
    		wp_enqueue_script('cycle', get_template_directory_uri() . '/js/jquery.cycle.all.min.js', 'jquery', false);
    
    		wp_enqueue_script('cookie', get_template_directory_uri() . '/js/jquery.cookie.js', 'jquery', false);
    
            if ( is_singular() ) wp_enqueue_script( 'comment-reply' );
    
            wp_enqueue_script('script', get_template_directory_uri() . '/js/script.js', 'jquery', false);
    
    	?>
    
        <?php wp_head(); ?>
    
        <?php if ( is_home() && !get_option('ss_disable') ) : ?>
    
    
        <?php endif; ?>

<?php bloginfo('name'); ?> ?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Site description') ) ? ?php get_search_form(); ? ?php wp_nav_menu(array('menu' = 'Top menu', 'theme_location' = 'Top menu', 'depth' = 1, 'container' = 'div', 'container_class' = 'menu', 'menu_id' = false, 'menu_class' = false)); ?
?php wp_nav_menu(array('menu' = 'Navigation', 'theme_location' = 'Navigation', 'depth' = 2, 'container' = 'div', 'container_class' = 'nav', 'menu_class' = 'dd', 'menu_id' = 'dd', 'walker' = new extended_walker())); ? ?php if ( is_home() !get_option('ss_disable') ) get_template_part('slideshow'); ?

tak wygląda header.php, może ktoś mi powie gdzie jest błąd? 2. Gdy wrzuciłem pierwszego newsa nie było problemu, przy drugim zaś się zaczęły, nad tekstem, po kliknięciu w newsa wyskoczyło takie coś:

AKTUALNOŚCI (nazwa newsa)” HTTP://TINYURL.COM/AOHO5RX" TARGET="_BLANK" CLASS="T" TITLE="SPREAD THE WORD ON TWITTER" (nazwa newsa)" TARGET="_BLANK" CLASS="DI" TITLE="BOOKMARK ON DEL.ICIO.US"

Od czego to jest zależne i jak to naprawić? 3. Utworzyłem sobie jedną z podstron, chcę tam zrobić galerię, tzn. aby po przejściu ukazywał się jeden obrazek i po kliknięciu można było przejrzeć pozostałe, jaki widżet mi to umożliwi? Aktualnie mam NextGENGallery ale nie znalazłem tam takiej opcji. 4. Nie mogę dojść do tego, która linijka kodu odpowiada z kolor wiadomości w slideshow, nagłówek zmienię, meta dane itd. tez, ale tekstu nie mogę, może ktoś mnie nakieruje?

#slideshow, .slideshow {height: 290px; width: 975px; overflow: hidden; position: relative;}

.slide {height: 290px; width: 975px; background: #d0ff7f;}

.slide img {display: block; float: left; width: 640px; height: 290px; position: relative; top: -20px; left: -30px;}

.slide .post {padding: 20px 30px 0;}

.slide .post-category {font-size: 11px; color: #F90403; text-transform: uppercase; margin-bottom: 5px;}

.slide .post a {color: #f6f6f6;}

.slide .post .post-category a {text-decoration: none;}

.slide .post .post-category a:hover {text-decoration: underline;}

.slide .post h2 {margin-bottom: 5px;}

.slide .post h2, .slide .post h2 a {color: #91ba2d; font-size: 26px; font-weight: normal; text-decoration: none;}

.slide .post h2 a:hover {text-decoration: underline;}

.slide .post .post-meta {font-size: 11px; font-style: italic; color: #000000; margin-bottom: 20px;}

.slide .post .post-meta span, .slide .post .post-meta a {color: #000000; text-decoration: none; font-family: Helvetica, Arial, sans-serif; font-style: normal;}

.slide .post .post-meta a:hover {text-decoration: underline;}

.slide .post .post-author {text-transform: uppercase;}

.slide .post-content p {margin-bottom: 15px;}

#larr, #rarr {display: block; width: 32px; height: 53px; position: absolute; top: 106px !important; opacity: 0.2; z-index: 99 !important;}

#larr {background: #ffffff url("images/larr.png") 8px 50% no-repeat; left: 0 !important;}

#rarr {background: #000000 url("images/rarr.png") 11px 50% no-repeat; right: 0 !important;}

#larr:hover, #rarr:hover {opacity: 1;}

Dziękuję z góry za wszelką pomoc!