Wordpress - problem z pluginami


(Filip Szylderowicz) #1

Witam,

Mam taki problem z instalacją pluginów na wordpressie:

Wybieram plugin do zainstalowania, następnie klikam w przycisk zainstaluj i dzieje się jakaś dziwna rzecz, wordpress chce dane do połączenia z ftp podaję je wyświetla komunikat, że pobiera wtyczkę, rozpakowuje ją i koniec, nic więcej się nie dzieje. Nigdy wcześniej nie miałem takich problemów i nie wiem co się dzieje? Może muszę nadać jakieś prawa dostępu dla plików lub katalogów?

Proszę o szybką pomoc.


(M@ster) #2

Jeśli klikasz zainstaluj to WP musi pobrać wtyczkę i wrzucić na Twój serwer, stąd pytanie o dane do FTP.

Jeśli sam ją wrzucisz to wtedy tylko ja aktywujesz i już działa :slight_smile:


(Filip Szylderowicz) #3

a jak bym wolał żeby tą wtyczkę pobierał mi WP i sam ją instalował tak jak zawsze to robiłem to co muszę zrobić?


(Irekxara) #4

ToFIK277 , nie komplikuj sobie życia, zawsze szukaj rozwiązań które działają a nie takich które może będą działać, co musisz zrobic ?? wyprobowac inna przegladarke byc może wczesniej robiłeś na innej wersji, moze ci cos blokuje, gdybac można, po prostu szukaj rozwiązań które działają :wink:


(Filip Szylderowicz) #5

pod inną przeglądarką też nie działa :confused: wiem, że trzeba nadać chmody na jakieś katalogi tylko nie wiem na jakie ?

Kiedyś na innym serwerze działało wszystko bez zarzutów wordpress sam pobierał i instalował wtyczki a na tym nie :expressionless:


(Dawid Deja) #6

Jak dla mnie mechanizm, który opisujesz działa poprawnie.

WP pobiera na serwer wtyczkę, rozpakowuje a to od Ciebie zależy czy ją aktywujesz czy nie.

Zasadniczo w WP oryginal source a nie jakieś zmodyfikowane, wszystkie wtyczki są domyślnie wyłączone.


(Sitemaster) #7

Poniżej masz pliki i katalogi z chmodami jakie powinny mieć ustawione z uwagi na bezpieczeństwo

W razie problemów na czas aktualizacji dla wp-admin, wp-content i wp-includes możesz dać chmod 0777, a po aktualizacji przywracasz chmody restrykcyjne i wsio.