Wordpress zwiększenie pamięci


(Wirrus) #1

Witam,

 

 

Czy istnieje wtyczka dzięki, której zostanie zwiększony limit pamięci serwera? Nie chodzi o upload plików czy zdjęć lecz pamięć serwera.

W panelu serwera (iq.pl) mam wszystko ustawione na maksymum ale mimo tego po włączeniu 3-5 wtyczek Wordpress nie pokazuje strony lub jest informacja o przeciążeniu pamięci serwera. 

 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

Próby usunięcia limitu przez wykorzystanie plików php.ini (memory_limit = 64M :wink:

lub poprzez

.htaccess

php_value upload_max_filesize 50M

php_value post_max_size 50M

php_value max_execution_time 500

php_value max_input_time 500

 

nie rozwiązują problemów. 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

Proszę o pomoc.


(hindus) #2

A to nie jest ustawione odgórnie przez providera, czyli w tym wypadku iq.pl? Czy masz serwer dedykowany?


(Wirrus) #3

Tak, mam serwer dedykowany. Mam ustawione wszystko na maksimum. Jest taki głupi problem z Wordpressem od jakiegoś czasu, że po włączeniu np. 3-5 wtyczek jest przeciążenie pamięci i dlatego właśnie szukam rozwiązania. Problem dotyczy Wordpressa a nie Joomli.


(system) #4

Jeżeli masz serwer dedykowany, to rozwiązania trzeba szukać po stronie konfiguracji PHP - może w ogóle nie masz włączonego rozpoznawania tego typu flag w htaccessie?


(Wirrus) #5

W pliku .htaccess dałem wpis żeby zlikwidować limit i niestety nic z tego. Korzystałem z tej instrukcji i testowałem. Żaden sposób nie zadziałał…


(system) #6

Spróbuj zmodyfikować plik php.ini.

Nie wiem jak wygląda konfiguracja Twojego serwera, niemniej najczęściej można go znaleźć gdzieś w /etc/php5/

 

Oczywiście po zmianie trzeba przeładować php/serwer www (to już w zależności od tego, jak masz to skonfigurowane).


(Wirrus) #7

Dałem wpis memory_limit = 64M ; do pliku php.ini. 

 

Go się wrzuca zawsze w katalogu głównym strony. W moim przypadku public_html. 

 

Nie działa…


(system) #8

A jest taka wartość faktycznie widoczna pod phpinfo?


(GioWDS) #9

Poczekaj, serwer dedykowany, plik php.ini w główny katalog strony.

Na 100% jesteś pewien?

Stwórz plik o nazwie debug.php o treści:

<?php phpinfo();

Wrzuć ten plik na serwer i wywołaj przez przeglądarkę, a wygenerowaną zawartość wstaw na forum.


(cinkibolek) #10

Zapytaj tych u których masz serwer. Nie wiem czemu tego nie zrobiłeś jeszcze, miałbyś info z pierwszej ręki i wszystko byś już wiedział dlaczego u nich php_value w .htaccess nie działa i czy mogą ci ten limit zwiększyć.


(YoJoe) #11

 

Brednie.

Załóż ticket w systemie pomocy IQ z prośbą o zwiększenie limitu pamięci dla skryptów php do co najmniej 128MB.

Wskazane 256MB.

 

Poza tym, przeczyść i zoptymalizuj tabele w bazie jeśli twój serwis www istnieje dłużej niż pół roku a często aktualizujesz jego zawartość.