Wstawianie funkcji w excelu


(Marek607) #1

Witam!

mam nastepujący problem:

Pisze sobie prymitywny program w excelu, ktory dodaje kilka liczb i wyświetla wynik.

Potrzebuje funcji:

1)W momencie gdy wynikiem jest liczba 0 nie wyświetla nic.

2) W przypadku gdy któreś z pól jest puste nie wykonuje równania

Przykład do p.2:

Jest funkcja:

=A3+B4-B5

I teraz jeżeli którekolwiek z tych pól jest puste tzn nie ma wstawionej liczby to kratka w której jest wstawione dodawanie ma być pusta.

Da sie coś takiego zrobić??

P.s. Czy są jakieś tutoriale lub ksiązki opisujące excela i zabawe w nim??


(goomish) #2

Dla podanych komórek użyj np. takiej, prymitywnej funkcji:

=JEŻELI(A3+B4-C5=0;"";JEŻELI(LUB(CZY.PUSTA(A3);CZY.PUSTA(B4);CZY.PUSTA(C5));"";A3+B4-C5))

Dla tych kilku komórek formuła choć prosta, sprawdza się dobrze. Gorzej jak będziesz chciał w ten sposób sprawdzić kilkadziesiąt, kilkaset komórek