Wybór użytkownika zamyka system


(Rodgrze) #1

Problem wygląda tak: kiedy wszystko się ładnie uruchomi pojawia się ekran logowania (choć go wyłączyłem kiedyś). Jest tam 2 użytkowników - ja i administrator (nie mogę się na niego zalogować, choć myślałem, że to ja jestem adminem). Kiedy uruchamiam swoje konto zaczyna wczytywać ustawienia osobiste, po czym rozpoczyna wylogowywanie i zamyka system.

Próbowałem poprzez tryb awaryjny zalogować się jako administrator - udało się, ale po wczytaniu ustawień laptop się wyłączył.

Wcześniej laptop wykonywał aktualizacje systemu (dużą (z 3 miesięcy)).

Nie mam w tej chwili dostępu do jakiejkolwiek płyty z windowsem xp. Mam SP 2.


(adam749) #2

A co się dzieje, gdy zalogujesz się na swój profil?


(Rodgrze) #3

Wyraźnie napisałem chyba :slight_smile:


(adam749) #4

To ma sie tyczyć zwykłego trybu, czy awaryjnego?

O awaryjnym tu pisałeś, ale nie napisałeś to o co prosiłem.


(Rodgrze) #5

:? To może w punktach:

  1. Tryb normalny:

a) administrator - nie mam uprawnień - nie wiem czemu

b) moje konto (profil) - wczytuje ustawienia osobiste, po czym rozpoczyna wylogowywanie i zamyka system.

  1. Tryb awaryjny:

a)administrator - wczytuje ustawienia osobiste, po czym rozpoczyna wylogowywanie i zamyka system.

b moje konto (profil) - analogicznie - wczytuje ustawienia osobiste, po czym rozpoczyna wylogowywanie i zamyka system.

Pulpit się nawet nie pokazuje (dla jasności).


(adam749) #6

To jak żaden tryb nie startuje to potrzebna by była płyta instalacyjna i zrobić parę operacji np: przywracanie systemu, naprawa systemu lub format w ostateczności, bo ja innego wyjścia nie widzę.

Żeby coś zdziałać to trzeba mieć dostęp do robienia jakiś modyfikacji, a jak nie można się zalogować to sie nie da tego zrobić.


(Rodgrze) #7

:slight_smile: O tym wiem dlatego napisałem, że nie mam tymczasowo płyty. Może ktoś miał podobny problem i jakoś to rozwiązał, przy użyciu płyty lub bez niej (choć wątpię).

:oops: Zapomniałem napisać o najważniejszej rzeczy, że nod32 v4 wykrył trojana w pliku ... userinit.exe w folderze system32. Przy każdym poprawnym uruchamianiu o tym wspominał (wyświetlał dymek), ale nie wykonywał żadnej akcji, w końcu poddał go kwarantannie (choć raczej usunął) i ... zaczęły się problemy. Tutaj jest link do tej samej sytuacji:

komputery.katalogi.pl/problem_z_logowaniem_po_usunieciu_userinit.exe_z_system32-t133469.html


(deFco247) #8

No to żeś wykrakał. :o

Plik userinit.exe służy właśnie logowaniu użytkownika, bez niego się dzieje to co u ciebie.

Jeśli chcesz rozwiązać ten problem, to niestety konieczna będzie Konsola Odzyskiwania (która de facto jest na płytce z XP),

lub w ostateczności jakiś Linux LiveCD i skopiowanie pliku userinit.exe z katalogu C:\WINDOWS\system32\dllcache do C:\WINDOWS\system32


(Rodgrze) #9

deFco247 - a co jeśli usunął wpis w rejestrze, wtedy samo skopiowanie tego pliku nie wystarczy.

Prawdopodobnie to ten klucz:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

i wartość ciągu "Userinit"="C:\WINDOWS\system32\userinit.exe,"

Jak mogę go dodać do rejestru?

Albo po prostu jak mogę to naprawić używając konsoli odzyskiwania?

Dzięki za pomoc.