Wydajność, dysk, użycie procesora na pulpicie


(Asty1988) #1

Witajcie. Chciałbym zapytać o najlepszy waszym zdaniem program do wyświetlania wydajności na pulpicie. Chodzi mi o wyświetlanie użytego dysku, użycia procesora, ramu, swapu, wykorzystała łącza itp. Wszystko w ładnych słupkach które można by spokojnie dopasował do wyglądu i dekoracji okien. Opcjonalnie możliwość wyłączania i włączania pokazywania poszczególnych opcji np pokazywanie tylko uzycia procesora, ale NIE pokazywanie ramu itp.


(matiit) #2

conky, adesklets, gdesklets (raczej dla GNOME), superkaramba (raczeej dla KDE) screenlets (wymagany beryl/compiz/c-f) i jeszcze pare by się znalazło.


(Asty1988) #3

a co polecasz najbardziej? :slight_smile:


(matiit) #4

conky

__ tyko z jakimś sensownym configiem


(Me) #5

jak wyżej.

conky :wink:


(El Presidento) #6

Moja Konfiguracja Conky:

#avoid flicker

double_buffer yes


#own window to run simultanious 2 or more conkys

own_window yes

own_window_transparent no

own_window_type normal

own_window_hints undecorate,sticky,skip_taskbar,skip_pager 


#borders

draw_borders no

border_margin 1


#shades

draw_shades no


#position

gap_x 1

gap_y 0

alignment top_left


#behaviour

update_interval 1


#colour

default_color 9f907d


#default_shade_color 000000

own_window_colour 090B0A


#font

use_xft yes

xftfont bauhaus:pixelsize=11


#to prevent window from moving

use_spacer no

minimum_size 1275


#mpd

mpd_host localhost

mpd_port 6600


TEXT

${time %d %B} ${color D7D3C5}${time %H:%M} | ${color} Up: ${color D7D3C5}${uptime_short} | ${color}Processes: ${color D7D3C5}$processes ${color}Running: ${color D7D3C5}$running_processes | ${color}Cpu: ${color D7D3C5}${cpu}% ${color}${cpugraph 10,80 AEA08E 9F907D} ${color D7D3C5} | ${color }Mem: ${color D7D3C5}$mem/$memmax - $memperc% ${color} ${membar 6,80}${color D7D3C5} | ${color }Net: ${color D7D3C5}${font}${downspeed eth0} Kb/s ${color} ${downspeedgraph eth0 10,80 AEA08E 9F907D} ${color D7D3C5} ${totaldown eth0} down | ${color D7D3C5}${upspeed eth0} Kb/s ${color} ${upspeedgraph eth0 10,80 AEA08E 9F907D} ${color 909090}${totalup eth0} up | 

${color }Root: ${color D7D3C5}${font}${fs_free /} / ${fs_size /} - ${fs_free_perc /}% | ${color} Home: ${color D7D3C5}${fs_free /home} / ${fs_size /home} - ${fs_free_perc /home}% |${color} Music: ${color D7D3C5}${fs_free /media/music} / ${fs_size /media/music} - ${fs_free_perc /media/music}% | ${color} Weather: ${color D7D3C5} ${execi 1800 weatherget -f ~/.conkyweatherrc --station-id=PLXX0012 --metric } | ${color} Mpd: ${color D7D3C5}${font}${mpd_smart}

Konfiguracja w pliku .conkyrc oraz plik .conkyweatherrc niezbędny do wyświetlania informacji o pogodzie:

http://www.comendante.ovh.org/Conky.rar

Oczywiście w pliku konfiguracyjnym musisz pozmieniać lokalizacje dla partycji. :!:

Aby zmienić lokalizacje dla miasta ( Pogoda ):

W miejsce kodu, wpisujesz kod dla swojego miasta, aby go uzyskać przechodzisz na stronę i podajesz nazwę miasta:

W miejsce Wrocław wpisujesz nazwę twojego miasta :!:

Zapomniałem tak on się prezentuje:

376b2555b56b9fa7m.png

221ba4dff4577effm.png

45cc6882e5d8d39am.png


(Asty1988) #7

juz sobie to postawiłem, i ładnie skonfigurowałem - musze przyznać, ze nadspodziewanie proste, przy cyzm mam pewien problem... mianowicie.. conky mi mruga. czytałem już o tym, dodałem wpis w xorgu, wyłączyłem double_buffer ale.. nadal miga :confused: innym to pomagało, mnie nie. włączenie "własnego okna" mnie nie satysfakcjonuje, bo po 1 zasłania cześć pulpitu, po 2 brzydko wygląda.


(El Presidento) #8
/etc/X11/xorg.conf

Dodajesz :

UWAGA! PO I PRZED LOAD MUSI BYĆ TABULATOR A NIE SPACJA! aby mieć całkowitą pewność, że wszystko zrobimy dobrze ( i nie uszkodzimy naszego xservera ) kopiujemy CAŁĄ linijke np tą Load "dri" ( oczywiście w pliku naszego xservera - a nie tu ) i wklejamy niżej - zmieniamy tylko w tej nowo wklejonej linijce dri na dbe.


(Asty1988) #9

ehhh :] mówiłem że dodałem to już :slight_smile: Nic to nie dało :slight_smile:


(El Presidento) #10

Zrestartowałeś xserver ?


(Asty1988) #11

oczywiście :slight_smile:

obecnie wstawiłem inny config, i wszystko chodzi :confused: mimo że wiele się nie różny. Kolorami, i informacjami wyświetlanymi.. dziwne. w każdym bądź razie serdeczne dzięki za pomoc :slight_smile:


(Adrian Nawrocki) #12

http://www.linux.pl/?id=foto&kategoria=0&results=206 to cię zainteresuje. Masz wszystko opisane co jest użyte.