Wysyłanie wiadomości email ze strony


(Qazwer8) #1

Witam, zrobiłem do mojej rejestracji Wysyłanie wiadomości na dany email.mam tylko pewien problem,jeżeli chcę powiększyć czcionkę,zmienić kolor lub dodać link do wiadomości , to cała rejestracja pada:(

echo 'Zostałeś Zarejestrowany !';

$temat="Rejestracja w serwisie.";

$tresc="Witaj $login jakis tekst jakis link ..";

$od = "From: mojastrona.pl ";

mail($email, $temat, $tresc, $od);

Czy da się w jakiś sposób dodać linki,powiększyć czcionkę lub zmienić kolor tekstu?


(Grzesie K) #2

oczywiście, że się da. Wystarczy wysłać tą wiadomość jako kod html.


(Qazwer8) #3

No ale własnie nie wiem jak to zrobić , próbowałem we wiadomości

wialomosc 
Link[/code]
 no ale rejestracja wtedy padała :(

-- [b]Dodane 30.05.2010 (N) 15:17[/b] --

Wtedy pokazuje mi się :

[code]Parse error: syntax error, unexpected T_STRING in/home/sites/m/mo/moj/mojastrona.pl/reje04/rejestr_do.php on line 56


(matiit) #4

Musisz escape'ować znaki "


(Qazwer8) #5

yyy,nie zabardzo kumam ,można troszkę jaśniej ?


(matiit) #6
$tresc = "cos tam Aaa";

//lub

$tresc = 'cos tam Aaa';

[/code]

(Qazwer8) #7

Dzięki bardzo, teraz działa:)

-- Dodane 30.05.2010 (N) 17:56 --

Jeszcze jedno pytanie,jezeli chce dodać np. 3 linki to wtedy mi się strona psuje:( , jak to mogę zrobić ?

Parse error: syntax error, unexpected '<' in /home/sites/s/st/srt/strona.pl/reje04/rejestr_do.php on line 60

(matiit) #8

pokaż ten plik, wrzuć na wklej.org


(Qazwer8) #9

http://wklej.org/id/342590/ :slight_smile:


(matiit) #10
$tresc = "

(Qazwer8) #11

Wydaje mi się że powinno działać no ale wyskakuje:

Parse error: syntax error, unexpected T_STRING in /home/sites/k/ki/kis/kisiell9-ba.za.pl/reje04/rejestr_do.php on line 61

:frowning:


(matiit) #12
$tresc = "

(Jacek705) #13

moja propozycja to zrobić w pojedynczych cudzysłowach i zrobić łączenie ciągów - wygląda bardziej przejrzyście:

$tresc = '

Przy pojedynczych cydzysłowach "w środku" mogą być dowolne znaki/znaczniki/zmienne i php nie będzie ich przepisywało


(Qazwer8) #14

dzięki,teraz działa :slight_smile: