Wyszukująca formuła w Excelu


(Michalmatma32) #1

Witam.

Chcę zrobić coś podobnego, jak tutaj http://www.elektroda.pl/rtvforum/topic1899501.html. Pierwszy zaproponowany w tym temacie sposób chciałem przerobić do swojej tabeli. Nie wiem dlaczego po zastąpieniu odwołań do odpowiednich komórek własnymi, formuła nie działa poprawnie.

Tabela z wyszukiwaniem (przerabiana): https://drive.google.com/file/d/0B6fYjySnlmwHUHVfZVl6WTBYLVE/view?usp=sharing

Moja tabela: https://drive.google.com/file/d/0B6fYjySnlmwHR3c1djBjaVdyZ2c/view?usp=sharing (przerobiona formuła znajduje się w kolumnie L)


(Dimatheus) #2

Hej,

A co dokładnie ma zwracać ta formuła? Na pierwszy rzut oka widać, że brakuje argumentu dla formuły czy.błąd.

=JEŻELI(CZY.BŁĄD(SZUKAJ.TEKST($O$3;Sheet1!$B7;1));"";MAX($L$6:L7)+1)

Według mnie powinno być na przykład tak:

=JEŻELI(CZY.BŁĄD(SZUKAJ.TEKST($O$3;Sheet1!$B7;1))=PRAWDA;"";MAX($L$6:L7)+1)

Pozdrawiam,

Dimatheus


(Michalmatma32) #3

Funkcja ma numerować kolejne wiersze, w których kod zawiera wyszukiwany kawełek tekstu.

grafika: https://drive.google.com/file/d/0B6fYjySnlmwHTUZUU3l2YWVIdXc/view?usp=sharing

Następnie na ich podstawie są wypisywane w tabelce po prawej. Nie wiem czy to jest najprostsze rozwiązanie, ale w orginalnym pliku wszystko działa.


(Dimatheus) #4

Hej,

A czy w kolumnie, po której będziemy szukać tekstu, będą wprost pojawiać się szukane ciągi znaków, czy mogą one znajdować się wewnątrz tekstu. Czyli dorzucając przykład, będziemy wyszukiwać frazę xzy, to w komórkach będzie się pojawiać wartość xyz, czy możliwe jest też pojawienie się ciągu agdsxyzsds? Skąd pytanie? Obrazek nie do kocha to prezyzuje. W kolumnie A są wartości abc, w wyszukiwaniu tylko bc, ale w kolejnym sumowaniu znowu abc.

Pozdrawiam,

Dimatheus


(Michalmatma32) #5

Szukany ciąg nie musi pojawiać się wprost, ale zawsze będzie na początku ciągu. Np. szukamy abc, wyskakują abcde, abc, abcxy, ale nie xabc.


(Dimatheus) #6

Hej,

Poprawna formuła powinna wyglądać tak:

=JEŻELI(CZY.BŁĄD(SZUKAJ.TEKST($O$3;$B7;1))=PRAWDA;"";MAX($L$6:L6)+1)

Nie działała poprawnie, bo tworzyło się odwołanie cykliczne w wartości MAX - brałeś bowiem do zakresu funkcji także bieżącą komórkę.

Pozdrawiam,

Dimatheus


(Michalmatma32) #7

Wielkie dzięki, działa! Taka drobnostka, a tyle problemów.