Xampp problem z MySql oraz inne


(shinakol) #1

Witam serdecznie, używałem wcześniej programu Xampp na Win XP - wszystko dobrze działało.

Teraz posiadam Windows 7 32bit i po poprawnym zainstalowaniu oprogramowania Xampp pojawiły się problemy, - mianowicie :

Oto Screen z zakładki "Stan" gdzie teoretycznie wszystko powinno być ok, a w praktyce nie jest nic w porządku.

clipboard01asdasdasdasd.gif

asdvb.gif

Nie wiem czy to coś pomoże ale przy próbie wejścia do bazy danych(phpMyAdmin) wyskakuje błąd : #2003 - Can't connect to MySQL server on 'localhost' (10061)

Aby jeszcze bardziej zobrazować wam sytuację dodam coś na temat portów :

port.gif

Screen jednak wydaje mi się że sugeruje iż wszystko jest w porządku, więc to nie wina zajętych portów. Czytałem że może to być wina Firewalla, lecz ja takowego nie posiadam. Posiadam za to Avast internet security lecz wyłączałem go i to też nie dało żadnego rezultatu.

Dodam także, że ten problem nie jest tylko na Xampp'ie. Instalowałem już inne programy, wamp, vertrigo serv, webserv a także samodzielnie instalowałem i konfigurowałem oddzielne pakiety apache, mysql oraz php - bez skutku.

Proszę o pomoc. // mam nadzieje że to nie wina systemu operacyjnego. ps. - wersja xampp najnowsza


(skandyn) #2

Jeśli masz zainstalowany komunikator Skype to go najpierw wyłącz, a następnie uruchom serwer Xampp.

Pozdrawiam.


(shinakol) #3

Wiem o tym że Skype może kolidować z Xampp'em, lecz nie posiadam Skype'a i nigdy go nie instalowałem na 7. Poza tym, jak widać na screenie port jest zajęty tylko przez Xampp'a

Nadal proszę o pomoc. [-o<


(ra-v) #4

Systemowy firewall blokuje. Sprawdź usługi i udostępnianie usług i portów


(shinakol) #5

W usługach nie wykazało nic związanego z mysql. Szukałem także w innych miejscach pokrewnych w panelu sterowania lecz także wskazuje wszystko na to że jest ok.

Jeśli ktoś ma jeszcze jakieś sugestię to będę wdzięczny.


(inzaghi89) #6

Dlatego na W7 korzystam z wersji bez instalatora (po instalacji też mi nie działało). Spróbuj jednak setup / 2 (relocate xampp).