XFCE 4.10 w Debianie Wheezy?


(Raf20076) #1

Używam środowiska XFCE 4.10 na Debianie Wheezy. Zainstalowałem te środowisko tą metodą z tąd http://unix.stackexchange.com/questions/150979/how-install-xfce-4-10-from-backports-repository-in-debian

 

 

W terminalu edytowałem plik sources.list

nano /etc/apt/sources.list

i dodałem te repozytorium

deb http://main.mepis-deb.org/mepiscr/xfce/ xfce-4.10 main

Następnie w terminalu dałem

gpg --keyserver pgp.mit.edu --recv-keys 81E77EAF14E225A0
gpg --armor --export 14E225A0 | apt-key add -

apt-get update

apt-get -t xfce-4.10 install xfce4

W ten sposób zainstalowałem xfce 4.10 na Debianie Wheezy (stable)

Moje pytanie czy ta metoda nie wysypie mi Debiana, (na razie wszystko jest OK). Wiem że xfce 4.10 nie jest dostępne w repozytorium stable. Czy jest może inna metoda zainstalowania xfce 4.10 na Wheezy. Druga sprawa wydaje się że xfce nie jest już rozwijana. Ostatnia aktualizacja pochodzi chyba z 2012 roku.


(jakubgross) #2

XFCE jest rozwijane. 

Komenda nie powinna wysypać Debiana, ale lepiej zainstaluj sobie xfce core (podstawa), jeżeli jeszcze jest. 


(Raf20076) #3

Wcześniej miałem zainstalowane xfce 4.8 więc core chyba jest, chociaż nie wiem czy core wogóle istnieje bo żeby zainstalować core to daje się polecenie

apt-get install xfce

Ponadto doinstalowałem pluginy do xfce bo ich nie było wskaźnik baterii i daty

apt-get install xfce4-datetime-plugin

apt-get install xfce4-battery-plugin

Generalnie jeśli chcemy zainstalować całe środowisko xfce z desktopem, menadżerem plików to powinniśmy dać chyba,

apt-get install xfce4 thunar-archive-plugin xfprint4 xfce4-terminal 
desktop-base xscreensaver xfwm4-themes gdm3

gdyż same

apt-get install xfce

zainstaluje nam tylko core i nie będziemy mogli korzystać normalnie z tego środowiska bez desktopu, menadżera etc?


(jakubgross) #4

To w czym teraz problem? 

Debian na pewno Ci się nie wysypie. 


(Raf20076) #5

Jak widać zrobiłem trik, że nie korzystam z repozytorium Debiana tylko z http://main.mepis-deb.org/ czyli repozytoriów systemu operacyjnego Mepis (http://mepis.org/) opartego na Debianie stable, czyli nie są to ryginale repozytoria Debiana. Więc nie byłem pewny czy te repozytoria są kompatybilne z Debianem, ale wygląda że są.


(jakubgross) #6

Tak, są. System ten bazuję ma Debianie Stable, więc praktycznie musi działać. 

Sam na Debianie używam repozytoriów z Minta. ponieważ w zwykłych nie ma wielu rzeczy. Np. ngroka. :open_mouth:


(roobal) #7

Jeśli w backportach jest nowa wersja, to samo apt-get upgrade nie pomoże. Musisz wskazać repozytorium.

apt-get install -t wheezy-backports xfce

Debian się nie wysypie, backporty to nie Sid, to po prostu nowsze pakiety przeportowane na Debiana stable.


(marcin82) #8

Raf20076

 

W żadnym linuksie nie poleca się używania repozytoriów spoza dystrybucji. Nawet jeśli coś jest oparte na Debianie, nie znaczy to, że nie pojawią się potem jakieś niezgodności wersji bibliotek itd.

 

 

 

jakubgross

 

 

Tylko przypadkiem tego innym nie polecaj …


(roobal) #9

Systemem Mepis opiekuje się raczej ktoś inny, niż deweloperzy Debiana, więc niekoniecznie musi to działać.


(jakubgross) #10

Wiem, ale u siebię testuję. Nie poelcam tego innym użytkownikom. To, że u mnie działa nie znaczy, że u nich też.

Najlepiej samemu sprawdzić czy działa.

PS. Nie jest dostępne w Stable, ale jest w UnStable, lepiej dodać te repozytorium. :wink:


(Raf20076) #11

Więc nie wiadomo kto się opiekuje Mepis, więc odinstaluje xfce całkowicie, usunę repozytoria Mepis, dodam repozytorium z Debian unstable (sid) gdyż xfce 4.10 nie jest dotępne w backports lub zostanę przy xfce 4.8  Dopiszę dalej co zrobiłem.

 

Usuwam całkowicie xfce typ poleceniem

sudo aptitude purge xfce4

Jednak nie usunęło całkowicie xfce

Znalazłem takie polecenie , jest chyba lepsze?

sudo aptitude -P remove ~nxfce4

Dostałem komunikat

Usunięcie następujących pakietów:                     
1)      exo-utils                                           
2)      libexo-1-0                                          
3)      libgarcon-1-0                                       
4)      libthunarx-2-0                                      
5)      libxfcegui4-4                                       
6)      libxfconf-0-2                                       
7)      orage                                               
8)      thunar                                              
9)      thunar-archive-plugin                               
10)     thunar-volman                                       
11)     xfburn                                              
12)     xfconf                                              
13)     xfdesktop4                                          
14)     xfprint4                                            
15)     xfwm4                                               
16)     xfwm4-themes   
 Pozostawienie następujących problemów z zależnościami:
17)     thunar poleca xfce4-panel (>= 4.9.2)                
18)     thunar poleca xfce4-panel (< 4.11)   

Zobaczę co dalej jest jeszcze zainstalowane, znalazłem taką komendę

dpkg --get-selections | grep xfce

Wynik

gtk2-engines-xfce                install
libxfce4ui-1-0                    deinstall
libxfce4util4                    deinstall
libxfce4util6                    deinstall
libxfcegui4-4                    deinstall
xfce-keyboard-shortcuts                install
xfce4-appfinder                    deinstall
xfce4-mixer                    deinstall
xfce4-panel                    deinstall
xfce4-session                    deinstall
xfce4-settings                    deinstall
xfce4-terminal                    deinstall
xfce4-utils                    deinstall
xfce4-volumed                    deinstall

Czyli muszę jeszcze odninstalować xfce-keyboard-shortcuts , gtk2-engines-xfce co do gtk2 engines nie jestem pewien jednak odinstalowałem te dwie pozycję.

 

Potem daje

apt-get update

Następnie czyszcze system

apt-get autoclean

Teraz zniknąła mi z menu sesja, czyli możliwość wylogowania się, ale doszłem że usunąłem xfce4-session, na szczęście na pasku u góry ekranu jest przycisk otwartych drzwi, więc się mogłem wylogować na niego klikając.