Youtube filmy w 1080p 60fps dziwnie klatkują


(Alex1331) #1

Witam. Gdy włączam film na Youtube który jest w jakości 1080p 60fps i wybieram jakość 1080p to film odtwarza się płynnie obraz i dźwięk nie zacina się ale obraz tak jakby klatkuje. Filmy w 1080p ale bez 60fps odtwarzają się poprawnie. Tu daję link do wideo na którym widać ten problem https://youtu.be/iG2YrOO9clQ nagrywałem telefonem gdyż programy do nagrywania obciążają procesor i by nie było widać tego problemu jaki jest naprawdę. Co może być przyczyną tego błędu? Słaby komputer czy zbyt wolne łącze? Moja specyfikacja: Płyta główna Asus P5GC-MX/GBL Procesor Intel Dual Core E5200 2.50 GHz 4GB Ram Karta graficzna AMD Radeon hd 5770 1GB DDR5 Windows 7 64Bit Internet 5 Mbps


#2

Cześć,
Gdzieś wyczytałem kiedyś na internecie, że głównie zależy od monitora, jaki masz. Nie każdy monitor - głównie starsze monitory, nie pozwalają na płynne odtwarzanie filmu, we wspomnianej jakości.


(Alex1331) #3

@paweeloss Monitor Mam Dell 2208WFPt 22 cale i rozdzielczość mam ustawioną na 1680x1050 I podłączony jest kablem DVI-HDMI


#4

Aby film był płynny w 1080p60 potrzebujesz monitora z FHD 1920x1080.


(Alex1331) #5

Ok dzięki za pomoc :smiley:


(stan55) #6

Ten film jest źle nagrany, puść w rozdzielczości 240 p, też klatkuje


(Alex1331) #7

Puściłem w 240p i u mnie normalnie bez klatek się odtwarza


(daras28-82) #8

Bzdura.

Sprawdź na tym: https://www.youtube.com/watch?v=iNJdPyoqt8U
Mam w domu kilka monitorów od 1024x768 do 1080, na każdym idzie płynnie.
Kilka komputerów o różnej specyfikacji.
Core 2 duo e6750, 4GB, Radeon 3450 - idzie płynnie do 1080 niezależnie od monitora.


(Alex1331) #9

Odtworzyłem i ten film normalnie się odtwarza. O co tu może chodzić? Dlaczego niektóre filmy chodzą normalnie a nie które klatkują?


(daras28-82) #10

Niestety tak już jest, niektóre w fatalnej jakości nie chcą normalnie działać.


#11

W takim razie, bzdurę na internecie wyczytałem. Więc czego to może być przyczyna? Gamepleye też klatkują w 1080p60.


(daras28-82) #12

Zależy od konkretnego materiału, jedne filmiki tną inne nie.
Zależy od łącza, miałem neostradę 10Mb i powyżej 720 wszystko prawie cięło, teraz mam Vectrę 150Mb i nie tnie nic nawet jak 4k puszczę.
Może to wina serwerów YT i ich aktualnej okupacji.
Co ciekawe na telefonie bez problemu łyka 1080 nawet gdy aktualna prędkość w testach nie chce wyskoczyć powyżej 4Mb.


(stan55) #13

Ten filmik idzie bez problemu nic nie klatkuje, nawet na 4K


(Morfik777) #14

@Alex1331
Dorzucę może coś od siebie. Ten klip, który nagrałeś fonem jest ok. Ja go oglądam płynnie bez żadnego “klatkowania”, ani tych dodatkowych efektów, towarzyszących opróżnianiu bufora. Na dole widać lekko przysłonięty tytuł. Porównaj teraz moje statystyki:

Do oglądania materiału 1080p w 60 klatkach/sek powinieneś mieć dobrze wysycone i stabilne łącze minimum 6 Mb/s downstream’u. Zwróć też uwagę na kodek. Teoretycznie jest to możliwe na łączu, które posiadasz. Sam jednak zobacz, że stream ciągnie Ci z szybkością poniżej 5 Mb/s - to za mało żeby oglądać płynnie taki materiał, patrz też ile masz utraconych klatek. Brakuje oddechu nawet na pakiety kontrolne i inne. Jedyne rozwiązanie, to ściągnięcie klipu i obejrzenie go offline. Monitor i hardware masz wystarczająco dobry.

edit: Nie wiem tylko czy daje się czymkolwiek ściągnąć klipy w 60 fps-ach z yt. To akurat nie było mi nigdy potrzebne.

edit #2: Jest jeszcze jedno wytłumaczenie a propos klipu, który podlinkowałeś. Po ściągnięciu i przeanalizowaniu danych okazuje się, że ktoś tu eksperymentuje sobie z HFR (High Frame Rate), używając “Variable rate mode”. Konkretnie - “Frame rate mode : Variable”.

Frame rate : 59.940 (59940/1000) fps
Minimum frame rate : 59.920 fps
Maximum frame rate : 90 000.000 fps

I raczej tutaj tkwi przyczyna tych przycięć, bo u siebie też lekkie zauważam.


(Alex1331) #15

Ok czyli to może być wina słabego łącza. A co do tego eksperymentu z HFR to identyczne przycięcia mam na tym filmie https://www.youtube.com/watch?v=vo06NKW2Mek&t=67s Ten chłopak raczej nie eksperymentuje z HFR.


(Morfik777) #16

Tu mam trochę więcej “dropniętych” ramek, ale ogląda się normalnie, przycina minimalnie od czasu do czasu. Ściąga się w 60 fps, nie jest to materiał interpolowany, wymaga szybszego streamingu.

Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.2
Format settings, CABAC : Yes
Format settings, ReFrames : 3 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 18mn 35s
Duration_FirstFrame : -17ms
Bit rate : 3 648 Kbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Frame rate : 60.000 fps
Minimum frame rate : 60.000 fps
Maximum frame rate : 60.080 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.029
Stream size : 485 MiB (96%)
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709