Z każdym uruchomieniem Linuxa, godzina cofa się do tyłu


(Giiixxxx6) #1

Witam,

Może nie jest to jakiś irytujący problem, bo żeby ustawić ponownie dobrą datę wystarczą 3 kliknięcia, ale jednak jestem ciekaw dlaczego tak się dzieje.
Z każdym uruchomieniem Linuxa (w tym przypadku Deepin), godzina w Windwosie cofa się do tyłu - na ten przykład teraz mam 12:08, podczas gdy tak naprawdę mamy godzinę do przodu (tak, cofa zawsze o pełną godzinę).


(D35CART35) #2

Dlatego że posiadasz dualboot.


(qbpm) #3

Linux ustawia sprzętowy zegar zgodnie z czasem UTC, a Windows zgodnie z czasem lokalnym. (Aktualnie UTC+1). U siebie przestawiłem to w Windows jakimś kluczem rejestru.


(D35CART35) #4

A jakim i jak to ustawić?


(Giiixxxx6) #5

Dlatego że posiadam dualboot? :smiley:

To ciekawe, bo Mint nic takiego na dual boocie nie robił.


(qbpm) #6

Google popsute?

Using regedit, add a DWORD value with hexadecimal value 1 to the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal

Więcej:
https://wiki.archlinux.org/index.php/time#UTC_in_Windows


(Giiixxxx6) #7

To wszystko jasne, dzięki - nie będę w rejestrze grzebał, bo to żaden problem w sumie, ale dobrze wiedzieć na przyszłość :wink:


(asus4ever) #8

Wydaje mi się, że czasami pomaga ustawienie odpowiedniej strefy czasowej. System wie wtedy, o ile godzin ma przestawić zegar, aby podawał czas lokalny.


(muminek77) #9

timedatectl set-local-rtc 1


(osykosy) #10

I tak ma być - nie może cofać się DO PRZODU !!!


(Giiixxxx6) #11

Super śmieszne, aż wszedłem na zewnątrz żeby się pośmiać :wink:


(krystian3w) #12

A i owszem problem, np. na tym forum miałem kiedyś tak godzinę ustawioną do tyłu to były cyrki z zapisaniem czy edycją odpowiedzi, najciekawsze było to że historia modyfikacji odpowiedzi zapisywała się co minutę a nie standardowo co pięć / sześć minut.