Zapisanie parametrów(?) modułów dźwięku Linux Mint 17


(system) #1

Witam, jakiś czas użeram się z szumami na słuchawkach, których nie ma kiedy włączony jest program PulseAudio Volume Control. Zauważyłem, że po wpisaniu komendy " lsmod | grep snd" i wyłączonym pavucontrol wyrzuca mi następujące parametry:

snd_hda_codec_via      32006  1 
snd_hda_codec_generic    70087  1 snd_hda_codec_via
snd_hda_intel          30783  3 
snd_hda_controller     32234  1 snd_hda_intel
snd_hda_codec         145035  4 snd_hda_codec_via,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              17709  1 snd_hda_codec
snd_pcm               105052  3 snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_seq_midi           13564  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            31197  1 snd_seq_midi
snd_seq                63540  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              30118  2 snd_pcm,snd_seq
snd                    84025  16 snd_hwdep,snd_timer,snd_hda_codec_via,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              15091  2 snd,snd_hda_codec

 

Przy włączonym pavucontrol:

snd_hda_codec_via      32006  1 
snd_hda_codec_generic    70087  1 snd_hda_codec_via
snd_hda_intel          30783  6 
snd_hda_controller     32234  1 snd_hda_intel
snd_hda_codec         145035  4 snd_hda_codec_via,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              17709  1 snd_hda_codec
snd_pcm               105052  5 snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_seq_midi           13564  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            31197  1 snd_seq_midi
snd_seq                63540  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              30118  2 snd_pcm,snd_seq
snd                    84025  20 snd_hwdep,snd_timer,snd_hda_codec_via,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              15091  2 snd,snd_hda_codec

 

Czy da się te parametry przypisać ręcznie? Jak już pisałem, przy włączonym pavucontrol nie mam żadnych szumów, a być może zmiana lub zapamiętanie parametrów na te ustawione przez pavucontrol by pomogły.


(MrQ) #2

To laptop czy komp stacjonarny?


(system) #3

Laptop. Próbowałem już wszystkich możliwości, suwaki w alsamixer, wyciszanie mikrofonów, instalacja nowego kernela i jakieś patche, które nie pasowały do mojej dźwiękówki. Jedynie po włączeniu pavucontrol szum znika i tak jak wyżej napisałem, parametry przy włączonym programie są inne niż przy wyłączonym.


(nintyfan) #4

Wykonałem diff-a na obu wynikach lsmod. Oba wyniki nie różnią pod względem załadowanymi modułami.


(system) #5

Nie za bardzo rozumiem co to jest wykonanie diff.


(nintyfan) #6

Diff wyświetla różnice dwóch plików.


(system) #7

Czyli nie da się wymusić zapisu tych ustawień z pavucontrol?


(MrQ) #8

Jesteś pewien że w konsolowym alsamixer zmieniłeś kartę na HDA Intel i tam w pozycji mikrofonu wciąsnąłęś “M” (mute)? W opcjach odtwarzania oczywiście.


(system) #9

Na 100%, zainstalowałem teraz Manjaro, tutaj nawet z włączonym pavucontrol jest szum i jakby cichy dźwięk zapętlonego dźwięku. Szum dopiero włącza się po uruchomieniu muzyki i tak jest w każdej dystrybucji. 

 

Edycja: Wywaliłem w Manjaro pulseaudio i ta cisza jest wspaniała. Szkoda, że większość środowisk korzysta z tego badziewia jakim jest PulseAudio. W starszych dystrybucjach z Pulse 1.1 wszystko chodziło elegancko. Nowe Pulsy 4 i 5 mają ten błąd.